Mac Script Fail - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Mac Script Fail

  • 5 Replies
  • 3017 Views
Mac Script Fail
« on: 18 / February / 2009, 10:03:00 »
Advertisements
Everytime I run the mac script it fails.  I load my unlocked SD card in the reader.  Open the script, choose the SD card, choose format (or petition I've tried both).  Then a little bit of time passes and a message comes up that says to unlock my SD cardto install CHDK.  Could not find the disk /dev/dis;  Number 1.  Any insight?

*

Offline barret

  • ***
  • 125
  • S3 & a550
Re: Mac Script Fail
« Reply #1 on: 18 / February / 2009, 10:34:54 »
maybe this problem is caused by incompatible card reader?
try different reader or different computer.

*

Offline zeno

  • *****
  • 891
Re: Mac Script Fail
« Reply #2 on: 18 / February / 2009, 14:25:28 »
I preume the script you're talking about is the one described here:
http://chdk.wikia.com/wiki/FAQ/Mac#Scripted_Installation_of_CHDK

I think the problem is with the disk identifier - I suggest you try the manual approach that's described just below. It worked for me.
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: Mac Script Fail
« Reply #3 on: 22 / February / 2009, 20:58:23 »
Hey Medic0506
I just installed using the applescript a few days ago. I fixed the script by finding this line
"do shell script "unzip ~/Desktop/a590-101b-0.9.3-688-full.zip -d ~/CHDK"
and replacing the actual file name and path with the autobuild zip I was using. I think that the script asks you to find the path, and then uses a hard coded path instead. The coder must have not spotted it because the hard coded path was the same as the one he was selecting.

I simply moved my zip file to the desktop, copied and pasted the name of the zip into the applescript, and ran it.

Good luck!


Re: Mac Script Fail
« Reply #4 on: 29 / March / 2009, 02:32:57 »
I also had the script fail for me for my SX10 when the script got to the point where it was supposed to copy the files to the card. Since the preparation was all complete, to finish the job I just copied the files into their proper partition using drag & drop in the Finder.

While examining the script, I also noticed that it specified the file "PS.FIR", but the DryOS cameras all use the filename "PS.FI2".
« Last Edit: 29 / March / 2009, 12:43:56 by Reddog99 »

*

Offline an0n

  • ***
  • 152
Re: Mac Script Fail
« Reply #5 on: 29 / March / 2009, 10:10:18 »
Even though I had to copy files on, having it partition and make card bootable was pretty good! saved a lot of time. Thanks to writer, hope you get the last part fixed, will be great for Mac users.

Edit: this script was written for OSX 10.5, I'm using 10.4, may make a difference.
« Last Edit: 29 / March / 2009, 10:14:27 by an0n »
A720IS.

 

Related Topics