SCRIPT ult_intrvl.bas - WORKING on SD850!!! (but cannot turn it off....!!!) - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

SCRIPT ult_intrvl.bas - WORKING on SD850!!! (but cannot turn it off....!!!)

  • 6 Replies
  • 2450 Views
*

Offline ac17

  • *
  • 20
Advertisements
Hi,
I know the page said it hadnt been tested, but I loaded ult_intrvl.bas on my SD850 and used it with sucess. It worked like a charm (except you need to set number of shots to zero if you want to use the Endless feature).

However, I could not turn iit off. Everytime I loaded (manually) CHDK, the script would start up again and I could not access the menu via the FUNC. SET button. IT was as if the camera was locked.

NOTE - When I used the script, my battery died and I replaced it to continue wha I was working on. So I dont know if this is a bug or whether I may have corrupted CHDK or the Script file when the battery died on my camera.

(Obviously I solved the problem with a fresh copy of CHDK).

Im just wondering if anyone else has had the same problem, or whether the problem is at my end with my lack of understanding regarding how to deactive scripts (however, remembering that I could not access the CHDK menu).


*

Offline ac17

  • *
  • 20
ED - I just reloaded the script on a fresh CHDK install and ran it.

I can now acess the menu, when the script is not running (which wasnt available to me previously).

However I still do not know how to turn it off.

Can anyone help me?

Cheers.
« Last Edit: 20 / February / 2009, 07:52:36 by ac17 »

*

Offline ac17

  • *
  • 20
So - can anyone please tell me how to disable a script?

*

Offline whim

  • ******
  • 2040
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Scripting Parameters -> Script autostart  [ Off ]

wim

note: your selected script will still start if you activate <Alt> in shooting mode and press the shutter ...
select default.bas (which is empty since 8-1-09) to reduce the impact of this.
« Last Edit: 20 / February / 2009, 08:35:47 by whim »


*

Offline ac17

  • *
  • 20
Hi whim - when I do that, now when in Alt and taking a pic, it says `this is a defult script. Scripts run when shutter is pressed...`

How do I get back to being able to just take a pic in alt (chdk) mode?

*

Offline reyalp

  • ******
  • 13059
You cannot take a picture in alt mode. In alt mode, pressing the shutter button starts a script. That's all it ever does.

edit:
alt mode isn't "CHDK mode": CHDK is running whether or not you are in alt mode.
Don't forget what the H stands for.

*

Offline ac17

  • *
  • 20
oh - thanks.

thank goodness i posted this in the newbie section (blush)

I thought chdk was only ever running in the alt mode !

Ah well - at least we can now add the SD850 to the list of cameras supporting this script !

thanks again

 

Related Topics