supplierdeeply

Eos 400d ( Rebel XTI )

  • 1869 Replies
  • 487530 Views
*

Offline thaibv

  • **
  • 57
  • Canon 400d: Spot, ISO 3200 and more
Re: Eos 400d ( Rebel XTI )
« Reply #120 on: 05 / August / 2009, 22:07:09 »
Advertisements
Hi,
I've just uploaded new files here
Bin: http://depositfiles.com/files/7kp2livfw
Code: http://depositfiles.com/files/g83nmqofy

Set Video System to NTSC/PAL to turn Auto AvComp on/off respectively. No anoying beep sound  :D
« Last Edit: 05 / August / 2009, 22:18:49 by thaibv »
999 Members and 9999 Guests are viewing this board.

*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #121 on: 06 / August / 2009, 11:04:51 »
Great! No annoying beep sound.

BTW: You could use every function in print-menu. Noone needs this menu.... ;)

*

Offline thaibv

  • **
  • 57
  • Canon 400d: Spot, ISO 3200 and more
Re: Eos 400d ( Rebel XTI )
« Reply #122 on: 09 / August / 2009, 05:05:54 »
Hello,

Finaly it is completed. Here are my lastest .bin and code files for 400d.
bin: http://depositfiles.com/files/hb6wg7y00
code: http://depositfiles.com/files/tn7h7n13n

Now you have Spot meter, full ISO range from 16 to 3200, auto Av compensation for low ISO (16 to 80) and especially it can display ISO value, Spot meter logo on screen.

Although it slow your 400d a little and you could not take a pic at 0.2 sec after turn on as original. However what you gain are much better.

One thing I worry about is my 400d's card door and card socket  :D(open/close, insert/remove a thousand times for test).   
999 Members and 9999 Guests are viewing this board.

Re: Eos 400d ( Rebel XTI )
« Reply #123 on: 09 / August / 2009, 09:55:51 »
Good work!
The new release works fine. :D


*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #124 on: 09 / August / 2009, 12:13:53 »
Yes. Great work. Spot meter logo is working fine (a little bit small, but okay!)!

Very good! :)

Re: Eos 400d ( Rebel XTI )
« Reply #125 on: 09 / August / 2009, 13:52:16 »
Good work!
The new release works fine.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Eos 400d ( Rebel XTI )
« Reply #126 on: 09 / August / 2009, 19:29:18 »
hey thaibv you should consider checking in your code in a public subversion repository, like we did with chdk. doesnt cost anything but its very useful. and it's not even difficult, even a child can do it. but it has a lot of advantages.
great stuff ur doing by the way. one day i will try it on my roommates 400d.

*

Offline whoever

  • ****
  • 280
  • IXUS950
Re: Eos 400d ( Rebel XTI )
« Reply #127 on: 10 / August / 2009, 12:17:28 »
It would also be nice to edit the dedicated wiki page, to reflect the state-of-the-art.

edit: And then, perhaps, to change the color of the corresponding link on the For Developers page.
« Last Edit: 10 / August / 2009, 12:23:08 by whoever »


Re: Eos 400d ( Rebel XTI )
« Reply #128 on: 12 / August / 2009, 14:00:18 »
hi and thanks

I believe that the last release has a bug with iso setting

you will see no differences between Iso 1600 and 3200 as well as iso 16 - 100 (i.e. sensibility of sensor in Iso 1600 is the same as iso 3200 if you shoot with the same time and ap.)

but the spotmetering is fantastic !

In release of post #120 the iso works fine

thanks





*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #129 on: 13 / August / 2009, 08:19:43 »
Full ack.
Sometimes it seems to work. The actual release is a little bit buggy

 

Related Topics