supplierdeeply

Eos 400d ( Rebel XTI )

  • 1869 Replies
  • 501448 Views
*

Offline thaibv

  • **
  • 57
  • Canon 400d: Spot, ISO 3200 and more
Re: Eos 400d ( Rebel XTI )
« Reply #80 on: 30 / June / 2009, 02:01:27 »
Advertisements
Please be patient. I have so little time, since I've become a father on 1th on june  :D

Congratulation!
There's many new father here. Me too  :D

Some news:
- Now I can make it show correct ISO value on screen, it change when set ISO from Cannon iso dialog and  when press DP button to hack ISO also.   Only when switch it back on, it show incorrect number (if switch off before with a value other than the original 100, 200, 400, 800, 1600).
- Another secret thing is I can write down Shutter Release count that Canon hide from public (to a file in CF card).

Wait for more hours, I will post my bin file and code when at home after work.
  
« Last Edit: 30 / June / 2009, 11:26:08 by thaibv »
999 Members and 9999 Guests are viewing this board.

*

Offline Foldesa

  • *
  • 21
  • 400d
Re: Eos 400d ( Rebel XTI )
« Reply #81 on: 30 / June / 2009, 13:07:15 »
I don't get it !!! Damn  >:(
For some reasons I can't always turn on ISO 3200 in the menu. Sometimes it goes, sometimes not. I'm tearing my hear out :) My cameara is half dead anway. The dust delete hardware is broken... Anyway I will try :-)

Zibri, You mean you can display other walues not just 100, 200, 400, 800, 1600 ? Can for exampl.:320 be shown ? It would be great :)

*

bugmenot

Re: Eos 400d ( Rebel XTI )
« Reply #82 on: 30 / June / 2009, 13:36:48 »
Best wishes ;) ! All the best for your child!

But when you are online the next time, please tell me, which file  with which software to analyse?

Let me help you tell me! :D

*

Offline Foldesa

  • *
  • 21
  • 400d
Re: Eos 400d ( Rebel XTI )
« Reply #83 on: 30 / June / 2009, 13:43:59 »
No spesific program. Just the decoded firmware and function lists, and some logs created when the camera is running and features are called and lots of try.


*

Offline thaibv

  • **
  • 57
  • Canon 400d: Spot, ISO 3200 and more
Re: Eos 400d ( Rebel XTI )
« Reply #84 on: 30 / June / 2009, 15:24:51 »
Hi,

Here my new files:  **updated: Download newer files here: http://chdk.setepontos.com/index.php/topic,3290.msg36095.html#msg36095
Bin: http://depositfiles.com/files/mdlitu1zy
Code: http://depositfiles.com/files/v16vcrkmg

How to use:
-Press DP button-> change iso
-Press Left arrow to display Mestering Dialog, then press DP button -> Spot meter
-Press Menu button to show camera menu then press DP to enter Factory mode (After camera beep, press Menu button twice to see Factory menu)
- Go in to "Factory Menu" dialog then press DP again to active Debug mode. After a beep, you will see CF red led blink when you press any button on your Cam. It write log to a file named 'STDOUT.txt' at the card's root directory.  To know yours shutter release count, set Spot metering when in debug mode then take out and insert your CF card into cardreader, open this file in Notepad and search for string: Release.

note: the bin file have bugs. Some time it turn off display and you have to switch off then back on.

regards,
« Last Edit: 01 / July / 2009, 12:04:36 by thaibv »
999 Members and 9999 Guests are viewing this board.

*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #85 on: 30 / June / 2009, 17:37:50 »
Another great work! Nothing for real use, but it looks great.

It displays the ISO, the handling is better.

The shuttercount works!
But what is "RecentErrorX" ..... ?

Will you build an ISO-Function, that let us control the ISO-Settings in the menu?

*

Offline thaibv

  • **
  • 57
  • Canon 400d: Spot, ISO 3200 and more
Re: Eos 400d ( Rebel XTI )
« Reply #86 on: 30 / June / 2009, 20:16:17 »
why not, do nothing for real use while it display real iso on screen?

"RecentError..." is some last Canon's loged error (guess: cannot focus, Error 99, Batery empty, no cf card, card full...)

Full ISO seting menu?  Have no answer now but may be in future.

thanks for trying!
« Last Edit: 30 / June / 2009, 20:32:23 by thaibv »
999 Members and 9999 Guests are viewing this board.

*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #87 on: 01 / July / 2009, 08:49:56 »
Sorry, but if i'll take a picture and the camera turns off display.... No, its not for productive use. Not for ME ;)

I'm testing the aktual autoexec.bin with my 2gb CF, the older one on 4gb CF. Both are working. The older one perfectly!

If i can help you, just say a word. I would do my best.


*

bugmenot

Re: Eos 400d ( Rebel XTI )
« Reply #88 on: 01 / July / 2009, 11:02:51 »
The shutter realese count is great! Some photos more than the seller told me, but not much :D

Did you noticed the comment before: "*** unofficial information ***" There you can also look how often e.g. Error1 was noticed by the camera!


*

Offline T.B.

  • *
  • 19
Re: Eos 400d ( Rebel XTI )
« Reply #89 on: 01 / July / 2009, 11:32:07 »
Oh. An ISO-problem?

If i set ISO to 100, the EXIf says ISO100
If i set ISO to 125 the Exif says ISO160
Ii i set ISO to 80 the exif says ISO100

If i set ISO to 3200 the EXIF says ISO 1600
And so on.

The problem is, if i set ISO1600 and press the "direct-print-button", dhe Camera sets ISO 2000, but displays ISO 1600. (Exif = ISO2000). If i press the "direct-print-button" twice, camera sets ISO to 2500 (EXIF) and displays 2000....

 

Related Topics