G7 1.00g questions - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

G7 1.00g questions

  • 3 Replies
  • 2009 Views
G7 1.00g questions
« on: 12 / March / 2009, 14:25:29 »
Advertisements
I just got a G7 (so I'm both a G7 and CHDK newbie), and can't figure out how to start the G7 in playback mode.  It seems to always start in record mode. 

Moreover, the Firmware Update option shows up in the playback menu when the lens is retracted.  But the only way I can figure out to retract the lens in playback mode is to set the lens retract time to 0.  But I don't really want to set the lens retract time to 0--I'd like to use the G7 with a lens retract time of 1 min so the lens doesn't keep on moving out when I want to review some photos quickly.  The double-playback press trick in the readme doesn't seem to work (I tried pressing it twice quickly, or with a two second space, and the lens still stays out and the Firmware Update option doesn't show up).

If I weren't using an SDHC card, I could get around this by using auto boot (which works fine on my 1gb SD card).  But I'm using a 4gb SDHC.

Any help would be appreciated.  Thanks!

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: G7 1.00g questions
« Reply #1 on: 12 / March / 2009, 16:39:35 »
Hi, welcome to the forum

You should be able to make your card bootable, it has nothing to do with the card being SDHC, but is
determined by card size: the maximum size of a FAT16 file system (required for CHDK autoboot) is 4 Gb
It's true that Windows will warn if you try and format a 4 Gb card 'with non-standard 64 kb sectors', but
i have not seen anybody report problems on this forum about that.
 
If you run Windows, try CardTricks (link see my sig), in other cases read the relevant Wiki page here:

http://chdk.wikia.com/wiki/Bootable_SD_card

have fun with CHDK,

wim
« Last Edit: 12 / March / 2009, 16:43:37 by whim »

Re: G7 1.00g questions
« Reply #2 on: 13 / March / 2009, 11:05:25 »
Yup, that worked.  Thanks!

Is there a way of getting it to boot straight to record mode, so one doesn't have to do that half-press of the shutter button?  (By the way, I couldn't see anywhere in the docs that that was how one had to get to record mode.  I had to search the forums for that.)  Say by an auto starting script?

Re: G7 1.00g questions
« Reply #3 on: 13 / March / 2009, 12:18:16 »
This did the trick:

Code: [Select]
@title Startup
print "Starting..."
sleep 800
click "shoot_half"
exit_alt
end

I wonder if I can replace the "sleep 800" with something better, like a while loop waiting for the camera to warm up (or whatever is needed).  Smaller delays are less reliable.


 

Related Topics