USB Remote on s2is - General Help and Assistance on using CHDK stable releases - CHDK Forum

USB Remote on s2is

  • 22 Replies
  • 8375 Views
USB Remote on s2is
« on: 18 / January / 2008, 06:34:33 »
Advertisements
Does anyone have USB-remote working on the s2is ?


If so, could you please state which build version you are using ?


Thanks.



David

Re: USB Remote on s2is
« Reply #1 on: 04 / November / 2008, 18:18:15 »
I don't, but I have the same question.

I have an S2IS.
I'm using allbest-s2is-100f-50.zip, with a gentledCHDK2 connection (2 servo ports on an Airtronics R/C receiver plug into the USB).

My script runs, but I always get a return of 0 on get_usb_power. 

I'm fairly certain I have the pinout correct (and I've tried multple configurations), as well as ensured the receiver ports are working (testing the USB connection in other ports, and testing (with servos) in those same ports).  My receiver is working, and I'm also getting at least 4.8v from my battery.

Re: USB Remote on s2is
« Reply #2 on: 04 / November / 2008, 18:26:56 »
My script runs, but I always get a return of 0 on get_usb_power. 


If you can test it with another camera it will probably work.

I gave up trying to get the s2is to work with a USB remote switch (based on the feedback from a tester).

That is why it says on the SDM website that it is not supported for synch shooting.


David

Re: USB Remote on s2is
« Reply #3 on: 04 / November / 2008, 21:47:38 »
Is there a way to tell what voltage the USB on the camera requires?

Also, I'm not using it for synch shooting (at least I don't think I am - unless I don't understand the difference).
I'm tring to read the USB voltage and trigger an action (based on receiving 'signal' from the R/C receiver).


*

Offline zeno

  • *****
  • 889
Re: USB Remote on s2is
« Reply #4 on: 05 / November / 2008, 04:26:11 »
An easy way to test if a USB switch can work on a given camera is to run a simple script like this:
   @title test remote
   do
     a = get_usb_power
     if a > 0 then print "a=", a
   until a>5000
   end

and then repeatedly connect and disconnect the camera to a PC USB port. The LCD display should tell you how long the connection was in place.

A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: USB Remote on s2is
« Reply #5 on: 06 / November / 2008, 02:53:29 »
 My S2 can detect usb voltage as seen in misc values and can report duration while running remote test scripts.  The problem is that it likes to go into playback mode and take no photos without running a remote script.  Despite my searching, I haven't found a reason for this and would like to know why it's like it is.

Re: USB Remote on s2is
« Reply #6 on: 06 / November / 2008, 18:52:31 »
An easy way to test if a USB switch can work on a given camera is to run a simple script like this:
   @title test remote
Thank you.
Wow!  I got some varying values, so now I know the script works.  Now all I need to do is figure ot why the "gentledCHDK2" cable isn't proving power to the USB port.

Re: USB Remote on s2is
« Reply #7 on: 17 / November / 2008, 12:55:40 »
UPDATE:  Spoke to James, and based on the data provided - he sent me a replacement "gentled chdk2".
When I tried the replacement cable, I am now getting non-zero values from get_usb_power on both channels.   :D

I'm going to re-write my script to trigger the shutter, get the wires cinched down, and get the camera up in the air (finally)!  I'll work on the zoom in/out functionality later.

I want to thank Mr. Gentles for conversing with me through many eMails, providing insight and testing tips, and also sending a replacement cable. 


Re: USB Remote on s2is
« Reply #8 on: 01 / December / 2008, 17:01:53 »
Just wanted to provide a quick update.
I re-wrote the script, got the wires cinched down, and got the camera up in the air!
WooHoo!

The pics didn't come out a crisp/clear as I expected, which is probably because I did not make sure it was set to 'auto', and I did not set ISO nor AV in the script.  :(

Progress is good - even if it's 1 step at a time... :D

*

Offline A1

  • *
  • 2
Re: USB Remote on s2is
« Reply #9 on: 09 / January / 2009, 13:03:05 »
My S2 can detect usb voltage as seen in misc values and can report duration while running remote test scripts.  The problem is that it likes to go into playback mode and take no photos without running a remote script.  Despite my searching, I haven't found a reason for this and would like to know why it's like it is.

I am running into the exact same behavior.  When I run a simple remote script, the camera will first go into playback mode, return, then fire the shot.  This increases the shutter delay significantly.

spence602 - with your updated script and using your chdk build, are you able to capture right when you press the shutter?  Or does it also go through a playback screen first?

Here is some interesting information from David in a different thread:
When +5V is connected to the USB, a signal goes to the DIGIC chip and the firmware sets a particular location in memory to indicate the +5V is present.
The Canon firmware switches to playback mode and tries to communicate with the PC when it sees that memory location is set to '1'.
Your computer may respond to the camera communication by starting a designated programme.
That programme may be Canon ZoomBrowser or it may be any other designated programme.
Now, to use a USB remote we need to stop all of this from happening.
When menu option 'USB Remote' is enabled, we set that memory location back to '0' one hundred times a second, so the Canon firmware never knows the USB is connected and does not switch to playback mode.

Just wildly speculating, but is it possible that the memory location for the S2 IS is in a diffferent location?

 

Related Topics