USB Remote on s2is - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

USB Remote on s2is

  • 22 Replies
  • 8108 Views
Re: USB Remote on s2is
« Reply #10 on: 09 / January / 2009, 15:59:14 »
Advertisements
I am running into the exact same behavior.  When I run a simple remote script, the camera will first go into playback mode, return, then fire the shot.  This increases the shutter delay significantly.

spence602 - with your updated script and using your chdk build, are you able to capture right when you press the shutter?  Or does it also go through a playback screen first?
I do not see the screen (viewfinder only) change - just my 'print' statement appears (after auto focus) and the picture was taken.  My LCD monitor is closed.

Re: USB Remote on s2is
« Reply #11 on: 10 / January / 2009, 10:15:56 »
is it possible that the memory location for the S2 IS is in a diffferent location?

Well, get_usb_power is working OK so it must be correct.

Spence, are you saying that with the LCD screen closed, everything works and the camera does not switch to playback mode when the USB signal is detected ?


David

Re: USB Remote on s2is
« Reply #12 on: 10 / January / 2009, 23:34:34 »
Yes, correct.
Since I'm using the camera for KAP, I wouldn't have the LCD on anyways.  My plan was to have a spy-cam pointing through the viewfinder while the kite/KAP rig was in the air.

I just look through the viewfinder to watch the script.  And it uses less battery power.

Re: USB Remote on s2is
« Reply #13 on: 11 / January / 2009, 11:11:46 »
Yes, correct.

I am not familiar with the current version of the basic CHDK, but could you try this  ..

Make sure USB remote is enabled and you are not in ALT mode.
Plug USB cable into camera and other end into PC.

Does the screen blank ?
After a ten second time-out does it take a photo ?

Thanks.


*

Offline A1

  • *
  • 2
Re: USB Remote on s2is
« Reply #14 on: 02 / February / 2009, 20:44:30 »
I was able to figure out why the S2IS goes into playback mode, but I need someone to check in the fix or grant me rights to check in [to trunk].  This works great on my S2IS, but after talking to David (Microfunguy), it does not address the problem he was having (with the Ricoh CA-1).

I made the following two changes to my local copy of kbd.c (https://tools.assembla.com/chdk/browser/trunk/platform/s2is/kbd.c):
 
1. Add at line 320:
physw_status[USB_REG] = kbd_new_state[USB_REG] & ~USB_MASK;
 
2. Lines 308-310 should be moved to after the remote button code block (Line 322)


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: USB Remote on s2is
« Reply #15 on: 02 / February / 2009, 21:15:23 »

Re: USB Remote on s2is
« Reply #16 on: 03 / February / 2009, 15:45:53 »
The fix by A1 works for me on build 565(old, I know) and my homemade wireless remote.  The only thing I noticed is that it doesn't trigger a script, but I don't know if it should or not. 
I'm now excited about trying it out, so thankyou.

Re: USB Remote on s2is
« Reply #17 on: 22 / February / 2009, 09:39:22 »
Has this fix been included in the latest build ? s2is-100e-0.9.6-714-full.zip  (739KB) from the http://mighty-hoernsche.de/ page ..
If not is there a build I can pickup ?
Thanks!
CHDK used for a Bullet-time sequence
Welcome to mishra.tv productions


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: USB Remote on s2is
« Reply #18 on: 25 / February / 2009, 06:40:58 »
yes, it has been included, see changelog.txt of the autobuild :)

Re: USB Remote on s2is
« Reply #19 on: 25 / February / 2009, 07:34:47 »
OK. I'll try this again. But I had the problem mentioned earlier with the switch to playback mode. When I upgraded the firmware, it did not even do that..
Do I need 4.5 V for this ?
Cheers!
yes, it has been included, see changelog.txt of the autobuild :)
CHDK used for a Bullet-time sequence
Welcome to mishra.tv productions

 

Related Topics