CHDK for new Canon PowerShot SX200 IS? - page 2 - Feature Requests - CHDK Forum supplierdeeply

CHDK for new Canon PowerShot SX200 IS?

  • 141 Replies
  • 63328 Views
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #10 on: 01 / April / 2009, 06:05:10 »
Advertisements
How to dump a NewDryOS fw:
1) You can dump your fw with Cardtricks (use "NewDryOS" method)
* Use Cardtricks with an empty SD card (max. 2GB size !),
  select your card, press the NewDryOS button, read all the messages carefully & follow them.
* Lock the card (important !), insert it & start up the camera - you'll see NO activity,
  just wait 30 seconds, then remove the batteries & the card.
* Insert the card in your card reader, start Cardtricks again, select your card & press Strings.
* Now you should see some strings from the firmware; close the window, click Clean in Cardtricks,
  then store the cleaned dump on your hard disk.
* Zip this file and upload it somewhere, e.g. at a free file hoster like http://www.zshare.net,
  then post the link to this fw dump on this thread here in the forum:
  [DOWNLOAD LINKS] Firmware dumps available.


This didn't work. I tried multiple times using a 2GB MicroSD card in an adapter, locked as per the instructions, and prepared in Cardtricks using the NewDryOS button. First I tried turning on the camera using the Play button (which usually turns it on and puts it into play mode) and then I tried using the normal ON/OFF button just for good measure. I tried both ways a couple of times each, and waited at least two minutes each time. Pressing either of those buttons made nothing apparent happen, as the instructions said, but when putting the card back into the reader the empty.dum file was still empty and the strings button brought up nothing. Any other suggestions? I also tried the card normally to make sure it worked in the camera, and it did. By the way, I also tried putting the ver.req and vers.req files in the root directory of the card, and neither worked. Either pressing Func/Set and Disp simultaneously or Func/Set first followed by Disp did nothing.
Cameras: SX200 IS 100c US, S3 IS US

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #11 on: 01 / April / 2009, 06:51:01 »
@Ezzelin

Micro SD cards are more likely to pose problems while trying to dump cams ...
Try it with a regular SD if you have one - maybe Canon supllied you with one,
even 16 or 32 MB should do nicely (as long as it's not an MMC card)


wim
« Last Edit: 01 / April / 2009, 06:53:50 by whim »

Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #12 on: 01 / April / 2009, 18:08:46 »
@Ezzelin

Micro SD cards are more likely to pose problems while trying to dump cams ...
Try it with a regular SD if you have one - maybe Canon supllied you with one,
even 16 or 32 MB should do nicely (as long as it's not an MMC card)


wim

I tried with and old 16MB SD card (the one that came with the S3 IS) and still nothing, both with the Play and the ON/OFF button.
Cameras: SX200 IS 100c US, S3 IS US

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #13 on: 02 / April / 2009, 05:28:35 »
Hi Ezzelin !

If you're still eager to keep trying, i suggest you have a peek here: http://chdk.setepontos.com/index.php/topic,2766.msg25978.html#msg25978

it is the A2000IS dumping thread, there was problems with this model as well. In this thread are also several
alternative udumper versions, maybe one of them will work ...

wim


Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #14 on: 07 / April / 2009, 07:30:18 »
Sadly, none of the DISKBOOT.BIN files in the zips in that thread worked; I tried all of them. Since I read in that thread that the ON/OFF button was the way that was working, that's what I used to try them out. Each time, it didn't show anything on the screen or give me any sign, which is good, but the file was always blank. I didn't need to reprepare the card each time, did I? I just moved on a new DISKBOOT.BIN and tried again. Any other suggestions? I really want to make this work.
Cameras: SX200 IS 100c US, S3 IS US

*

Offline mx3

  • ****
  • 372
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #15 on: 07 / April / 2009, 09:52:11 »
Sadly, none of the DISKBOOT.BIN files in the zips in that thread worked; I tried all of them.

what about fi2? (just pack diskboot.bin  into fi2...)
is camera ID  known already via vers.req?
skype: max_dtc. ICQ: 125985663, email: win.drivers(at)gmail, eVB decompiler

Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #16 on: 08 / April / 2009, 03:21:37 »
Sadly, none of the DISKBOOT.BIN files in the zips in that thread worked; I tried all of them.

what about fi2? (just pack diskboot.bin  into fi2...)
is camera ID  known already via vers.req?

I couldn't get vers.req or ver.req to work on this camera. I've read and followed the instructions, and have successfully used them on an S3, so I'm not sure what to say about that. How would I go about packing diskboot.bin into a fi2? Or is there a link you can point me to?
Cameras: SX200 IS 100c US, S3 IS US

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #17 on: 08 / April / 2009, 03:46:54 »
I couldn't get vers.req or ver.req to work on this camera.

If you using Windows, you can read camera PID in device manager when camera is connected to PC (see screenshot; unfortunately not in English).


Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #18 on: 08 / April / 2009, 04:36:22 »
I couldn't get vers.req or ver.req to work on this camera.

If you using Windows, you can read camera PID in device manager when camera is connected to PC (see screenshot; unfortunately not in English).
OK, I did that. The PID appears to be 31C0. Here's the screenshot:

How does this help us? Is there any other information I can get about the camera in the Device Manager that would be useful? What's the next thing to try? Thanks.
Cameras: SX200 IS 100c US, S3 IS US

*

Offline mx3

  • ****
  • 372
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #19 on: 08 / April / 2009, 04:46:27 »
How does this help us? Is there any other information I can get about the camera in the Device Manager that would be useful? What's the next thing to try? Thanks.
http://chdk.setepontos.com/index.php/topic,2995.0.html
I'm not sure where to find compiled fi2enc (sources are in svn / trunk).
You can make it yourself of wait for someone to share...

skype: max_dtc. ICQ: 125985663, email: win.drivers(at)gmail, eVB decompiler

 

Related Topics