CHDK for new Canon PowerShot SX200 IS?

  • 141 Replies
  • 32512 Views
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #100 on: 06 / July / 2009, 06:33:51 »
    Advertisements
    Great progress indeed, also waiting for a port, do you guys think it'll be possible to disable the flash popup on the sx200 upon boot?

    I don't think so, seems the flash mechanic is dependent with the objective, so it must pop up when you boot, and directly retract when going to review mode...
    hope i'm wrong ;)

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #101 on: 06 / July / 2009, 06:41:44 »
    Hello & welcome, mmgRay !
    Great progress indeed, also waiting for a port, do you guys think it'll be possible to disable the flash popup on the sx200 upon boot?

    ...you can fix it with a stripe of adhesive tape like other SX200 users do  :(

  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #102 on: 10 / July / 2009, 17:57:11 »
    any news yet?  :(

  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #103 on: 17 / July / 2009, 08:35:29 »
    Ya, was wondering the same thing, just bought this model. If anyone needs help testing, I be at your service.


    *

    Offline OldGit

    • ****
    • 303
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #104 on: 18 / July / 2009, 12:59:29 »
    Sorry for the delay with the dump, had to go away for work, just got back.
    Bad news - blinking via sound card no good.
    Good news - blinking via 232 port works ....
    So I now have this file http://www.zshare.net/download/62838104e12c7266/
    Looks ok in hex editor but I'm not sure that I have all required data.
    Can someone take a look and see if I got right ?.
    If not can someone point me at a start address and size and I will try again.
    SX200 IS-100C

  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #105 on: 18 / July / 2009, 14:03:00 »
    Sorry for the delay with the dump, had to go away for work, just got back.
    Bad news - blinking via sound card no good.
    Good news - blinking via 232 port works ....
    So I now have this file http://www.zshare.net/download/62838104e12c7266/
    Looks ok in hex editor but I'm not sure that I have all required data.
    Can someone take a look and see if I got right ?.
    If not can someone point me at a start address and size and I will try again.

    Great work. With a quick look I think I can confirm that you have indeed got all of the firmware.

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #106 on: 18 / July / 2009, 14:03:52 »

    *

    Offline OldGit

    • ****
    • 303
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #107 on: 18 / July / 2009, 14:54:21 »
    Thanks for the sanity checks and the advice on IDA.
    I'm glad I'm on the right line, the blinking was driving me crazy.
    I'll give the next stage a go but not being too good at ARM code it may take me while.

    Thanks for all the help.
    SX200 IS-100C


    *

    Offline mx3

    • ****
    • 372
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #108 on: 19 / July / 2009, 02:02:43 »
    Good news - blinking via 232 port works ....
    How ?????
    I remember someone directly conected led output into computer...
    How did you?
    led -> photodiod -> transistor -> rs232????

    I'm sure your method worth of mentioning in wiki
    skype: max_dtc. ICQ: 125985663, email: win.drivers(at)gmail, eVB decompiler

    *

    Offline OldGit

    • ****
    • 303
  • Publish
    Re: CHDK for new Canon PowerShot SX200 IS?
    « Reply #109 on: 19 / July / 2009, 03:48:47 »
    mix3,
    I used the 232 as the PC was introducing noise to the audio signal.

    I used a phototransistor into a comparator then into a max202cpe (ttl to rs232 interface chip) then used a scope to get the timing right.

    Replaced loader code with blinker code and edited to send start bit, data bits and stop bit.

    Now I need to trim the dump as suggested by fe50 and find a disassembler (don't have IDA)

    As the camera belongs to the wife, I'm just glad to no longer be upsetting her by "playing with the pretty lights" and running down the battery.
    SX200 IS-100C

     

    Related Topics