CHDK for new Canon PowerShot SX200 IS? - page 10 - Feature Requests - CHDK Forum supplierdeeply

CHDK for new Canon PowerShot SX200 IS?

  • 141 Replies
  • 64300 Views
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #90 on: 01 / July / 2009, 15:38:09 »
Advertisements
Here's an different approach (I look for the second firmware address after "BOOTDISK"):

http://www.mweerden.net/download/udumper_alt/sx200is_PS.FI2
http://www.mweerden.net/download/udumper_alt/sd780is_PS.FI2
http://www.mweerden.net/download/udumper_alt/DISKBOOT.BIN
http://www.mweerden.net/download/udumper_alt/main.c

If this doesn't work, then I'm out of "easy" ideas. The only alternative I can think of is to explore the firmware a bit by selectively blinking small parts (very slow blinking can easily be used to manually retrieve small blocks of data) hoping to find something very similar to other firmwares. This method is a bit more elaborate.

No go on the new versions. I tried the .fi2, and the DISKBOOT.BIN using both the ON/OFF button and the play button. The empty.dum file was always empty.

Is there any way you could make a firmware blinker for the SX200?

Since I do not have a SX200, I cannot do anything directly... If there is some interest (let me know), I can publish a small howto based on the D10. Since it looks it has common points with the SX200, it may be useful.

Anyway, my blinker is quite a hack, and only works on linux (since I use python's alsa module), but it has the advantage that it can be easily adapted...

I would love a guide for how you blinked the D1! I can use linux, and if pointed in the right direction buy the stuff to receive the blinked image.
Cameras: SX200 IS 100c US, S3 IS US

*

Online reyalp

  • ******
  • 13500
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #91 on: 01 / July / 2009, 20:07:13 »
No go on the new versions. I tried the .fi2, and the DISKBOOT.BIN using both the ON/OFF button and the play button. The empty.dum file was always empty.
Keep in mind that udumper doesn't know anything about empty.dum or the filesystem. It just writes to sectors near the start of the SD card. This means the card should be freshly formatted, and empty.dum the first file created. Alternately (if on a *nix platform), you could could just look for the dump in the device.

It's also worth noting the DISKBOOT wouldn't be expected to work, since we weren't even able to get LEDs blinking by that method, while the same file does work with FI2.
Don't forget what the H stands for.

Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #92 on: 01 / July / 2009, 22:48:28 »
No go on the new versions. I tried the .fi2, and the DISKBOOT.BIN using both the ON/OFF button and the play button. The empty.dum file was always empty.
Keep in mind that udumper doesn't know anything about empty.dum or the filesystem. It just writes to sectors near the start of the SD card. This means the card should be freshly formatted, and empty.dum the first file created. Alternately (if on a *nix platform), you could could just look for the dump in the device.

It's also worth noting the DISKBOOT wouldn't be expected to work, since we weren't even able to get LEDs blinking by that method, while the same file does work with FI2.
Well, I originally used the NewDryOS button in CardTricks to format the 16MB SD card and prepare the empty.dum. After that I just copied over the .fi2 file. I also just tried formatting the card fresh again and copying over the empty.dum file manually, and then copying the .fi2 file, and that didn't work either. One more thing that I didn't note is that when I first start up the .fi2 file the front AE assist light flashes once along with the green and blue LEDs lighting up on the back.
Cameras: SX200 IS 100c US, S3 IS US

*

Online reyalp

  • ******
  • 13500
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #93 on: 01 / July / 2009, 23:10:17 »
Hmmm,  mweerdens FI2 files are loading for you guys ?

In my experiments with tommie-lie we concluded they had to be a certain minimum size or the firmware refused to load them http://chdk.setepontos.com/index.php/topic,3347.msg34396.html#msg34396
Don't forget what the H stands for.


Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #94 on: 02 / July / 2009, 01:29:46 »
One more thing that I didn't note is that when I first start up the .fi2 file the front AE assist light flashes once along with the green and blue LEDs lighting up on the back.

That's fine. It means that everything seems to work until the alleged WriteSDCard function is called.

Hmmm,  mweerdens FI2 files are loading for you guys ?

In my experiments with tommie-lie we concluded they had to be a certain minimum size or the firmware refused to load them http://chdk.setepontos.com/index.php/topic,3347.msg34396.html#msg34396

There is 20kB of padding, but they are all zeros (instead of the random data you seem to have used). The compression of the FI2 makes it look as if it isn't there. So I guess the file size isn't important, but the amount of data stored from 0x1900 on is.

Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #95 on: 02 / July / 2009, 06:29:12 »

*

Offline OldGit

  • ****
  • 303
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #96 on: 03 / July / 2009, 10:09:48 »
Hi all, new to all this but i've been following the progress on the SX200 and, with all the excellent work already done by others here, I have managed to get a working ps.fi2 to blink.
I will be trying to dump in the morning.
Can I assume that I also need to set the base address in the dec.c to 0xFF810000 for this to work ?.
Sorry if this is stupid question.
SX200 IS-100C

*

Offline fe50

  • ******
  • 3136
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #97 on: 03 / July / 2009, 10:16:51 »
Hello & welcome, OldGit !

Can I assume that I also need to set the base address in the dec.c to 0xFF810000 for this to work ?.

Yes, 0xFF810000 should be ok...

Until now the ROM starting addresses were 0xFFC00000 for the A-series and 0xFF810000 for the S-, SD-, and G- series


Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #98 on: 03 / July / 2009, 11:43:00 »
Great progress indeed, also waiting for a port, do you guys think it'll be possible to disable the flash popup on the sx200 upon boot?

*

Offline mx3

  • ****
  • 372
Re: CHDK for new Canon PowerShot SX200 IS?
« Reply #99 on: 05 / July / 2009, 01:35:40 »
Can I assume that I also need to set the base address in the dec.c to 0xFF810000 for this to work ?.
it can be usefull to see 0xFFFF0000 - 0xFFFFFFFF
skype: max_dtc. ICQ: 125985663, email: win.drivers(at)gmail, eVB decompiler

 

Related Topics