can't get a script to run - page 2 - Script Writing - CHDK Forum
supplierdeeply

can't get a script to run

  • 13 Replies
  • 4688 Views
*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: can't get a script to run
« Reply #10 on: 22 / March / 2009, 22:13:06 »
Advertisements
@Hillman12

Make sure there's no empty line at the beginning of the script (1st line is "rem Author - Keoeeit"),
also append an additional empty line at the script's end.

Select the whole script text, copy the selection to the Windows clipboard (Ctrl-C), open the Windows Notepad and paste it (Ctrl-V);
save the file with document type = "text file" and file code = "ANSI" (NOT UTF-8 or Unicode...),
use a short name (e.g. INTERVAL.BAS); copy this file to the \CHDK\SCRPTS folder...

Then select this script from the CHDK script menu, adjust the parameters (you should see them now) & start the script with the shutter...

This script maybe is not ideal for starting, you should try a smaller, simple script like the following:
Code: (sdlbasic) [Select]
rem Interval shooting
rem org by A630Lover, chdk.setepontos.com

@title Interval shooting
@param a Shoot count
@default a 10
@param b Interval (Minutes)
@default b 0
@param c Interval (Seconds)
@default c 10

t=b*60000+c*1000
if a<2 then let a=10
if t<1000 then let t=1000

print "Total time:", t*a/60000; "min", t*a%60000/1000; "sec"

sleep 1000

print "Shoot 1 of", a
shoot
for n=2 to a
    sleep t
    print "Shoot", n, "of", a
    shoot
next n
end

...this small script should run on all CHDK cams & versions, you can also download it as attachement on this post....

Re: can't get a script to run
« Reply #11 on: 22 / March / 2009, 23:07:23 »
Wow! Thank you. I will give this a try tomorrow! :) ( late now have to get to bed).

Tom

Re: can't get a script to run
« Reply #12 on: 23 / March / 2009, 08:14:35 »
Got up early this morning and made the change- I used the script supplied by fe50 and copied it to the notebook instead of to a word document.  I had a feeling that the "no empty line at the beginning" was the kind of problem I was having.

Anyway, the smile of satisfaction that I have over this will carry me through the day. Going to do some time lapsin', man. 8)

I can't thank you guys enough. I belong to several Astronomy and Amateur Radio forums and it's really great to see that the priority of helping out with a selfless wealth of knowledge and experience resides here as well.  :D


My best to all,

Tom


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: can't get a script to run
« Reply #13 on: 24 / March / 2009, 17:02:34 »
make sure to spread the word about chdk in those forums, will ya :D


 

Related Topics