A470 Porting - page 19 - DryOS Development - CHDK Forum

A470 Porting

  • 253 Replies
  • 85421 Views
*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #180 on: 03 / June / 2009, 14:07:53 »
Advertisements
New build again (seems I can't keep my fingers away ::)).

Most importantly, all recent development done by MrSpoon (present in his patch in first msg in this thread) was manually added in by me to the current svn trunk source (769 right now). Ths includes a new colour matrix which you might find worth checking out (affects the DNG output). After a very quick test it seemed to me to be a lot better (closer to the JPG colours).

I also dusted off my reversing gear and I finally have the encryption keys necessary to build also .FI2 files, so there is no need to use a bootable card anymore - firmware update start method now also works.

The "rawfix" is of course applied as well.

Other stuff MrSpoon has mentioned in the thread should be in there too.

Since it seems svn updating is very slow (for the a470 tree) I decided to host alpha builds for the time being at a fixed URL:
http://nostalgia.suroot.com/chdk-a470-unofficial

I'll try put new builds there whenever something interesting happens.


As usual, bug reports will help development, and we still haven't heard anything from 101b users AFAIK  ::)

Cheers,

Thorwak
Do it 'til it Hz

Re: A470 Porting
« Reply #181 on: 03 / June / 2009, 17:46:38 »
A470-101a using 101b-769unofficial Test results
(using boot method)

OSD 
Grids, zebra, histogram and other data displays all work correctly now

RAW
Imagesize now reports and converts as 3096 x 2324 out of 3152 x 2340
Red and green seem to have a little bit of high clipping vs JPG and 768
Tried various conversion settings with DCRAW best results with "-a -W"

MISC NOTES
Autofocus assist LED flashing at startup is now green one on the back YAY!
LCD on-off results seem different (might be correct now for all I know)

I've not found any new issues or errors I'll try some more things later this
eve and follow up if there is anything odd.

Thanks for your efforts Thorwak and of course to Mr. Spoon for starting us off.

*

Offline reyalp

  • ******
  • 14087
Re: A470 Porting
« Reply #182 on: 03 / June / 2009, 19:17:23 »

Since it seems svn updating is very slow (for the a470 tree) I decided to host alpha builds for the time being at a fixed URL:
http://nostalgia.suroot.com/chdk-a470-unofficial
I haven't been following this thread closely, but if you can post a complete patch against the current trunk, I'll look into committing it.
Don't forget what the H stands for.

*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #183 on: 04 / June / 2009, 01:29:18 »
I haven't been following this thread closely, but if you can post a complete patch against the current trunk, I'll look into committing it.
Great! :) I'll post it tonight since I don't have access to my dev environment right now.


Red and green seem to have a little bit of high clipping vs JPG and 768
I'm still very new to CHDK, and I don't know too much about photography neither unfortunately. Would you say it's better (colour-wise) than the 768 all-in-all? How would we go about finding the "correct" colour matrix? (See MrSpoon's patch in first msg in this thread to see how it was changed in this unofficial build vs. the last 768-rawfix)

I would be happy to build and host various test versions if someone is good at calculating those. :)

EDIT: Thanks for reporting btw Tahkcalb, I can't test the 101b myself :) There were some updates to LED addresses in MrSpoons patch so the differences you see makes perfect sense.
Also: I just noticed you mentioned you have a 101A camera - did we know already 101b version of CHDK works for this fw? Seems like great news to me :) Maybe the build should be renamed 101a_b or something like that then?
« Last Edit: 04 / June / 2009, 01:36:18 by Thorwak »
Do it 'til it Hz


*

Offline reyalp

  • ******
  • 14087
Re: A470 Porting
« Reply #184 on: 04 / June / 2009, 01:50:12 »
Also: I just noticed you mentioned you have a 101A camera - did we know already 101b version of CHDK works for this fw? Seems like great news to me :) Maybe the build should be renamed 101a_b or something like that then?
Normal practice is to just copy the compatible version to both names in the batch builds. So for example only ixus800_sd700-101b is built, and then it is copied to ixus800_sd700-101a. You can see this in the top level Makefile.
Don't forget what the H stands for.

*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #185 on: 04 / June / 2009, 01:59:50 »
Normal practice is to just copy the compatible version to both names in the batch builds. So for example only ixus800_sd700-101b is built, and then it is copied to ixus800_sd700-101a. You can see this in the top level Makefile.
Noted, I'll fix this too tonight then. Thanks!
Do it 'til it Hz

Re: A470 Porting
« Reply #186 on: 04 / June / 2009, 02:37:27 »
I'm still very new to CHDK, and I don't know too much about photography neither unfortunately. Would you say it's better (colour-wise) than the 768 all-in-all? How would we go about finding the "correct" colour matrix? (See MrSpoon's patch in first msg in this thread to see how it was changed in this unofficial build vs. the last 768-rawfix)

I would be happy to build and host various test versions if someone is good at calculating those. :)

I think it is much better. I tried some shots with full sun, shade and tungsten over the day. I don't have a
calibrated target or anything to provide numbers. But the results when converted with Rawker(internal)
and DCRAW (from source build) are all higher in red and green channels than 768 when I output as 16bitTiff.
Using "-a" average option with DCRAW is now almost the same as the JPG output. So I'd assume that is what
the in-camera software is doing for the JPGs and I'd not worry about it too much. The work in other threads
on the color issue will likely spill over to us soon enough.

Quote
EDIT: Thanks for reporting btw Tahkcalb, I can't test the 101b myself :) There were some updates to LED addresses in MrSpoons patch so the differences you see makes perfect sense.
Also: I just noticed you mentioned you have a 101A camera - did we know already 101b version of CHDK works for this fw? Seems like great news to me :) Maybe the build should be renamed 101a_b or something like that then?

I mentioned 101B on 101A as working earlier in the thread.  I've not seen anything that is different from any of the other
101B reports so far. But I will if something does prove to be different. I usually check this thread every day, so mention
if you need any checking of specific items. Or feel free to gmail me at same username as here if you need instant reply.

Again, thanks for the efforts.

*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #187 on: 04 / June / 2009, 13:16:58 »
I haven't been following this thread closely, but if you can post a complete patch against the current trunk, I'll look into committing it.
Here's the full diff taken against the 769 trunk. I also fixed the Makefile to "build" a470-101a as discussed earlier. I can't see a way to attach files(?) so I'll have to link to it instead since I got an error about maximum msg length :P (I feel really stupid - how do I attach files anyway?).

http://nostalgia.suroot.com/chdk-a470-unofficial/a470-769-patch.txt

I tested it against a clean 769 trunk with "patch -p0 < patch.txt" and it builds and works fine (tested in camera again).

Thanks for your help!
Do it 'til it Hz


*

Offline reyalp

  • ******
  • 14087
Re: A470 Porting
« Reply #188 on: 04 / June / 2009, 17:11:51 »
Here's the full diff taken against the 769 trunk. I also fixed the Makefile to "build" a470-101a as discussed earlier. I can't see a way to attach files(?) so I'll have to link to it instead since I got an error about maximum msg length :P (I feel really stupid - how do I attach files anyway?).
attachments are temporarily disabled due to forum issues.

edit:
patch committed, svn 770

Is this the first CHDK camera without a DISP button ? If so, there may be some interface issues.

Also, I'd appreciate confirmation that the 101b build actually works on 101a.

It looks like the fat32 support code is in, is there a reason CAM_MULTIPART is not enabled ?
« Last Edit: 04 / June / 2009, 17:30:29 by reyalp »
Don't forget what the H stands for.

Re: A470 Porting
« Reply #189 on: 04 / June / 2009, 21:34:22 »

Also, I'd appreciate confirmation that the 101b build actually works on 101a.


Just snagged 770 and it loads fine with no immediate issues on a GM101A Jan 24 2008.
Tried bracketing(continuous) , couple lua and ubasic scripts, DNG, and the OSD options.
If there is a general test sequence/suite for check offs, mention it and I'll run through it.


Thanks all.

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal