supplierdeeply

A470 Porting

  • 253 Replies
  • 37253 Views
  • Publish
    Re: A470 Porting
    « Reply #70 on: 13 / April / 2009, 23:11:50 »
    Advertisements

    *

    Offline Husky

    • *
    • 26
  • Publish
    Re: A470 Porting
    « Reply #71 on: 14 / April / 2009, 00:27:15 »

    *

    MrSpoon

  • Publish
    Re: A470 Porting
    « Reply #72 on: 14 / April / 2009, 07:11:43 »
    I haven't looked into the USB remote control yet however the code for it is included in this port (kbd.c). CHDK's implementation of this feature is very basic, simply checking for a voltage applied across the USB power pins. Please test this and let me know :)

    I've been asked to upload my code so I've attached it. This code produces the working 101b diskboot, however is rather buggy for 102c. As I've said before I was still getting to grips with CHDK when I did 102c so that code needs going over.

    Instructions for setting up your development environment are in this post.

    EDIT: See first post for source code.
    « Last Edit: 17 / April / 2009, 20:46:52 by MrSpoon »

  • Publish
    Re: A470 Porting
    « Reply #73 on: 14 / April / 2009, 15:17:05 »


  • Publish
    Re: A470 Porting
    « Reply #74 on: 15 / April / 2009, 16:08:36 »
    Thank you very much Microfunguy and tested and it works perfect except the video camera is turned off when trying to burn, and I for years and I like to thank stereo. :P

    Traducido con google

  • Publish
    Re: A470 Porting
    « Reply #75 on: 16 / April / 2009, 05:32:02 »
    tested and it works

    You may like to try the bracketing and timelapse features.

    Download this file and copy the scripts to your script folder.
    Try time_lapse.bas, it is described here and here.


    Quote
    the video camera is turned off when trying to burn


    I do not understand, could you explain again ?


    David

  • Publish
    Re: A470 Porting
    « Reply #76 on: 16 / April / 2009, 05:37:49 »
    Al intentar grabar un video se apaga la camara gracias.

    *

    MrSpoon

  • Publish
    Re: A470 Porting
    « Reply #77 on: 16 / April / 2009, 06:52:08 »
    The camera turns off when recording video?

    I'm sorry for the confusion, I said I'd done video for 1.01b and would do it for the 1.02c. I haven't yet, I only uploaded the incomplete sources since they were requested and I had to comply with the GPL. They currently include the video code but there's a bug in the 1.02c assembler code somewhere.

    I'll fix the code and produce a patch for Microfunguy when I have free time. Unfortunately this is exam season :(


    *

    Offline Husky

    • *
    • 26
  • Publish
    Re: A470 Porting
    « Reply #78 on: 16 / April / 2009, 13:22:52 »
    tested and it works

    You may like to try the bracketing and timelapse features.

    Download this file and copy the scripts to your script folder.
    Try time_lapse.bas, it is described here and here.


    Quote
    the video camera is turned off when trying to burn


    I do not understand, could you explain again ?


    David

    Is this for 1.01b firmware?

  • Publish
    Re: A470 Porting
    « Reply #79 on: 16 / April / 2009, 13:33:50 »
    Yes

     

    Related Topics