A470 Porting - page 20 - DryOS Development - CHDK Forum supplierdeeply

A470 Porting

  • 253 Replies
  • 85613 Views
*

Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: A470 Porting
« Reply #190 on: 05 / June / 2009, 02:13:58 »
Advertisements
If there is a general test sequence/suite for check offs, mention it and I'll run through it.
You can run the LUA library test and add the A470 to the list there if the test is effective...

*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #191 on: 05 / June / 2009, 07:50:08 »
You can run the LUA library test and add the A470 to the list there if the test is effective...
I tested the 1.02c and everything passed according to logfile, wiki updated. Would be nice with others testing on 1.01a/b.

Is this the first CHDK camera without a DISP button ? If so, there may be some interface issues.
No idea wether it's the first, but there is no DISP button on a470 at least. What are we missing out on when it comes to CHDK? :/

It looks like the fat32 support code is in, is there a reason CAM_MULTIPART is not enabled ?
Could be that it's just untested, I guess only MrSpoon could answer this. He mentioned he was moving earlier this week so I don't know when he might be back online. I only have a 2 GB card, but I guess I could try partioning it and test the functionality. Would that be meaningful or do we need someone with a big card?

Thanks for updating the svn, I'm sure a lot of ppl enjoy having an improved a470 in the autobuild!


Also, a big Thank You to those testing and reporting back on my early test builds! :)
Do it 'til it Hz

*

Offline reyalp

  • ******
  • 14089
Re: A470 Porting
« Reply #192 on: 05 / June / 2009, 22:50:15 »
CAM_MULTIPART would enable "swap partitions" and "make card with 2 partitions"

The boot time stuff isn't ifdef'd so it should detect and swap partitions already, if it works. AFAIK It should work if you have a fat16 and fat32 partition regardless of the sizes.
Don't forget what the H stands for.

*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #193 on: 06 / June / 2009, 12:11:52 »
I actually bought a fast SDHC card yesterday right before going home, 8 GB, since I realized they weren't that expensive anymore (and I could sure use the extra speed for .DNG). Then I spent hours trying to get Windows to accept the SDHC card, applying a hotfix I had to request by mail etc etc until I booted the computer with the card in the reader and the PC wouldn't even post.. I didn't know older card readers aren't compatible with SDHC :o So, will probably wait 'til after the weekend before I test so I can do it for real. Frustrating though, I had planned it all so well :D
Do it 'til it Hz


*

MrSpoon

Re: A470 Porting
« Reply #194 on: 06 / June / 2009, 15:55:33 »
Hey, I never knew it took so long to get the net hooked up in a new flat!

Anywho, I've tested multipart booting and that seems to work fine. When I enabled CAM_MULTIPART the new options didnt work.

To try it you'll need to define WriteSDCard (I have this as 0xFFCF9440 for the 102c, if its wrong that'd explain a few things).

Swap partitions tells me I only have one partition, and make two partitions crashes the cam. That's as far as I've looked into it for now, so I left CAM_MULTIPART disabled.

*

Offline reyalp

  • ******
  • 14089
Re: A470 Porting
« Reply #195 on: 06 / June / 2009, 17:01:48 »
I didn't know older card readers aren't compatible with SDHC :o So, will probably wait 'til after the weekend before I test so I can do it for real. Frustrating though, I had planned it all so well :D
Fortunately SDHC capable readers are dirt cheap too :)

MrSpoon:
Thanks for the info.
Don't forget what the H stands for.

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: A470 Porting
« Reply #196 on: 07 / June / 2009, 06:08:51 »
Anywho, I've tested multipart booting and that seems to work fine. When I enabled CAM_MULTIPART the new options didnt work.
To try it you'll need to define WriteSDCard (I have this as 0xFFCF9440 for the 102c, if its wrong that'd explain a few things).
Swap partitions tells me I only have one partition, and make two partitions crashes the cam. That's as far as I've looked into it for now, so I left CAM_MULTIPART disabled.

In your code mbr_read_dryos() was called?
http://chdk.setepontos.com/index.php/topic,2798.msg31398.html#msg31398

*

MrSpoon

Re: A470 Porting
« Reply #197 on: 07 / June / 2009, 17:29:27 »
Ooh, that addition does seem to get things working :) I'll produce a patch once I get around to getting the WriteSDCard address for 101a/b (or someone else does).


*

Offline Thorwak

  • *
  • 26
  • a470
    • Nostalgia Public NetHack Server
Re: A470 Porting
« Reply #198 on: 07 / June / 2009, 17:31:57 »
Great news! Looking forward to trying it out as soon as you have a patch (will buy a new card reader tomorrow ;) )

EDIT:
I did some analysis on the 101b fw and assuming you are right about the address for 102c, the corresponding function in 101b should be at 0xFFCF8A00. I wouldn't bet my life on it though so we could maybe do a test build before it gets into svn.

EDIT2:
I implemented the change pointed to by ewavr, and it seems fine :) I have my 8 GB card autobooting, with a small boot partition created from within the camera. I can't swear wether I used the "make card bootable" or the cardtricks util to make it bootable, there was a lot of fiddling back and forth. The "swap partition" works fine though.

I can only test the 102c, so if someone is feeling brave, please try the 101b build (also for 101a). 102c feedback would be good too.

BACKUP EVERYTHING ON YOUR CARD FIRST!

I will provide a patch once we have some feedback, if MrSpoon doesn't beat me to it :)

Get the 722-mpart test builds:
http://nostalgia.suroot.com/chdk-a470-unofficial


« Last Edit: 09 / June / 2009, 15:41:48 by Thorwak »
Do it 'til it Hz

*

Offline rys

  • *
  • 4
Re: A470 Porting
« Reply #199 on: 09 / June / 2009, 22:58:20 »
I did some analysis on the 101b fw and assuming you are right about the address for 102c, the corresponding function in 101b should be at 0xFFCF8A00. I wouldn't bet my life on it though so we could maybe do a test build before it gets into svn.

Hello,

I have a 101b, and it fails to boot using the build in your last message.

Edit: Should also mention, using an 8GB SDHC card. Boots if either the larger partition is removed (boots into CHDK), or boots if the write protect tab is turned off. (boots to normal OS.) If I use Firmware Update with the write protect tab off, the camera shuts down.
« Last Edit: 09 / June / 2009, 23:01:19 by rys »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal