USB Remote Shutter Problem - Allbest v19 - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

USB Remote Shutter Problem - Allbest v19

  • 9 Replies
  • 2816 Views
USB Remote Shutter Problem - Allbest v19
« on: 18 / January / 2008, 17:29:30 »
Advertisements
Hi,

I'm slowly learning how to use all these new features, but the one I was most interested in was the remote shutter as before to get around this I would use the 2 second timer to take photos that required no movement.... but I cannot get it to work.

Canon - G7
Allbest v19 Build
'Tickbox' ticked to allow remote shutter in the menu
1 hacked up USB cable with two wires that I connect across the 3V battery.

I've tried keeping the wires in contact for a few seconds just to see, but still no joy. Can anyone help me?

Cheers,

M

*

Offline jetzt

  • ****
  • 316
  • [A710IS,(SD200)]
Re: USB Remote Shutter Problem - Allbest v19
« Reply #1 on: 19 / January / 2008, 04:39:13 »
I think you have to start a script to,if you didn't do that already, I used
 Multipurpose Motion Detector from here: http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection on an a710is works just fine. :)

Re: USB Remote Shutter Problem - Allbest v19
« Reply #2 on: 19 / January / 2008, 04:41:48 »
HI,
I guess you have used my testversion, so I have put a new version on
http://hem.passagen.se/fsmmal/chdk2.html

If you can check the procedure on
http://chdk.setepontos.com/index.php/topic,203.msg1745.html#msg1745
and then report back I can check the code. What version of G7 do you use?

Re: USB Remote Shutter Problem - Allbest v19
« Reply #3 on: 19 / January / 2008, 18:02:08 »
Balls...

First off I was not using the v20 test build... so I can see why it wasn't working now as it wasn't supported...

Allbest, plugging and unplugging makes no difference to the values in the table. The usb cable is working fine as I plugged my phone in and it sync'd and started to charge... And I've just this second tried the Canon software for taking remote pictures via the PC, which works fine. Anyway, here are the results:

1:c2008000
2:3f1f1e1f
3:4
4:105c3330

I also formated my SD card and placed v20* on there without any scripts...

ver.req info:
P-ID:3125 PAL
GM1.00i
E18
NOV 1 2006

I hope this helps you...

Cheers,

M

*allbest_cln-g7-100i-20.zip


Re: USB Remote Shutter Problem - Allbest v19
« Reply #4 on: 20 / January / 2008, 10:59:14 »
Hi,
are you running the remote script? It is needed to use the remote function.
If the values do not change when connecting the cable, that would indicate the remote button actually is working.

Re: USB Remote Shutter Problem - Allbest v19
« Reply #5 on: 20 / January / 2008, 15:21:27 »
Hi,

So, even though I have Allbest build v20 and have the tick box ticked I still have to run a script? I thought that the idea of the tick box in the scripts menu was to allow the use of the remote shutter with other scripts...?

Confused.

M

Re: USB Remote Shutter Problem - Allbest v19
« Reply #6 on: 21 / January / 2008, 16:52:36 »
Actually, the tick is there for being able to turn remote off when loading pictures to the pc (via USB cable).

Re: USB Remote Shutter Problem - Allbest v19
« Reply #7 on: 21 / January / 2008, 17:12:18 »
Okay I'm even more clueless now. Can someone point me in the direction as to how this works..?

Questions I have are:
If you have to run the script to use the remote, can you run another script to do something like the motion detection script like jetzt above talks about?

Cheers,

M


Re: USB Remote Shutter Problem - Allbest v19
« Reply #8 on: 22 / January / 2008, 01:14:18 »
Deleted
« Last Edit: 22 / April / 2008, 09:44:52 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

Re: USB Remote Shutter Problem - Allbest v19
« Reply #9 on: 22 / January / 2008, 13:32:27 »
Hi, thanks for the lessons. I didn't know that Canon removed the feature on purpose... what were they thinking? Probably didn't want to upset the DSLR owners. I did know however that it was not an original feature and the firmware hack provides a work around.

I got confused by the first line in http://chdk.wikia.com/wiki/UBASIC/Scripts:_Cable_Release which says that the script is no longer required as it's been added... thinking that the whole time you are running CHDK it's looking for the power pulse on the USB port. The post of the person above when he says he's running a script (motion detection) and it works with that, is confusing. I've looked at the script and cannot see the remote shutter information in there. So to me that's not too much to assume that he has the script running all the time. I'd have thought it possible and quite high on someones list to enable this all the time CHDK is running?

As for CHDK scripts... I'm learning.

Cheers,

M

 

Related Topics