The SX1 IS Porting Thread - page 37 - General Discussion and Assistance - CHDK Forum

The SX1 IS Porting Thread

  • 381 Replies

Offline agb

  • *
  • 1
Re: The SX1 IS Porting Thread
« Reply #360 on: 23 / February / 2010, 16:09:29 »

I'm new to CHDK. It took some time before I could have it running on my SX1 + 8GB SDHC card but it finally works!
Just for the record I wanted to say that sdminste.exe (from StereoData Maker) did the trick for me ( was also useful). So, with sdminste.exe I could make two partitions on my card and swap between them. With cardtricks, I could format the partitions and make the small one bootable and copy the CHDK on both.

Hope this helps someone else because I spent quite some time searching the net as I could not manually boot the CHDK via the firmware install menu.

Of course it would be a lot easier if cardtricks would support cards > 4gb. And of course it would also be a lot easier if windows would recognize all partitions on removable media... Oh well...

« Last Edit: 23 / February / 2010, 16:11:14 by agb »

Canon Powershot SX1 IS crashes when taking picture while recording video
« Reply #361 on: 27 / February / 2010, 09:29:02 »
When I start capturing a video via the red record button, the SX1 IS starts recording and CHDK display the current data rate that the video stream creates (usually around 1MByte/s) and the red LED underneath the MENU key is flashing. It's obviously recording the video stream. When I press the snapshot button now to take a snapshot of the current image...

Erroneous behavior:
- the camera takes the picture (or at least one can hear the shutter noise)
- the screen freezes while the red LED keeps flashing
- after 1.5 seconds the red LED stops flashing and stays on for about 1 second
- then the camera shuts off without retracting the lens
- when switching back on after the crash, the camera retracts the lens and the display "unidentified image" (which sometimes even shows a small thumbnail of the previously taken picture but mostly not, the file can easily be deleted like valid pictures)
- the bug is 100% reproducible

I'm using
- Canon Powershot SX1 IS with Firmware 2.01A
- Tested CHDK version sx1-201a-0.9.9-874 and sx1-201a-0.9.9-875 both with same behavior)
- 8GB SDHC class4 card with two partitions (16MByte FAT12 for CHDK boot version, 7.98GB FAT32 for CHDK full version and storing pictures).
- Despite other posts in CHDK forums my camera does not freeze when only half-pressing the picture button to engage auto-focus
« Last Edit: 27 / February / 2010, 09:30:52 by chrisaal »

Re: The SX1 IS Porting Thread
« Reply #362 on: 04 / March / 2010, 12:20:05 »
Hi all,

First of all, I do congratulate to all who made such a brilliant enhancement to the Canon cameras. I am owner of SX1IS Firmware 2.01A.

I can confirm exactly the same behaviour on my SX1 as described by chrisaal in previous post.
In addition, I have tried this with SD card 4GB with only one partition with identical result.
It is an annoying thing because it prevents you from taking pictures while recording video. It is not so simple to disable chdk from loading on 8GB SD card with two partitions. So I am looking forward for solution of this unwanted behaviour.

Re: The SX1 IS Porting Thread
« Reply #363 on: 04 / March / 2010, 13:11:56 »
I don't know if this is necessary or not, but thought I would throw together a short list of things pertaining to the SX1. I've gone through the thread, and seen this question asked several times.
This is a list of things that are working in the SX1, as well as things that fboesch and pev69 are looking into, as far as I can tell. Please let me know if I am posting in the wrong place. I am not a developer, but wanted to do something to help as I am very grateful to all who have put in the effort to get CHDK up and working on this camera.
First off is the main info from the SX1 wikia:

The SX1 CHDK DOES NOT support the manual loading method through the "firmware update" mechanism !
With CHDK the camera always starts in playback mode; press (or half press) the Shutter once or just hold POWER for ~2 seconds for record mode
As on other newer cameras with 12 bit sensors, the 'Custom curves' feature do not work on the SX1
Due to the special display width (the standard grids are just made for a 320 pixel display), this camera needs modified Grids
When using MD scripts: mask out the outer area to prevent continuous shooting

1. Bad Pixel lua works
2. DNG works, on a Mac, Graphic Converter and the Gimp can read the DNG files, haven't tried anything with Windows, sorry.
3. Grids need to be modified, see post number 274, thanks to lucasflim, his link here: , I also turned off auto rotate under Canon's tool menu, as someone else posted that this could cause problems with the display.
4. I have tried several ubasic and lua scripts, fast motion detection with the above mentioned masking, ultraintervalometer, all the test scripts, everything seems to be working well.
5. Bracketing in continuous mode works
6. Multi-partition support works
7. Disable overrides works
8. long exposures work
9. I haven't yet played with other types of bracketing, ie: focus etc, but assume right now that they work.
10. Have tried several overrides, seem to work.
11. usb remote is reported to be working
12. I had reported that my wireless remote that came with the camera wasn't working at one point, I see now that CHDK has some remote options, don't have my remote with me so cannot check this feature at present.
13. I am trying to report on what I have read, as well as what I have tried myself, it seems that CHDK is "95 %" working on the SX1

Some of the things not working:

1. When shooting continuously, camera can lock up?
2. See above on this page about trying to capture an image while filming a movie. (post 361 by chrisaal)
3. I believe I read about an issue with zebra, but I never had issues, I turned off the Canon Histogram because of screen drawing issues when I tried the histogram and zebra modes, seemed to take care of any issues for me.
4. filming stops quickly when filming high quality outdoors? I haven't played around too much with the video yet, having too much fun with pictures.
5. CHDK does not start with the firmware update method ( I know I'm repeating this, but the question keeps coming up in the thread!)
6. As above, custom curves don't work

I hope it is OK to post this here, to everyone who has put in time and effort on this porting, fboesch, pev69, reyalp, fe50, ewavr, PhyrePhoX, and everyone else who has tested or had input with the port, Thank you for all of your work!


« Last Edit: 04 / March / 2010, 13:32:52 by danstr »
SD780, SX200, SX1, SD890 and SD980 - O.K. Way too many cameras, not enough photos!

Re: The SX1 IS Porting Thread
« Reply #364 on: 30 / April / 2010, 18:33:28 »
Hello all, Ive been away from camera fever for some time but now that I am retaking it I'm interested in one simple feature: Adjustable shutter in video mode.

Is it possible? and if so, what do we have to do to make it work?
Is it about digging in the dump for entry points that change these parameters or it is known and just matter of coding it in c/asm?


Tips on locating RefreshPhysicalScreen
« Reply #365 on: 03 / May / 2010, 06:31:02 »

I am trying to fix a particular bug in SX20IS port - the main CHDK menu does not go away. It seems that the problem is in the address of RefreshPhysicalScreen and/or enabled_refresh_physical_screen (the second is, obviously, easy if you know the first.) I have dumps of SX10 ans SX20 and trying to look for similar calls between those (SX10 is presumably working fine). No luck so far.

Can anybody give a tip how the RefreshPhysicalScreen can be located, e.g. how was it achieved in SX1?

Regards in advance.

Re: The SX1 IS Porting Thread
« Reply #366 on: 19 / May / 2010, 23:37:29 »
Hello, a newbie question. Is remote shooting available for the SX1? And if so, how so?

The tab does not show up in Zoom Browser.

With CardTricks I managed to make a 1GB sd bootable, so as a non programmer, that's progress. Much appreciated if anyone could help answer.

Discovering chdk suddenly alters the horizon.

Also, where can I find the commands, I see ExtraStuff in Reply #358 found the chdk commands in the print menu, I do not see any there. chdk is loading, i get the red insignia on start up sx1-200h-0.9.9-893
« Last Edit: 19 / May / 2010, 23:45:10 by morris »

Re: The SX1 IS Porting Thread
« Reply #367 on: 08 / June / 2010, 01:09:46 »
I tried to install CHDK on my SX1is but I cannot get the "Firm Update" on the Display menu. Any suggestions?
Thanks in advance...


Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: The SX1 IS Porting Thread
« Reply #368 on: 08 / June / 2010, 01:34:05 »
Hello & welcome, amilev !

I tried to install CHDK on my SX1is but I cannot get the "Firm Update" on the Display menu
Manual loading (with "Firmware Update" Menu item) doesn't work with the SX1, you have to use the automatic loading mechanism...

I suggest to use CardTricks to prepare your SD card & to install CHDK...

Re: The SX1 IS Porting Thread
« Reply #369 on: 14 / August / 2010, 09:16:33 »
i'm a pretty happy user of the SX1 IS. Only "pretty" because its sensor leads to noisy pictures combined with a poor noise reduction algorithm...
Fortunately, the CHDK engine allows to use lower ISO values than the officilally available ones (10 or 16 vs 80...). And it allows to reduce the noise very efficiently...

The auto ISO function is very handy for this, allowing to use a wide range of ISO : from 16 to 1250.

I have some issues / questions about this...

The auto ISO works pretty well in AV mode except that the picture is always over-exposed by about 2 EL. That means that i CANNOT under-expose my shots since even at a manual setting of -2 EL, the obtained exposition is equivalent to 0...
-> Is there a way to correct (shifting) the exposition in the CHDK Auto-ISO mode ? I looked at the source code (but i'm not a programer...) and i didn't see this parameter when shooting in auto-ISO mode...

In manual ISO value overriding, the lower ISO value i get is 10, in AutoISO it's 16, even when the minimal set value is 10... -> is that an expected behaviour ?

Thanks for reading this and maybe answering me.
And thanks for all the devs/testers here...

« Last Edit: 15 / August / 2010, 06:09:45 by knib »


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal