Anyone working on the SD780? - General Discussion and Assistance - CHDK Forum

Anyone working on the SD780?

  • 27 Replies
  • 11985 Views
Anyone working on the SD780?
« on: 04 / April / 2009, 00:33:36 »
Advertisements
I have a SD780 and really need to be able to use Usb remote.. is there anyone working on this... I'd love to help. I've been trying to get a Dump of the firmware but not much luck. It wont start with NewDryOS, starts with DryOS and VXWorks but goes right to Locked card..Any Help would be great......
« Last Edit: 04 / April / 2009, 00:36:43 by srunyon1 »

Re: Anyone working on the SD780?
« Reply #1 on: 04 / April / 2009, 01:25:51 »
I found out to get the firmware version on this camera you put the ver.req on the disk then you press the func/set button then the Trash button. at the same time. not the DISP Like other Cams..
my firmware is
                                  GM1.00c

There is also an easter egg there to show the clock as rotating Cubes.. i think that it trash then set/func..
I keep getting it but not sure how...

Re: Anyone working on the SD780?
« Reply #2 on: 04 / April / 2009, 01:31:50 »
looks like you just hold the func key down

*

Offline whim

  • ******
  • 2042
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Anyone working on the SD780?
« Reply #3 on: 04 / April / 2009, 04:55:15 »
Another cam dumped - nice !

If you can, please upload the dump somewhere and post a link to it in this thread:

http://chdk.setepontos.com/index.php/topic,288.0.html


wim


« Last Edit: 04 / April / 2009, 05:35:32 by whim »


Re: Anyone working on the SD780?
« Reply #4 on: 06 / April / 2009, 00:48:20 »
no you miss understood I've tried and tried with no luck.. I need to get a smaller card and try.. but still trying

*

Offline whim

  • ******
  • 2042
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Anyone working on the SD780?
« Reply #5 on: 06 / April / 2009, 03:13:33 »
Ok, sorry ...
Just keep in mind: you said NewDryOS doesn't start, that's a good sign. It *should* appear to be dead - just wait 30 seconds, and remove first battery, then card. Then check the empty.dum
(if you're using CardTricks just press 'Strings' to do that)
[ DryOS and VxWorks versions will show 'card locked': they will cause the cam to start
normally because the 'DISKBOOT.BIN' is not encoded and therefor not recognised as valid ]

wim



 

Re: Anyone working on the SD780?
« Reply #6 on: 24 / April / 2009, 23:31:28 »
Tried using the universal dumper in cardtricks 1.44.
I have a 16GB card so I formatted it with two partitions:
 FAT16 (16 MB)
 FAT32 (rest of card)
Prepared the card by loading the NewDryOS universal dumper onto the FAT16 partition.
The camera "responds" by not starting normally when the write protected card is inserted, so apparently it's reading BOOTDISK.BIN.  :)
So waited the 30 or so seconds.
But...  :( Nothing is dumped to empty.dum. Repeated several times.
Therefore I hash checked the first 24MB of the card (thus encompassing the whole FAT16 partition) before and after booting - nothing is written to it.  :-[
Any ideas how to proceed? Guess some changes are needed in udumper source.
- Louis

*

Offline fvdk

  • ***
  • 146
  • Ixus 70 1.01b / 1.02a & Powershot A590is 1.01b
    • My Flickr photo page
Re: Anyone working on the SD780?
« Reply #7 on: 25 / April / 2009, 00:18:08 »
Tried using the universal dumper in cardtricks 1.44.
I have a 16GB card so I formatted it with two partitions:
 FAT16 (16 MB)
 FAT32 (rest of card)
Prepared the card by loading the NewDryOS universal dumper onto the FAT16 partition.
The camera "responds" by not starting normally when the write protected card is inserted, so apparently it's reading BOOTDISK.BIN.  :)
So waited the 30 or so seconds.
But...  :( Nothing is dumped to empty.dum. Repeated several times.
Therefore I hash checked the first 24MB of the card (thus encompassing the whole FAT16 partition) before and after booting - nothing is written to it.  :-[
Any ideas how to proceed? Guess some changes are needed in udumper source.
- Louis

I too tried to dump the firmware with all the different diskboots that Wim provided but no luck  :-[

Frans


Re: Anyone working on the SD780?
« Reply #8 on: 26 / April / 2009, 00:07:03 »
I picked up one of these (version 1.00C) yesterday and have experienced pretty much the same thing.  No firmware dump yet...

*

freakypriest

Re: Anyone working on the SD780?
« Reply #9 on: 27 / April / 2009, 13:33:15 »
I am also trying to dump this firmware.
I've got an SD780, a 256 MB SD card and a card reader.

Cardtricks 144 does not seem to help. :-(


A question to the pros: The SD780 switches off if you open the lid above the SD card and the battery. Did previous models do that, too? If not, could that be a problem for dumping the firmware?
I ask this because you are supposed to remove the battery before the SD card but if you open the lid the cam switches off. I don't know if this is a problem and I don't know if this happens with NewDryOS where the camera seems dead.
« Last Edit: 28 / April / 2009, 13:15:51 by freakypriest »

 

Related Topics