extra long exposures (split from: Hardcore modding on a A530, thanks to CHDK!

  • 183 Replies
  • 42422 Views
*

Offline fudgey

  • *****
  • 1705
  • a570is
Advertisements
The actual functioning of the code is well over my head though. Why three ports, of which one is clearly a bitmap (configuration port?) Is perhaps the writing order important? What do they control in the first place?

Well, two could be simply because there are two voltages. But the third...

This is just speculation since I just can't know any better without documentation... but one way of doing a simple custom DAC like this in hw would be to connect resistors in series with a few I/O pins and their ends all together to one of the supply voltage CTL pins (and another resistor to ground to have some sane maximum resistance limit during cpu reset and another one to a supply voltage to make the divider complete). Then, pulling a pin down effectively connects one resistor in parallel with the fixed one, changing the CTL voltage. Configuring a pin tristate (or weakly pulled up) effectively disconnects it. Configuring & setting the pin to source from Vdd is the only no good choice here.

The way to configure this I/O pin tristate instead of making it sourcing the cpu's Vdd is likely located in a separate register, not in the same word as the I/O pin state.

Btw I only found two ports being toggled in a570, not three (of course I may have missed something).

*

Offline jetzt

  • ****
  • 316
  • [A710IS,(SD200)]
Maybe an inconvenient question, but I ask it anyway:
Somebody knows where to at least get the schematics for some of the cameras?
I had my A710 open for a few times now, for cleaning, but without some knowledge about how everything is connected, you can only locate the main parts and that's it ...
If I knew where I could make some measurements on this topic.

The long exposures are really fun, but the noise isn't. Thanks however.

i'm interested in getting extra long exposures working on the a650. it was stated that one needs to know asm to be able to add it. i don't know asm but i'll do whatever i can to help implement the feature, including learning asm if someone can guide me through it. (long shot, i know)

*

Offline fudgey

  • *****
  • 1705
  • a570is
A completely untested a650 beta build (I don't have access to an a650) of trunk 766 with extra long exposures can be found here: http://www.zshare.net/download/60731683297146b4/. A diff against svn trunk 766 included.

I can't begin to tell how unsure I am about what happens if you try it, so if your camera is financially crucial to you, wait until someone else does (probably just the usual i.e. it either works or crashes in a way that shuts down the camera with the lens out whenever you attempt to shoot, requiring reboot or even removal of batteries...but don't shoot me if it performs worse than that).

Please test both extra long exposure override, short exposure override, shooting without overrides and also continuous mode shooting.


unfortunately it might take me a little while to get to this. i'm about to deploy my two a650s and due to a lack of work i probably won't be buying any to replace them, well, until i relent.

ewavr

I was wondering if there's a chance that an extended exposure time for the A560 (ver FW: 100a) might be available soon. Thank you a lot ^^
Regards

ravel
atual work with 65s: http://ravelithium.deviantart.com/
« Last Edit: 06 / June / 2009, 18:17:12 by ravelithium »

*

Offline reyalp

  • ******
  • 11443
I've added extra long exposure for a540 in svn 771. Only tested briefly, seems to work.
Don't forget what the H stands for.

*

Offline yvesson

  • ***
  • 207
  • A540 SX10IS
    • poll about some pics (not much serious) ^^
Hej,
Good reyalp, I'll test that soon. Thanks.


*

Offline mngc

  • ***
  • 113
  • a590is fw 1.0.1b & sx110is fw 1.0b
Hi,

@reyalp

My camera is a590is fw 1.0.b. Possibly add support for extra long exposure? Thank.
Very interesting feature for me.

Lajos

*

Offline yvesson

  • ***
  • 207
  • A540 SX10IS
    • poll about some pics (not much serious) ^^
Hej,
Tryed 256s with dark frame substraction, looks kinda clean to me, apart from some dark line middle left of pic.
Tryed also 101s without dark frame, there is millions of hot pixels (expected) but it works fine, good job reyalp.

 

Related Topics