Newbie Help?

  • 4 Replies
  • 730 Views
  • Publish
    Newbie Help?
    « on: 02 / May / 2009, 14:44:06 »
    Advertisements
    I've searched for newbie help in this forum, and I haven't found it, so I decided to post my first question here.

    I've got two Canon Cameras, an A570 and a G7 and I'm trying to determine the firmware version on these cameras.

    I made an empty file named ver.req on the root directory - there is also a folder at that level - more about that later.

    When I put the card into my camera(s) and try to read the firmware version I get version 1.0.1.0 for the A570IS and version 1.0.0.0 for the G7.

    The CHDK section on how to determine the firmware version says that these are not the actual version numbers, and to keep trying until the actual version numbers appear.  I checked that the file name is correct - ver.req and I opened the file with TextEdit (I'm on a mac ) and noticed that there was one invisible character in the file - maybe just a space character, so I deleted that and tried again with the same result.

    The CHDK section on determining the firmware version also said to be sure that the last file on the chip was a picture, not a movie.  I had previously deleted all the pictures with iPhoto, so there were no pictues on the chip.  I shot a picture just to see if that would help. --  at the root directory there is the ver.req file and a DCIM directory.  The DCIM directory has a 102CANON subdirectory and that sub directory has the jpg image in it.

    That still didn't work, so I tried changing the ver.req filename to vers.req and that didn't change the results.

    So I've got a couple of questions
    1) does anyone have any idea of what I'm doing wrong?
    2) is this the proper area for this topic?

    TIA
    dbh512

  • Publish
    Re: Newbie Help?
    « Reply #1 on: 02 / May / 2009, 15:37:34 »
    2) is this the proper area for this topic?


    Try here


    David

  • Publish
    Re: Newbie Help?
    « Reply #2 on: 03 / May / 2009, 08:33:01 »
    Did you make sure that Textedit was in text only unicode 8, and made sure you didn't get a file extension when you saved the file? The first time I tried it with textedit I left it in rich text and just deleted the file extension, and I got the same problem as you. You have to make sure its text only with the right file encoding.
    My Flickr Page
    I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

  • Publish
    Re: Newbie Help?
    « Reply #3 on: 03 / May / 2009, 16:43:28 »
    Thanks for the heads-up, CanonBlue.
    I know that I deliberately deleted the .txt extension when I originally created the file.
    BUT....
    What I didn't know is that Finder on a mac hides all sorts of files and file extensions.  I went to my place of employment and borrowed a PC laptop this weekend, to work on this.
    I quickly found that, indeed there was a .txt file extension on the file that I had created.  There was also a hidden directory for deleted files, and some other miscellaneous junk that I had no knowledge of through the mac's finder - which I assumed was the file manager in Windows.  --- That's been a problem with the mac all along - it makes stuff so "friendly" that I can't get any real work done.  If anyone has any ideas on how to use a mac to see ALL the stuff on a chip I'd be interested.

    Now that I have stripped everything I don't need, including the file extension, I am able to find the real firmware version ( GM1.01A )

    Thank you,
    DBH512


  • Publish
    Re: Newbie Help?
    « Reply #4 on: 03 / May / 2009, 16:49:15 »
    I'm glad you got it to work, but just so you know you can do that on a mac too :-). Deleting the .txt extension apparently isn't the same as making sure it doesn't have one in the first place. What you have to do is first make sure its in the right text-only format (which is under options somewhere) and then when you save it, there's a little box that says something like "add .txt extension if none is specified" and you have to make sure that is UNchecked. Then it will work.

    If you saved it in the proper plain text format, I'm not sure why just deleting the .txt wouldn't work, but I guess it doesn't. I've done that kind of thing before, and usually when I change a file extension it gives me a little warning like "are you sure you want to change the file extension? it will change what program tries to open this file" which shows that it is doing what I want it to do.

    The mistake I made at first was slightly different, I forgot to put it in plain text and I just deleted the .rtf extension. But if it was in plain text I would have thought that replacing .txt with .req would work. In any case, if you do what I described at the top of the post it works.

    I love macs, but I don't know that much about things like viewing all the hidden files on a card. I think you can do everything through the Terminal, but I don't know exactly how to do it.
    My Flickr Page
    I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

     

    Related Topics