Purge RAW not working on my A590 IS, help! - General Help and Assistance on using CHDK stable releases - CHDK Forum

Purge RAW not working on my A590 IS, help!

  • 10 Replies
  • 2694 Views
Purge RAW not working on my A590 IS, help!
« on: 07 / May / 2009, 20:03:14 »
Advertisements
good day all!

i deleted JPEG files using the camera's playback menu but when i tried to purge RAW the DCIM folder using CHDK's file browser, the RAW files are still there. am i missing something?  :-[

installed Autobuild 0.9.8, revision 758 on a 4GB card set to bootable using card tricks (also did the same on my 1GB card, still the same problem)

RAW settings:
Dark Frame Substraction - Off
RAW file in dir with JPEG - On
Bad pixel removal - Off
DNG format - On
'DNG' file extension - On
Raw buffer cached - On

any ideas?

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Purge RAW not working on my A590 IS, help!
« Reply #1 on: 07 / May / 2009, 20:53:12 »
deletes only *.crws, not *.dngs

Re: Purge RAW not working on my A590 IS, help!
« Reply #2 on: 07 / May / 2009, 21:31:28 »
ok, tried it again but this time with the *.crw extension. same result, *.crw still there even without the similar JPEG name.

tried with the *.cr2 extension. RAW files still there.

P.S.
do i have to unlock the SD card to purge RAWs?
« Last Edit: 07 / May / 2009, 21:36:58 by spreketek »

Re: Purge RAW not working on my A590 IS, help!
« Reply #3 on: 07 / May / 2009, 22:03:22 »
update:

Purge RAW now works but only if you are inside the canon folder (104). Purging RAW with the DCIM folder doesn't work... for me at least.

still want to have DNGs purged too. maybe in later builds?


*

Offline wontolla

  • ****
  • 413
  • S3 & G9 & A720
Re: Purge RAW not working on my A590 IS, help!
« Reply #4 on: 08 / May / 2009, 06:07:47 »
Weird, you are right, it doesn't work.

I'll see what I can do this weekend.

Edit:
Should we include DNGs as well in the "purgeification"?
« Last Edit: 08 / May / 2009, 06:10:38 by wontolla »

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Purge RAW not working on my A590 IS, help!
« Reply #5 on: 08 / May / 2009, 06:55:37 »
the purge raw thing was flagged buggy a long time ago, needs reworking thoroughly.
and yes, dng should be included, why not?

*

Offline wontolla

  • ****
  • 413
  • S3 & G9 & A720
Re: Purge RAW not working on my A590 IS, help!
« Reply #6 on: 11 / May / 2009, 12:01:30 »
Yes it is buggy but I couldn't find the reason, it worked in the S3 but not in the A720.
I wrote a new version and updated the old Purge RAW thread

This new version will:

Erase DNGs too.
Show before hand, the amount of memory to be claimed.
Warn you when there are no RAW/DNGs to be erased.

Due to my poor debugging skills, I deleted the function's capability of searching through several folders, which was the faulty bit. It was complex and un-useful in my opinion (I hope no-one misses this).

From now on, you will need to run the function from inside a Canon folder. Remember that you still can keep important RAW files from being wiped out by selecting them before purge.

Any comments/suggestions are welcomed.

The diff file is here.

I hope I can build and upload for people to test. The number of supported cameras has increased and it seems compilation time is huge!   :o

Have fun!

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Purge RAW not working on my A590 IS, help!
« Reply #7 on: 22 / May / 2009, 19:32:09 »
will look into it. can you please attach it to the bugtracker somewhere?


Re: Purge RAW not working on my A590 IS, help!
« Reply #8 on: 23 / May / 2009, 10:37:46 »
wontolla's patch link went down :(

It would be great if we could implement the new version in the autobuilds.

*

Offline wontolla

  • ****
  • 413
  • S3 & G9 & A720
Re: Purge RAW not working on my A590 IS, help!
« Reply #9 on: 23 / May / 2009, 15:12:28 »
The link is working now.

I opened a new issue in the bugtracker including the diff file. I hope I did it right!

 

Related Topics