0 file saved after taking picture - Script Writing - CHDK Forum supplierdeeply

0 file saved after taking picture

  • 4 Replies
0 file saved after taking picture
« on: 08 / August / 2009, 04:16:45 »

Recently bought a Ricoh CA-1 usb remote trigger for my S3IS, have been using CHDK for sometimes but the script is the first time for me.
My question is it seems to me that I can't execute any script listed here, have tried some simple ones but I get "Unexpected symbol near '@' " on the display all the times. So I think every script I tried to launch stuck on the very first line "@title name_of_script". I don't know what did I miss please I need your help, thanks in advance.
« Last Edit: 08 / August / 2009, 12:05:48 by federico99 »

Re: Newbie question about loading the script
« Reply #1 on: 08 / August / 2009, 05:01:28 »
Ok, I found that editing script with windows notepad is a bad idea because windows'  carry/return key can't be recognized by CHDK, more likely the script file should be in linux text file format. I will try ultraedit like software to see the result.


Offline fbonomi

  • ****
  • 469
  • A570IS SD1100/Ixus80
    • Francesco Bonomi
Re: Newbie question about loading the script
« Reply #2 on: 08 / August / 2009, 05:57:32 »
mmhh.. I use notepad very often and don't get this problem...

Re: Newbie question about loading the script
« Reply #3 on: 08 / August / 2009, 07:10:50 »
OK, I download the "Crimson Editor" and save the following lines to "Unix text file format":
@title Remoto
is_key a "remote"
if a=1 then

And the error msg "Unexpected symbol near '@', PRESS SHUTTER TO CLOSE" keeps popping up, but the script does work! Yes, at last I get it works, now I can really try more scripts. Thanks.
-- --------------------------------------------------------Update
Oh, now this is creepy. I loaded the script, clicked the trigger, the camera did take the photo and the red led flashes saying the file is written into the memory card, but then I switched to View mode, there's nothing there! cero files recorded! OMG..... keep trying.....
Ive found the origen of my confusion after the successfully running the Fast MD script, I didn't know the differences between .BAS and .LUA script, and that's why the interperter can't recognize any line I copied. Sorry about that.
----------------------------------------------------------Update & Solved
Allright, I don't know how, but the picture didnt saved is because the "Remote parameter/Remote" hasnt been activated, and maybe because I have activated once from the Script menu but it didnt keep the setting after next camera rebooted, I dont know, but the last time I reactivated the Remote option from Main Menu it's starting to save files for scripts. It's solved then, finally.
« Last Edit: 08 / August / 2009, 12:05:31 by federico99 »


Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: 0 file saved after taking picture
« Reply #4 on: 08 / August / 2009, 09:17:21 »

Just for the file - or if other users stumble over this thread...

  • CHDK scripts are plain text files, the scripts work fine with the Windows CR+LF line endings.
  • The Windows Notepad can be used for editing CHDK scripts without limitations...
  • Just make sure that the file coding is ANSI, NOT unicode !
  • Note: The first line of a script should not be an empty line;
  •         it is also recommended to place an empty line at the end of the script


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal