Motion detection to capture birds - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum

Motion detection to capture birds

  • 14 Replies
  • 5516 Views
Re: Motion detection to capture birds
« Reply #10 on: 31 / May / 2009, 03:53:26 »
Advertisements
Thanks for taking the time to help!

Ok, I put that script on my camera and here are the results:

First of all, I noticed that in all modes I get a red message in the top left corner of the camera screen that says "uBASIC:9 Parse err". I don't think I've ever noticed that before. Did I do something wrong in copying the script?

When in taking pictures mode it produces readable results that stay still:
"No video button.
Rec mode."

When in viewing pictures mode:
The text in the bottom left goes by too fast to really read, but i think it says no video button and then something like mode.

When in video mode:
Text also goes by too fast to read. I think it says no video button and then I think I can catch the words play and mode, but I'm not sure.
Quote
"MDFB script ERROR:"
"Not in REC mode, exiting."
if you are in play mode or if the get_mode command on your camera doesn't work correctly.

I think this matches the error I've been getting from the motion detector script when in video mode. Its difficult to read but I think I have noticed the word exiting. Does that mean that it thinks I'm in play mode when I'm in video mode? Is there some setting that I should change to make it realize its in video mode? I've looked for something like that but couldn't find anything...
« Last Edit: 31 / May / 2009, 03:56:42 by CanonBlue »
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

Re: Motion detection to capture birds
« Reply #11 on: 31 / May / 2009, 08:46:04 »
I also tried this script: http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection
And still no luck. I'm not sure if ANY scripts are working when I'm in video mode. Even the one you gave me to test the mode doesn't seem to work the same there as it does in normal shooting mode.

(Btw is there a reason that the motion detector script I am using, the first one, doesn't seem to be on the main scripts page? I went there to check and I found a different one instead, but I think the one I've been using works better.)
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

Re: Motion detection to capture birds
« Reply #12 on: 01 / June / 2009, 05:08:21 »
(In case anyone else was following this, this problem was solved in the original thread for the MD script. I was able to use an earlier version of the script where you explicitly tell it that you're in video mode.)
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

Canon Powershot A590


Re: Motion detection to capture birds
« Reply #14 on: 04 / June / 2009, 02:57:12 »
Nice! I want to try to photograph hummingbirds this summer, but there aren't any around here right now. So far we have a crow that comes and eats food from our railing, but there have been a few other birds peeking around and trying to get up the courage to come eat too, so maybe I'll be able to get some more interesting photos.

I also had a bit of trouble with the focus sometimes. The ones taken with the other building as a background came out pretty well, but when I aimed the camera with a far away vista as the background, the camera wanted to focus far away and when the bird came and set off the camera, the bird was out of focus. I'm not sure exactly what to do about that kind of thing.
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

 

Related Topics