Using on PS SX1 IS - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Using on PS SX1 IS

  • 15 Replies
  • 5286 Views
Using on PS SX1 IS
« on: 29 / May / 2009, 15:19:17 »
Advertisements
Sorry if this is a stupid question, but I cant seem to get it to load on an SX-1. I read the readme and it says to use the 'firm update' but that didnt work. Then I read on the FAQ's to not use firm update, but didnt say what to use instead. Any input appreciated. Thanks!
Bob


Re: Using on PS SX1 IS
« Reply #1 on: 30 / May / 2009, 04:19:33 »
Do you get a Firm Update option at all in the menus?

Do you have a Mac? If so I might be able to help, but if not then its probably a different problem than what I had.
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

Re: Using on PS SX1 IS
« Reply #2 on: 30 / May / 2009, 15:46:41 »
Hi CanonBlue. I do have the FirmUpdate option, but when I select it, the PS just hangs. this is on a windows machine.

I think when I hit firm update it says 2.0.0 --> 1.1.0  (or something like that).  On the sx1 page it says DONT use firm update though. so how else do I do it?

I also read it needs a 4gb card and I have it on a 2GB. so Ill get a bigger one and try it.

Re: Using on PS SX1 IS
« Reply #3 on: 30 / May / 2009, 15:47:47 »
Ok, in that case I don't know... maybe someone else can help.
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.


Re: Using on PS SX1 IS
« Reply #4 on: 30 / May / 2009, 16:28:19 »
Thanks anyway :)

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Using on PS SX1 IS
« Reply #5 on: 30 / May / 2009, 16:34:50 »
Sorry if this is a stupid question, but I cant seem to get it to load on an SX-1. I read the readme and it says to use the 'firm update' but that didnt work. Then I read on the FAQ's to not use firm update, but didnt say what to use instead. Any input appreciated.

Hi Bob,
since the manual loading method on the SX1 is not working, you have to prepare your card for the autoload method like described here: CHDK wikia: FAQ #17.

For Windows i wrote a pictured installation guide some time ago, you'll find it here: Installing_with_Cardtricks.

Your 2GB Card is ok, no need for a bigger one.
« Last Edit: 30 / May / 2009, 17:48:53 by fe50 »

Re: Using on PS SX1 IS
« Reply #6 on: 31 / May / 2009, 18:29:22 »
Thank you fe50, I really appreciate it! Ill try it tonight or tomorrow and Ill report back :)

Re: Using on PS SX1 IS
« Reply #7 on: 02 / June / 2009, 10:02:58 »
Well I had no luck whatsoever. I tried a new card too. I couldnt get cardtricks to work either... my options were slightly different. The link you sent said to format, where mine said format 32.  Then I download chdk via the button but the chk -> card button never lights up for me to select.  The ONLY way I can get chdk on to the card is my sd card reader. I put it on the root (unzipped of course), and hit firm update, but it freezes up.  Card locked or unlocked, it doesnt matter. This just isnt working for me :(


Re: Using on PS SX1 IS
« Reply #8 on: 02 / June / 2009, 10:05:59 »
by the way its a 32gb card, so I cant autoload it?

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Using on PS SX1 IS
« Reply #9 on: 02 / June / 2009, 13:08:04 »
Well I had no luck whatsoever. I tried a new card too. I couldnt get cardtricks to work either... my options were slightly different. The link you sent said to format, where mine said format 32.  Then I download chdk via the button but the chk -> card button never lights up for me to select.  The ONLY way I can get chdk on to the card is my sd card reader. I put it on the root (unzipped of course), and hit firm update, but it freezes up.  Card locked or unlocked, it doesnt matter. This just isnt working for me :( 

What Windows version do you use ? Win98 or Win ME could have problems with writing the bootable flag...

-> you have to use a card reader, you can't use Cardtricks directly with the camera via USB...
-> the Cardtricks way described in the wikia guide works only with cards up to 4GB !
-> use a card reader, insert the card -> you'll have a drive letter (e.g. "E:") in the Windows Explorer
-> start Cartdricks, select this drive letter with a mouse click to the SD card symbol
-> now you should be able to follow the "Installing_with_Cardtricks" guide...

A SD card bigger than 4GB must be partitioned in a small boot partition (FAT12 or FAT16) and a big data partition with FAT32 format; since this is a bit tricky, you should try it with the small card & Cardtricks...
The preparation of such big cards can be done with the SDM Installer, read more about it here: http://stereo.jpn.org/eng/sdm/index.htm & here: http://stereo.jpn.org/eng/sdm/quick.htm
--> CAUTION: when using this SDM Installer, remove all removable storage like USB pens or
                    hard discs before; ALWAYS check whether the correct drive letter is selected BEFORE EACH mouse click !

Do NOT use the "Firmware Update" method, this do NOT work on the SX1 !

 

Related Topics