DNG - Cannot load CHDK/badpixel.bin - General Discussion and Assistance - CHDK Forum

DNG - Cannot load CHDK/badpixel.bin

  • 14 Replies
  • 6117 Views
*

Offline nemesis

  • *
  • 7
  • Ixus 40 v1.00k
DNG - Cannot load CHDK/badpixel.bin
« on: 09 / June / 2009, 04:06:33 »
Advertisements
I'm trying to enable the DNG format on my Ixus 40 (SD300) v1.00k, but it keeps throwing my the error:
Quote
Cannot load CHDK/badpixel.bin
Please run CHDK/SCRIPTS/TEST/badpixel.lua

I've run the badpixel.lua script three times now, and confirmed that a badpixel.bin file actually does exist in the CHDK folder.  The script reports 0 bad pixels; and the resultant badpixel.bin file is 0 bytes long.

Trawling the forums and google doesn't reveal any solutions other than running the script -- which I've done...

I've also tried modifying the badpixel.lua script to use press("shoot_half"), press("shoot_full") etc, but still, zero byte badpixel.bin, and no DNG.

Anyone have any suggestions?

*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #1 on: 09 / June / 2009, 06:52:48 »
I'm trying to enable the DNG format on my Ixus 40 (SD300) v1.00k, but it keeps throwing my the error:
...
I've run the badpixel.lua script three times now, and confirmed that a badpixel.bin file actually does exist in the CHDK folder.  The script reports 0 bad pixels; and the resultant badpixel.bin file is 0 bytes long.
Trawling the forums and google doesn't reveal any solutions other than running the script -- which I've done...
If you're running a Windows system you can create the badpixel.bin file manually with ewavr's show_bad_b.exe: CHDK wikia: Badpixel_removal.

Since the show_bad_b zip package includes the C source code, you should also be able to compile it on other operating systems like Mac OS, e.g. with the GCC...

*

Offline nemesis

  • *
  • 7
  • Ixus 40 v1.00k
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #2 on: 09 / June / 2009, 09:49:55 »
Strange.  show_bad_b.exe also gives me a 0 byte badpixel.bin.

Given the age of this camera, I find it a little implausible that at least 1 pixel wouldn't have gone bad...

*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #3 on: 09 / June / 2009, 13:40:47 »
Strange.  show_bad_b.exe also gives me a 0 byte badpixel.bin.
Given the age of this camera, I find it a little implausible that at least 1 pixel wouldn't have gone bad...

Show_bad_b gives the pixels which are marked as bad by the original Canon firmware, these pixels were already defective when the camera was manufactured (as described in the wikia article).

The badpixel.bin file is only needed for the DNG creation; you can use a dummy file (just 4 bytes with 0's (zeros)), then you should be able to activate the DNG support - you'll see the bad pixel as black dots in your image then.

Since we have some SD300 users with working RAW and DNG support - maybe there's something other wrong...

Can you try it again, with a fresh formated card & a fresh downloaded CHDK package and the default settings ?
Maybe you can upload a zipped RAW image somewhere...

If this still won't work, i can try to contact a SD300 user with a running DNG workflow to do some tests, maybe there's a problem with the newer CHDK builds...


*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #4 on: 09 / June / 2009, 14:11:27 »
I've compiled & uploaded two unmodified trunk#718 (03-Feb-2009) versions ('complete' packages, all compile options enabled, compiled with gcc 3.4 env) for the Ixus 40 to test whether DNG stuff is working on those "old" version:

   a) #718 package for 100k fw: ixus40_sd300-100j-0.9.6-trunk718-gcc3-full.zip
   b) #718 package for 100j fw: ixus40_sd300-100k-0.9.6-trunk718-gcc3-full.zip

*

Online reyalp

  • ******
  • 12103
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #5 on: 09 / June / 2009, 17:22:09 »
FWIW, the SD300 code has some weird stuff in the capt_seq/raw areas.
Don't forget what the H stands for.

*

Offline nemesis

  • *
  • 7
  • Ixus 40 v1.00k
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #6 on: 21 / June / 2009, 05:54:02 »
The badpixel.bin file is only needed for the DNG creation; you can use a dummy file (just 4 bytes with 0's (zeros)

That worked perfectly.  I've taken a few photos, and can't spot any black pixels in the images.

When I have some more time, I'll give the other debugging stuff a go for completeness.

Cheers

Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #7 on: 08 / February / 2010, 09:47:54 »
I'm trying to enable the DNG format on an SX 200, but I got the error:
Cannot load CHDK/badpixel.bin
Please run CHDK/SCRIPTS/TEST/badpixel.lua

what to do? thanks
(A 410), SX 200, (SX 280), SX 700


*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #8 on: 08 / February / 2010, 10:25:08 »
@mastodon

1) download the User Guide (see link in my signature, PDF file)

2) go to the index on page 1 and you'll see "Bad pixel notes", should be at page 55/56 (in the A4 version)

I couldn't explain it any better than fe50 did there ...

... and the manual should come in handy anyway

have fun,

wim

BTW: - 2 RAW pictures will be taken, takes  30 - 45 sec
        - If "press Set to save ..." does not appear after 45 secs, press <Alt>, wait a sec, and again <Alt>,
          (sometimes a CAnon screen refresh can overwrite the CHDK output, <alt> - <alt> will refresh screen)
« Last Edit: 08 / February / 2010, 10:34:54 by whim »

*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: DNG - Cannot load CHDK/badpixel.bin
« Reply #9 on: 08 / February / 2010, 13:17:18 »
Hmmm...could it be that with "Please run CHDK/SCRIPTS/TEST/badpixel.lua"  the camera is telling you "Please run CHDK/SCRIPTS/TEST/badpixel.lua" ? :D

--> Enable DNG support guidance

 

Related Topics