SX10 motion detection issue - camera power save mode - Script Writing - CHDK Forum

SX10 motion detection issue - camera power save mode

  • 1 Replies
  • 2353 Views
SX10 motion detection issue - camera power save mode
« on: 20 / June / 2009, 22:46:36 »
Advertisements
I just bought a new Canon SX10 IS (V. 1.02B) and am using the only CHDK version I could find for it (from this site: http://mighty-hoernsche.de/). I have a bit of experience with CHDK basics from using it on my S2IS and A710IS.

I'm running the motion detection script from here: http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection although I do realize that my firmware version is not on the supported list. So maybe there's no cure, but I'll try anyway.

The problem I'm having is that the camera goes into 'power saving' mode after just one minute, but I'd like to set the camera up on a tripod running the motion sensing script to try to take shots of birds at my birdfeeder. Obviously with the camera 'shutting down' every minute, this isn't working well. I've referred to the manual and it does state that, even with the power saving function turned off, the LCD (or viewfinder) will turn off after one minute of inactivity. Is there a way to disable this so that I can leave the camera on, running the stript, without it turning itself off?

Thanks in advance for any help!

*

Offline reyalp

  • ******
  • 13448
Re: SX10 motion detection issue - camera power save mode
« Reply #1 on: 20 / June / 2009, 23:49:14 »
I assume you have the CHDK setting "misc->disable LCD off" set to script or alt ?

You could try setting the MD timeout to < 1 minute, and then doing a press/release of some key that doesn't affect anything to simulate activity. Alternately, if you use MDFB http://chdk.setepontos.com/index.php/topic,471.0.html in fast mode, it will keep halfshoot pressed most of the time, which should also trick the camera into thinking it's not idle.
Don't forget what the H stands for.

 

Related Topics