A570is- Latest Build from svn problem resolved (I think...) - AllBest's Builds - CHDK Forum supplierdeeply

A570is- Latest Build from svn problem resolved (I think...)

  • 14 Replies
  • 7906 Views
A570is- Latest Build from svn problem resolved (I think...)
« on: 27 / January / 2008, 18:29:37 »
Advertisements
Hi,

Finally I was able to check latest svn version, after a very busy month.

1) Using video zoom through script: now focus is disabled after zooming. Previously focus was adjusted after every zoom.
I noticed that enabling manual focus (using standard camera button) before using chdk script, enable focus after each zooming.
I made a quick search through code and find an error in generic/shooting.c

void shooting_set_focus(int v, short is_now) {
   if((is_now) && (shooting_get_focus_mode())) {   <--- Wrong. shooting_get_focus_mode() is 0 for normal, 1 for MF.
     if ((!conf.dof_subj_dist_as_near_limit) && (v>0)) lens_set_focus_pos(v);
     else {
        int near=shooting_get_near_limit_from_subj_dist(v);
        if (near>0) lens_set_focus_pos(near);
     }
   }
   else photo_param_put_off.subj_dist=v;


Changed if((is_now) && (shooting_get_focus_mode())) to if((is_now) && (!shooting_get_focus_mode()))
and now I have focus after every zoom.


2) In include/platform.h
#define PROPCASE_MF_ACTIVE 115 is wrong
#define PROPCASE_MF_ACTIVE 133 is correct

I check that propcase 115 is always 0 before shooting in all mode and 1 after half shoot in all mode, but not in movie mode where is always 0.
The value is not modified using MF. I think that it is something as READY TO SHOOT
Propcase 133 is 0 for normal and 1 in MF in all mode included movie mode.

If You want to check the exact focus mode, You must use the propcase 6
It's Values are: 0 Normal Mode, 1 Macro Mode, 4 MF Mode

Another couple of Props are:
props 102: Drive Mode 0 Normal, 1 Continuous Mode, 3 Self Timer Mode
props 122: Flash On 1, Flash Off 0. Check value after half shoot for valid response.

Ciao

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #1 on: 28 / January / 2008, 02:03:06 »
2) In include/platform.h
#define PROPCASE_MF_ACTIVE 115 is wrong
#define PROPCASE_MF_ACTIVE 133 is correct

I check that propcase 115 is always 0 before shooting in all mode and 1 after half shoot in all mode, but not in movie mode where is always 0.
The value is not modified using MF. I think that it is something as READY TO SHOOT
Propcase 133 is 0 for normal and 1 in MF in all mode included movie mode.

If You want to check the exact focus mode, You must use the propcase 6
It's Values are: 0 Normal Mode, 1 Macro Mode, 4 MF Mode

Another couple of Props are:
props 102: Drive Mode 0 Normal, 1 Continuous Mode, 3 Self Timer Mode
props 122: Flash On 1, Flash Off 0. Check value after half shoot for valid response.


Ok, PROPCASE_MF_ACTIVE is unnecessary (because PROPCASE_FOCUS_MODE exists).
Value #115 for PROPCASE_FOCUS_MODE based on A720. It seems that A720 have slightly different PropertyCase set (also #49 for shooting mode) and needs own branch in platform.h
PROPCASE_FLASH_MODE #143 also A720 based (on,off,auto).
And what about PROPCASE_IS_FLASH_READY for A570 (#208 for A720) ?

Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #2 on: 28 / January / 2008, 09:25:09 »
I checked dump and found that propcase 122 is the candidate to IS_FLASH_READY


It is used in aFlashdecision and in aErrorGetflashd. There are other proces involved such as

Ciao

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #3 on: 28 / January / 2008, 09:33:39 »
I checked dump and found that propcase 122 is the candidate to IS_FLASH_READY

Ok, how about PROPCASE_FLASH_MODE (#143 for A720)
0 - flash auto
1 - flash on
2 - flash off


*

Offline quietschi

  • ***
  • 116
  • Ixus70 102a
Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #4 on: 28 / January / 2008, 09:45:02 »
Hi

propcase 122 imo is flash used (0,1 yes or no)
propcase 208 seems to be is flash ready

btw. here are some props we found on digicIII base cameras(SD1000)
http://chdk.wikia.com/wiki/PropertyCase

quietschi

Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #5 on: 28 / January / 2008, 11:31:03 »
Hi,


I checked code and found that 208 is present in aSsprepreseq_c and other Asxxxx subs.

This are routines used for shooting and I think You are right.

Ciao



*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #6 on: 29 / January / 2008, 09:32:46 »
Sorry, I am very confused.

Please, can somebody specify this values for A570/A560?

#define PROPCASE_FLASH_MODE ??
#define PROPCASE_IS_FLASH_READY 208 ??
and
#define PROPCASE_SHOOTING_MODE  0 or 49??

Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #7 on: 30 / January / 2008, 08:02:22 »
I think valid values are:
 #define PROPCASE_SHOOTING                  206
 #define PROPCASE_IS_FLASH_READY                208
 #define PROPCASE_SHOOTING_MODE                             49  checked only in camera

And what about shooting_set_focus error ???


Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #8 on: 30 / January / 2008, 08:20:48 »
And what about shooting_set_focus error ???

There is no error. AllBest did it intentionally:

Hi AllBest,

I got focus distance override and bracketing working on the IXUS800 with your build 11 by making this little change:
void shooting_set_focus(int v, short is_now) {
   // if((is_now) && (shooting_get_focus_mode())) {
     if((is_now)){

Unfortunately most of the cameras hangs up when we do "set_focus" not in the manual focus mode...

I think cameras that support manual focus mode require manual focus mode to not hang.
But why not a config menu entry: focus distance override and bracketing requires manual focus mode?
Could be default disabled for IXUS/A560 and enabled for all others, so everyone can try.

« Last Edit: 30 / January / 2008, 08:28:48 by nirschi »

Re: A570is- Latest Build from svn problem resolved (I think...)
« Reply #9 on: 30 / January / 2008, 18:37:59 »


Unfortunately most of the cameras hangs up when we do "set_focus" not in the manual focus mode...

I think cameras that support manual focus mode require manual focus mode to not hang.
But why not a config menu entry: focus distance override and bracketing requires manual focus mode?
Could be default disabled for IXUS/A560 and enabled for all others, so everyone can try.



This is not true. My camera (A570is) support manual focus and do not hang doing "set_focus" when camera is not in MF.

I agree that a config menu entry could be a good solution.


 

Related Topics