Canon G9 and trigger issue - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Canon G9 and trigger issue

  • 12 Replies
  • 4929 Views
Canon G9 and trigger issue
« on: 27 / July / 2009, 08:04:22 »
Advertisements
Hello experts :-)
Currently using a canon G9 for aerial but have some probs. I control the trigger and settings thru a remote system by usb interface (vp-systems camremote2). First of all the I just found that when controlling the camera thru the usb the RAW settings wont work . And some other settings like TV and Av goes half auto so my shuttertimes goes high and result is fuzzy pics. Its all mounted on a askman 50 with pan and tilt.

So for testing, I downloaded and installed CHDK for the G9 (http://chdk.wikia.com/wiki/Downloads)(latest version)
Managed to configure it all, the camera with the CHDK and the remote control. The camremote "talks" to the G9 but.. when I trigger the shutter from my TX, it "only" focuses but doesnt take the picture.. like if the impulse was wrong or to "short/small".. Is it possible to configure the pulse, and if so to what and where? The CHDK seems to "take" over the settings as I wanted, so thats fine! Manual picutres works perfect with the CHDK and all the settings I made.
Tried different values from the TX, from 90% to 135%, same.. VP-systems camremote2 has an usb/chdk configuration, could it be in that, meaning needs software change?

Or better ideas? Scripts?

Thanks for all help an ideas.
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount

Re: Canon G9 and trigger issue
« Reply #1 on: 27 / July / 2009, 08:29:35 »
I am not very familiar with the basic CHDK but I think there is an option to enable a 'fast' trigger mode where the photo is taken as soon as a USB high voltage is detected.

Normally, first on/off pulse focuses and second triggers.

Re: Canon G9 and trigger issue
« Reply #2 on: 27 / July / 2009, 09:17:43 »
Thanks Microfunguy... but cant find anything like that in the menus.. :-(
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount

Re: Canon G9 and trigger issue
« Reply #3 on: 27 / July / 2009, 09:30:26 »
What G9 firmware version do you have ?


Re: Canon G9 and trigger issue
« Reply #4 on: 27 / July / 2009, 09:42:19 »
GM1.00H,
April 2008
Adj Ver. 008.005
Havent upgraded build-in firmware, should I?
(and if I manually start the CHDK the menu says: 1.0.0.0->1.1.0.0)
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount

Re: Canon G9 and trigger issue
« Reply #5 on: 27 / July / 2009, 09:47:38 »
Adj Ver. 008.005
Havent upgraded build-in firmware, should I?


I do not think you need to.

We will soon find out.

Replace DISKBOOT.BIN with this version :-

http://www.zshare.net/download/63230034fe6ee80e/

In Bracketing/Overrides menu set focus-mode to 'manual'.

(it does not actually put your camera into manual focus mode, it is a little 'trick').

At top of screen it should say FAST.

That means a photo will be taken as soon as USB pulse detected.


Does it work ?

Re: Canon G9 and trigger issue
« Reply #6 on: 27 / July / 2009, 10:02:55 »
Thanks mate, but no.
The "fast" appears and the cam tries, but stops with the focus fix and then goes back.. if I keep holding the trigger, manuel on this HW (camremote2) or the TX, it does the same.
Im running the lastest chdk, maybe I should try elder ones?
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount

Re: Canon G9 and trigger issue
« Reply #7 on: 27 / July / 2009, 10:18:13 »
Hold abit now!.. After couple of reboots, removing the card for RAW checks etc... it works.. lol.. :)
Thanks very much!
Going to do some tests... I'll back here.

Is it OK to go with this chdk?
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount


Re: Canon G9 and trigger issue
« Reply #8 on: 27 / July / 2009, 10:19:53 »
that really should work, I have just tried with my A620 and a simple USB remote switch.

People use that mode with Aurico and the gentLES receiver with the single pulse-width output.

Plug your camera into your PC, it should take a photo immediately.

EDIT:

OK, posted as you replied.

If you want to hide the header at the top of the screen, in menu Stereo \SDM Header choose none or compact.

You have a new option in the Advanced\OSD Parameters\Zoom value, you can display horizontal field-of-view in degrees.

As to whether it is OK to use that version, you tell me  :)
« Last Edit: 27 / July / 2009, 10:23:11 by Microfunguy »

Re: Canon G9 and trigger issue
« Reply #9 on: 27 / July / 2009, 10:32:16 »
Thanks alot mate.
Just took it for a ride and good damn it works!
Its a biiit slow with RAW of, but hey, this ait the fastest camera and I bet I could get a better SD card, wich will be done tomorrow! The most and best is:
TV, AV and RAW + trigger now works as it should, controlled by ME!
Found 1 more future, if I do a fast trigger on my radio the camera locks and wait until next trigger and it snapps faster then ever :-) Perfect for aerial with vibrations etc!

Thanks again.. so strange.. here I am in Sweden.. novice and kinda... lost.. and hour later, its all fixed, all beacuse of a friendly internet friend! :-).. the power of wiki, forums and search tools :-)... oh well computers aswell ;-)
Into this AP.. G9 hooked up on a raptor e620 with vp-systems and askman lp50 mount

 

Related Topics