Unable to Download Photos Through USB Connection: Solved - General Help and Assistance on using CHDK stable releases - CHDK Forum

Unable to Download Photos Through USB Connection: Solved

  • 0 Replies
Unable to Download Photos Through USB Connection: Solved
« on: 21 / August / 2009, 13:53:51 »
Many months ago, I upgraded the camera to a newer firmware version (earlier than that listed above), did the special formatting on the 8GB card using Ubuntu ( to autoload CHDK on power up and utilize the full card). I was able to power up the camera in "view" mode, connect to the PC using the camera's USB cable, and offload photo using the normal Windows offload capability on both my Vista and XP machines. Now, both PC's refuse to acknowledge the camera on power up.

  • Unlocking the card causes stock firmware to load, and the PC recognizes the 25MB partition.
  • Switching USB ports doesn't work.
  • Using the CHDK menu choice to reset to default settings doesn't work.
  • By booting PC to ubuntu and removing the SD card and placing it directly into PC, I can see the 2nd partition, and I can obtain photos that way.
  • I grabbed 2 of the latest firmware versions, and neither was able to successfully announce itself to the camera.

Camera and OS Details
PowerShot A650IS
Firmware: a650-100d-0.9.8-791
8GB, dual partition (25MB, 7.75GB)
OS: Vista SP2, WinXP

While typing up this list, I realized the one thing I forgot to do was to upgrade the firmware on both the partitions of the SD card. Once I did this, the OS recognized the camera just fine. So, if you have more than one partition on your SD card, be sure to upgrade the CHDK installations on both your partitions.


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal