SX200is Porting - page 13 - DryOS Development - CHDK Forum supplierdeeply

SX200is Porting

  • 1105 Replies
  • 414504 Views
Re: SX200is Porting
« Reply #120 on: 31 / August / 2009, 13:45:43 »
Advertisements
Darkness,

congrats  :D

So no small screen issues anymore? Cool ;)

*

Offline Darkness

  • **
  • 72
  • SX200IS 100D
Re: SX200is Porting
« Reply #121 on: 31 / August / 2009, 14:03:49 »
concerning the  ? 0x1000000 : 0x2000000;   or    ? 0x2000000 : 0x1000000; issue...

with the former, my lense comes out (always, even when pressing play), with the latter it does not.
SX200IS 100D

*

Offline Darkness

  • **
  • 72
  • SX200IS 100D
Re: SX200is Porting
« Reply #122 on: 31 / August / 2009, 14:06:17 »
So no small screen issues anymore? Cool ;)
that may be caused by the difference in 100C and 100D, since I did not change anything compared to oldGits code...
SX200IS 100D

Re: SX200is Porting
« Reply #123 on: 31 / August / 2009, 14:48:14 »
btw i had just a quick look on the svn...do you really use the lib.c in sub/100d?
if that is the case and everything works then vid_get_viewport_live_fb() and vid_get_viewport_fb_d()
aren't used because they are from SX10  :)

tr1stan


*

Offline Darkness

  • **
  • 72
  • SX200IS 100D
Re: SX200is Porting
« Reply #124 on: 31 / August / 2009, 15:50:32 »
btw i had just a quick look on the svn...do you really use the lib.c in sub/100d?
if that is the case and everything works then vid_get_viewport_live_fb() and vid_get_viewport_fb_d()
aren't used because they are from SX10  :)

tr1stan
No, the files in 100d dir are mostly from sx10, I imported those first to easily compare some files (using tortoiseSVN. Just use the code from the 100C folder for now.

I just checked though, if I use OldGits code, but with lib.c from sx10, the chdk seems to boot, but the chdk menu does not work. However, I can see that it's active because my lens comes out and it does not shutdown if I go to ALT mode (I have to press it again to be able to shut down, so keyboard works in this case).

So far, I have been unable to find differences between the 100c and 100d firmware (also confirmed by the fact that the 100c code runs on 100d)

For those that are more familiar with chdk, I uploaded a compiled diskboot.bin to http://drop.io/sx200is_100d so they can experiment with it and perhaps provide usefull information about stuff that works or does not work.

selecting a specific feature in the menu does not seem to work in most cases, the reversi game works  :)
menu dissappears sometimes (looks like the screen refreshes and redraws background), scrolling makes it reappear.

OldGit, very impressive work I must say.
SX200IS 100D

Re: SX200is Porting
« Reply #125 on: 31 / August / 2009, 17:02:08 »
I 've tested the disknoot.bin from obove.
The Cam starts and make the Firmupdate. It schows the CHDK Logo, but to small.
No Funktion with the PRINT Button.

Smartkiller
SX200 IS Firm. 100c
SX1 IS Firm. 201a

*

Offline Darkness

  • **
  • 72
  • SX200IS 100D
Re: SX200is Porting
« Reply #126 on: 31 / August / 2009, 17:43:18 »
I 've tested the disknoot.bin from obove.
The Cam starts and make the Firmupdate. It schows the CHDK Logo, but to small.
No Funktion with the PRINT Button.

Smartkiller
It shows something orange during bootup, can't even read what...
When I press print button, I think "Default script  ALT" text appears (battery is dead, can't verify)
When I press menu afterwards, I get the chdk menu.
SX200IS 100D

Re: SX200is Porting
« Reply #127 on: 31 / August / 2009, 17:49:57 »
I think that is the Firmware difference. My Cam has Firmware 100C! It makes nothing by Pressing the PRINT Button.

My SD-Card in no bootable and i start the diskboot.bin with Firmware Update.


When i make the SD Card bootable and Lock the write safe, the Cam starts with CHDK and i became the Menu by pressing the Print Button.

Smartkiller
« Last Edit: 31 / August / 2009, 18:00:54 by smartkiller »
SX200 IS Firm. 100c
SX1 IS Firm. 201a


Re: SX200is Porting
« Reply #128 on: 31 / August / 2009, 19:27:50 »
Don't know if this is known info, but according to Canon Support the only difference between 100C and 100D is a minor issue in the language selection menu.

Anyway, as a newcomer, and a happy SX200 owner, I'm looking forward to trying this fine piece of software.
(btw, I own a Nissan 200SX also..:p)

*

Offline OldGit

  • ****
  • 303
Re: SX200is Porting
« Reply #129 on: 01 / September / 2009, 01:02:26 »
... according to Canon Support the only difference between 100C and 100D is a minor issue in the language selection menu.
Thats good news, thanks.
Quote
(btw, I own a Nissan 200SX also..)
Don't think we can hack that, ......but then again......  :D

OK guys, so where are we,  it seems to work, kind of,
we think 100D and 100C are the same for the most part,
but we get different results on the display ??
What we know / don't know...
I can't find any data on what CCD Canon used in this Cam, I don't think they make the CCD so maybe we can find data from a supplier.
Sensor size we know 1 / 2.3
12.1 MP
The 230K pixels screen res advertised by canon (actually sub-pixels, as in each is a single R, G or B)
Screen size 3"

Given this and the buffer address we should be able to work this out, so why the *@#**$ can't I see it.

I don't think the 960 size I set in lib.c is correct, I used it just to get something on screen.

As the OSD debug and script driven data dumps are working, maybe I can use them to gain some more info,

Do we have scripting guru amongst us ?.

On other things, any know how to get the usb flag value from OSD debug ?, the screen shuts off when I connect a powered cable.
And what do all of you think about linking the popup flash to the canon flash setting.
If we could hook the call to strobe up / strobe down then we could test the value of the canon setting,
If not off then up, else skip call.

Well enough dreaming, the day job calls.
OldGit
SX200 IS-100C

 

Related Topics