IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread - page 3 - General Discussion and Assistance - CHDK Forum

IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 161414 Views
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #20 on: 15 / August / 2009, 22:50:48 »
Advertisements
There will be a dump shortly.  I have some space I'm gonna start placing stuff for my attempts.
Canon Models - SD300, SD780, & SX210

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #21 on: 18 / August / 2009, 19:03:31 »
For webspace you can upload file on www.megaupload.com

Great work!!! :)
« Last Edit: 18 / August / 2009, 22:28:31 by Mongomeri »

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #22 on: 19 / August / 2009, 18:42:36 »
@HarpMa: Is it possible for you to upload your current version to the svn-server? Because I think the sd1200 I am working on is similar to sd780.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #23 on: 19 / August / 2009, 19:40:39 »
I'll post it to my site but as for placing in svn i think it's too early.  Doesn't get very far yet.  But for reference I can make it available...

Harpo
Canon Models - SD300, SD780, & SX210


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #24 on: 20 / August / 2009, 00:26:52 »
I do not suggest anyone other then a developer even look at this link.  It will ONLY show your a logo.

{modified - removed URL since topic top now includes it}

Also, don't do a make clean.  If you do then the stubs are likely going to break.  I have not followed multiple guidelines on the making of this.  
« Last Edit: 08 / September / 2009, 15:18:24 by HarpoMa »
Canon Models - SD300, SD780, & SX210

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #25 on: 21 / August / 2009, 16:54:42 »
[Off-Topic - but I don't know where to direct this question. Promise to keep it short.]

After the last weekend and quite a lot of videos I realized that there is no auto-focus while taking a video. I couldn't belief this and called Canon today. Support employee #1 supposed my cam to be defective and advised me to send my camera to a local hardware contractor. Contractor #1 told me that this is totally normal. Called Canon again. Support employee #2 confirmed this. And stated, that this is true for many/most Canon cams. I still can't believe this.
(Meanwhile I found the Video Parameter: AF key that might be a workaround)

Can someone confirm, that this cam can't auto-focus while taking a video?

Jens

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #26 on: 21 / August / 2009, 19:29:15 »
Yes.
It looks strange but it's true and is clearly stated in Users Manual.
AFAIK it can be fixed for other camera models with CHDK.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #27 on: 22 / August / 2009, 14:59:05 »
Yes.
It looks strange but it's true and is clearly stated in Users Manual.
AFAIK it can be fixed for other camera models with CHDK.

I read the manual before I bought the cam. Didn't get that.

Now keeping my fingers crossed a bit more, while waiting for a beta firmware,

Jens


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #28 on: 30 / August / 2009, 17:24:03 »
With my SD1200IS udumper is not working, because the sequence of bytes 0000 0000 0000 0000 0000 0003 ... followed by adresses greater than MIN_ADDRESS (firmware jumps) has not been found:
Code: [Select]
#define MIN_ADDRESS     0xFF810000
...
for (i=0x1900;i<0xF0000;i+=4) {
if ((*(unsigned int*)(i+0x34)==0) &&
(*(unsigned int*)(i+0x38)==0) &&
(*(unsigned int*)(i+0x3C)==3) &&
(*(unsigned int*)(i+0x4C)>MIN_ADDRESS) &&
(*(unsigned int*)(i+0x50)>MIN_ADDRESS) )
{
...
}
}
Any ideas modifying the udumper to work with SD780IS? Then I would like to try it on my SD1200IS.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #29 on: 30 / August / 2009, 19:57:18 »
I never used the udumper for the SD780.  It may help to take the FW for the sd780 and look for the pattern of bytes around the functions required to fopen/fwrite/fflush/fclose   Not certain if you can perform them that early in the boot cycle but might be worth a try.  Note of course that the SD1200 will NOT have the same position for the functions.  Only the pattern might match.

For the SD780 I dumped the first firmware with the blinker program (ie serially blink the firmware to the LED)  For the second FW dump (8M version) I used the fopen/fwrite/fflush/fclose.
Canon Models - SD300, SD780, & SX210

 

Related Topics