IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread - page 43 - General Discussion and Assistance - CHDK Forum  

IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 224069 Views
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #420 on: 21 / March / 2010, 16:13:31 »
Advertisements
I've tried the 882 version, and as always I accidentally loaded it from AUTO mode, please do something about it!!!
So after restarting my camera in P mode:

I noticed that: when AWB is balancing, then preview lags a little bit, so some part of code needs some cleaning...
BASIC script with Focus control still crashes and turns off... (This script: http://armanbohn.com/blog/?p=93)
Motion Detection WORKS!!! Hooray!!!
The Unidentified image bug I mentioned before still exist, but it only shows up in 640 and 320 mode.
RAW is working (even shows up in Photo Shop), I'm not sure, but it looks like Bad pixel removal doesn't work, tomorrow I will try to make a new badpixel.bin

Regards, Ignas

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #421 on: 21 / March / 2010, 18:10:33 »
@ignasx - No idea what you are talking about in your first comment.  You are welcome to fix the issue if you are in such a dire need for it.  Second comment you need more clarity.  "AWB is balancing..." I don't know specifically what you are refering to.  RAW/DNG does take a bit to write an image is that what you are talking about?

BASIC script - I'll look at that.
Unidentified image - I'll see what I can see now that I know it's only under certain modes.
Bad pixel - one day I will test it.

Harpo
Canon Models - SD300, SD780, & SX210

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #422 on: 21 / March / 2010, 18:13:08 »
@danstr - no problems I'm happy to fix stuff I certainly don't use much of the functions of chdk so I don't know what all is broke all the time.  I will address this issue when I manage to find why it's an issue.  LOL
Canon Models - SD300, SD780, & SX210

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #423 on: 21 / March / 2010, 18:59:32 »
@HarpoMa
Thanks Jason, really it's only an issue in that different preferences can't be saved as a set of preferences. The script's default settings can be changed when saving the script on the computer, it just means saving a separate script for each set of differing parameters, instead of being able to save different parameter sets within the script as is usually the case. To be honest, I haven't tried the latest build on my other cameras, it may be chdk related, not sd780 related. Build 881 on my sd890 saves the parameters.  I'll let you know what I find.
(edit) The script parameters are saved on my sd890 with build 882, but not on the sd780, I even tried the script by placing it in the main script folder thinking that might make some difference, I'm not sure why I thought that.
The sd780 does work with multipartition on an 8GB card, in regards to needing verifying on your first post. Except for the issue I mentioned, basic scripts work, and I notice I no longer need to remove the bit in Lua scripts that I had to before, the part that checks for recording, badpixel.lua worked "right out of the package".
I also notice that the numbers do not show anymore when scrolling up in the menus as well.
Nice job! :D
Dan
« Last Edit: 22 / March / 2010, 10:56:43 by danstr »
SD780, SX200, SX1, SD890 and SD980 - O.K. Way too many cameras, not enough photos!


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #424 on: 21 / March / 2010, 19:21:46 »
Hi all - 1st post on the forums but been lurking for a while now. Just wanted to say that as a complete newbie, I've successfully loaded the beta and it works great.

Still getting to grips with all the functions, but already just having the shutter speed override is amazing.

HarpoMa et al.... legends, the lot of you!!! Thank you!

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #425 on: 21 / March / 2010, 22:11:15 »
« Last Edit: 21 / March / 2010, 22:15:25 by gonzalito »

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #426 on: 21 / March / 2010, 23:06:36 »
Another silly question...
On the sx200 I can use zoom while taking photos in chdk. Any idea if that can be implemented in the sd780? AFAIK the other cameras probably don't do this, I've tried chdk on 5 in all, and the sx200 is the only one I own that I can do this on.
This is more of a side note than an actual request, Jason.
Dan
SD780, SX200, SX1, SD890 and SD980 - O.K. Way too many cameras, not enough photos!

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #427 on: 21 / March / 2010, 23:47:58 »
@danstr - Can you describe more of the "zoom during photo"  As I don't have an sx200 I don't know what precisely you refer.  You don't mean movie because I know that works.  If its a script that where I'll be heading next so just provide the script you use and I'll debug with it.

@gonzalito - I don't know if it's possible but one of these days I will try to get further into the movie stuff.  I have done some research (and have likely caused the unidentified image bug) in the process.  :)
Canon Models - SD300, SD780, & SX210


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #428 on: 21 / March / 2010, 23:57:45 »
@HarpoMa
Not a script, and not in movie mode, just taking photos on the sx200, the zoom works, it might have something to do with the motor Canon uses in that camera. In CHDK on the sx200 you can sort of half push the zoom lever that surrounds the shutter button, and zoom in and out to shoot pictures. If you push all the way side ways, it steps in small increments. Kinda handy, actually. That camera has the print button, and that is the alt button, so you don't have to back out of CHDK, zoom and then press print to get alt again, like I have to with other cameras, or disp on the sd780, it just works while in alt.
Be kind of neat to add that capability to chdk for all cameras. Maybe the sx200 porting enabled it somehow?
Dan
SD780, SX200, SX1, SD890 and SD980 - O.K. Way too many cameras, not enough photos!

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #429 on: 22 / March / 2010, 07:10:00 »
Thanks a lot for your effort, HarpoMa :)

I also wanted to ask you about "Video quality" option. In SD400, i.e. , members saw see big improvements in picture quality and data rate when increasing this option (to full 99%). Would you work on that feature in the SD780?

Thanks again!

 

Related Topics