IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread - page 66 - General Discussion and Assistance - CHDK Forum

IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 185717 Views
CHDK badpixel.bin creation issues with newer builds
« Reply #650 on: 31 / July / 2011, 19:59:29 »
Advertisements
I just wanted to mention that the new CHDK build that waterwingz created for SD780IS 100c cameras fixes the disappearing OSD Menus problem.

However, I noticed that when I upgraded to the latest build CHDK fails to create the badpixel.bin file and reports an error after taking two photos during the badpixel creation process. My camera is a SD780IS 1.00C. The problem also occurs with the July 31, 2011 ixus100_sd780-100c-0.9.9-1258-full_BETA.zip build.

The error message is:
badpixel.bin failed.
Please try again.

On my previously installed version of CHDK (build 0.9.9-1143) the "Create badpixel.bin" menu item worked fine. Back in April 2011 I even did a blog post about creating CHDK raw DNG images.

Here is the version info for an older CHDK build that successfully created badpixel.bin files:
Ver: 0.9.9-1143
Date: April 13, 2011
Camera: ixus100_sd780
FW: 100c

For testing purposes I unzipped a fresh copy of the old April 13, 2011 CHDK 0.9.9-1143 build and tried it on my camera and was able to properly create a badpixel.bin file using the Raw Parameters "Create Badpixel.bin" command. It worked normally and reports:

badpixel.bin created
bad pixel count: 6484

Regards,
Andrew
Canon SD780IS

*

Offline reyalp

  • ******
  • 12725
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #651 on: 31 / July / 2011, 23:19:49 »
the "badpixel.bin failed." message happens when the counts don't match between images. Sometimes this can happen due to changing conditions, like the sensor warming up between shots. That's why it says try again.

If the latest version really fails all the time, that would be odd. Something unexpectedly modifying raw buffer memory could cause this I guess.
Don't forget what the H stands for.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #652 on: 01 / August / 2011, 03:33:03 »
I can confirm that the patch is working!

I tested with SD780 - Firmware 1.00B.

It is an improvement, no disappearing menu and I can switch between the menus. Video mode is available now, too.

Thank you waterwingz.
« Last Edit: 01 / August / 2011, 03:35:43 by Cloud »
Canon SD780 (Ixus 100 IS) - FW 1.00B

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #653 on: 01 / August / 2011, 11:17:08 »
I've been away this last week, but it's nice to return and see this thread back to full activity. Tonight I'll download the latest release and experiment for a while.


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #654 on: 01 / August / 2011, 15:33:12 »
However, I noticed that when I upgraded to the latest build CHDK fails to create the badpixel.bin file and reports an error after taking two photos during the badpixel creation process. My camera is a SD780IS 1.00C. The problem also occurs with the July 31, 2011 ixus100_sd780-100c-0.9.9-1258-full_BETA.zip build.

I tested to create badpixel.bin using the 1.00B firmaware version and it is working. It took 2 pics and then created the badpixel file. I was able to turn on the DNG format with no problem after that. Not sure if there is a problem with the 1.00C version???

*

Offline openuas

  • **
  • 57
  • OpenUAS
    • OpenUAS
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #655 on: 11 / August / 2011, 17:30:47 »
Well since I have also a IXUS100IS version 100C among my camera collection I can perform a badpixel  :blink: test.

Q: Will latest autobuild be OK or do you want me to test a specific version? Then I'll report back the result.

*

Offline reyalp

  • ******
  • 12725
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #656 on: 11 / August / 2011, 23:12:25 »
Well since I have also a IXUS100IS version 100C among my camera collection I can perform a badpixel  :blink: test.

Q: Will latest autobuild be OK or do you want me to test a specific version? Then I'll report back the result.
Try the latest version.
Don't forget what the H stands for.

*

Offline openuas

  • **
  • 57
  • OpenUAS
    • OpenUAS
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #657 on: 12 / August / 2011, 09:01:32 »
Tested on ixus100_sd780 FW Vers 100c 0.9.9-1286 Aug 8 2011 22:16:51 (GCC 4.4.3)

Ran the badpixel LUA script, got some result. Script ran but could not find any badpixel.bin on my SD although it stated it wrote the file and I had 255 bad pixels. I do however had two files CRW_0155.CRW and CRW_0156.CRW in the directory /DCIM/100CANON/

Since I've never had a need to use the badpixeltest I'll read through http://www.andrewhazelden.com/blog/2010/02/enabling-chdk-raw-images-on-the-canon-sd780is/ then see if I can get more results.

BTW how do I know if I have the correct badpixel.lua file?
« Last Edit: 12 / August / 2011, 09:08:11 by openuas »


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #658 on: 12 / August / 2011, 11:20:33 »
Actually you want to use the built-in Create badpixel.bin feature in the RAW menu. You no longer need to use the .lua script. I wrote an updated blog post here Enabling RAW DNG Images With CHDK.





Tested on ixus100_sd780 FW Vers 100c 0.9.9-1286 Aug 8 2011 22:16:51 (GCC 4.4.3)

Ran the badpixel LUA script, got some result. Script ran but could not find any badpixel.bin on my SD although it stated it wrote the file and I had 255 bad pixels. I do however had two files CRW_0155.CRW and CRW_0156.CRW in the directory /DCIM/100CANON/

Since I've never had a need to use the badpixeltest I'll read through http://www.andrewhazelden.com/blog/2010/02/enabling-chdk-raw-images-on-the-canon-sd780is/ then see if I can get more results.

BTW how do I know if I have the correct badpixel.lua file?
Canon SD780IS

*

Offline openuas

  • **
  • 57
  • OpenUAS
    • OpenUAS
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #659 on: 13 / August / 2011, 05:24:43 »
Thanks, tested Tested on ixus100_sd780 FW Vers 100c 0.9.9-1286 Aug 8 2011 22:16:51 (GCC 4.4.3)  with the build in badpixel routine. And indeed I got a ~1.2.6Kb badpixel.bin file. Examined with a Hex editor, looks right since the file probably contains positions in 4Bytes then filesize / 4 gives the about bad pixels ~3200bad pixels. If more help testing the badpixel routine let me know.

Still very happy the firmware for this version is created, thank to all!

 

Related Topics