IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 147316 Views
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #670 on: 18 / June / 2013, 18:52:33 »
Advertisements
This is probably in the wrong thread

Sorry, I forgot to mention, this specifically refers to the IXUS100.

A user said neither the SDM or CHDK versions worked like that.

If so, either the ram address is incorrect or that article is incorrect.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #671 on: 18 / June / 2013, 21:03:36 »
This is probably in the wrong thread
Sorry, I forgot to mention, this specifically refers to the IXUS100.
A user said neither the SDM or CHDK versions worked like that.
If so, either the ram address is incorrect or that article is incorrect.
Easy enough to check - ask your user to take two 30 second exposures - one with dark frame on and the other with dark frame off.  Observe whether the total save time is 60 seconds or 30 and you'll know if they have hooked the right address in capt_seq.c   I assume that the SDM code for capt_seq.c  is just lifted from the CHDK port so results should be the same.
« Last Edit: 18 / June / 2013, 21:06:14 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #672 on: 23 / June / 2013, 13:58:31 »
If so, either the ram address is incorrect or that article is incorrect.
The RAM address is fine but the hook in capt_seq.c is commented out for both firmware versions.   

Also, "wait_until_remote_button_is_released()" is also commented out so precision sync is not possible with this camera.

I just posted to this effect in the SDM Yahoo group - if your user wants it fixed he/she will need to come here and help with the testing.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #673 on: 23 / June / 2013, 14:18:28 »
if your user wants it fixed he/she will need to come here and help with the testing.

Here I am, and surely I will help with the testing ;-)!

Best regards und thank you for your support,
Christoph
« Last Edit: 23 / June / 2013, 14:29:22 by muelli »


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #674 on: 23 / June / 2013, 14:34:46 »
Here I am, and surely I will help with the testing ;-)!
Welcome.   Anticipating your arrival, I took a look at some comparable ports to the IXUS100.  The D10 has the same hooks as the IXUS100 in the same place but they are not commented out.  So we would be pretty safe to try that.

Here's both firmware versions for CHDK 1.2.0  - SD card lock booting only.

100b> https://www.box.com/s/bruj531up48y31oiup7f
100c> https://www.box.com/s/mrddiduz06m3p5aa38m6

You can check the noise reduction by shooting for 10 seconds with it Off and On.  With it On, you should get a 20 second shooting time, with it Off you should get 10 seconds.

You can check the USB remote precision sync by inserting a long sync delay and observing if the shutter delays firing after the remote is released for that amount of time.


Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #675 on: 23 / June / 2013, 15:47:00 »
Thank you! For firmware 100C the dark frame reduction works. If I activate it, the camera processes 10 seconds after 10 seconds shutter time and removes all the hotpixel. The other function seems to work, too; I had set the delay to 3 seconds.

Best regards,
Christoph

*

Offline nafraf

  • *****
  • 1303
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #676 on: 12 / December / 2014, 08:15:19 »
Patch to correct keyboard behavior, errors were reported here.
- Set KEY_PLAYBACK as default ALT key, KEY_DISPLAY as the second option
- Remove KEY_POWER from KEYMASK1

*

Offline koshy

  • *****
  • 799
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #677 on: 14 / December / 2014, 21:11:14 »
Patch to correct keyboard behavior, errors were reported here.
- Set KEY_PLAYBACK as default ALT key, KEY_DISPLAY as the second option
- Remove KEY_POWER from KEYMASK1
Tested to be working fine. Play is ALT key now and I can power the cam off while in ALT mode. Thanks.


*

Offline nafraf

  • *****
  • 1303
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #678 on: 15 / December / 2014, 06:14:31 »
Thanks. Changes committed to trunk, changeset 3799

 

Related Topics