IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread - page 47 - General Discussion and Assistance - CHDK Forum

IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 223975 Views
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #460 on: 08 / April / 2010, 00:57:18 »
Advertisements
Where can I find the override aperture option in 100c?

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #461 on: 08 / April / 2010, 01:16:35 »
Where can I find the override aperture option in 100c?
The IXUS 100 / SD780 do not have a real aperture, only a ND filter - as all other Ixus series cameras; so there's no Av CHDK override, only a ND filter override.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #462 on: 08 / April / 2010, 02:31:37 »
I'm moving my thread over here from the main discussion line:

Hi, i've finally managed to try and install CHDK (ixus100_sd780-100c-0.9.9-885-full_BETA) on my SD780IS camera.
Everything seems to be working fine, i can access the menu, run scripts, etc. etc.

The problem is that when i try to shoot the camera focus and then freezes: the lens stays out but everything else seems to be turned off. I can get the camera to respond by power cycling or by pressing the display button (the camera seems to boot from scratch when i use the display button, showing the CHDK splash page).

Also, one thing i forgot to mention in the other thread: the vers.req and ver.req files don't work: either i'm pressing the wrong buttons (i doubt it) or something's not working correctly, all i can manage to get is the clock ticking.

Any idea on why is this happening and what can i do to solve the problem or help debugging?



To answer to Jason / HarpoMa:
The CHDK firmware i installed is 1.00C and i'm not in ALT mode when shooting, when in ALT mode i can see the scripts running correctly.


Thanks!
Marcello

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #463 on: 08 / April / 2010, 11:14:38 »
Follow the instructions on this page http://chdk.wikia.com/wiki/SD780IS with regards to getting the version of the camera.  I know the build works beyond what you are experiencing.  I'm concerned that if you have a new camera it may have a newer firmware.  So you need to confirm you have camera firmware 1.00C.   

Now that I've written that there is one thing that you might find would cause this....  Did you turn on Zebra?  If you did turn it off.  Zebra is known to crash the sd780 at present.
Harpo
Canon Models - SD300, SD780, & SX210


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #464 on: 08 / April / 2010, 16:39:02 »
Hi, i checked and it actually was the zebra option. I initially turned it on and then forgot about it.
My bad! ;)

I checked the camera firmware and it is indeed 1.00C so i can confirm that zebra causes crashes.

Thanks for your help!
M


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #465 on: 09 / April / 2010, 06:46:20 »
I really appreciate the work on this camera, but can't make the ND filter override work.  Have others?  If so is there something I might have missed in the setup?

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #466 on: 09 / April / 2010, 09:44:11 »
How do you know that it does not work ?

What I mean is ... how do you know what the Canon firmware intended to do before you tried to override it ?


David

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #467 on: 09 / April / 2010, 11:01:34 »
@ap1414 - ND Filter does work.  Go to overrides and turn on ND Filter.  The filter does not engage until 1/2 shutter press

Harpo
Canon Models - SD300, SD780, & SX210


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #468 on: 09 / April / 2010, 12:10:38 »
How do you know that it does not work ?

What I mean is ... how do you know what the Canon firmware intended to do before you tried to override it ?


David

Without the override, in P mode at wide angle, the firmware selects 1/80 f9.  At that point I'd rather stay at f3.2 with a faster shutter but with "ND Filter:Out" showing in red on the display the camera still selects 1/80 f9, so it doesn't seem to be having any effect

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #469 on: 09 / April / 2010, 12:20:34 »
@ap1414 - I'm still new with chdk but I beleive you will find that a lot of the canon screens lie when we do things it doesn't expect.  For instance you are overriding ND.  If the camera put it out itself it would adjust it.  So basic rule is this....if you override then canon doesn't know about it.

Anyone with more info have a better way of saying this?

Harpo
Canon Models - SD300, SD780, & SX210

 

Related Topics