IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread - page 62 - General Discussion and Assistance - CHDK Forum  

IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread

  • 678 Replies
  • 212761 Views
Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #610 on: 12 / July / 2011, 18:49:14 »
Advertisements
I'm very interested in testing and having a working DHCK port for my camera! 
I actually got a big chunk of the porting work done last week.  Busy working on another camera right now but once I get a break,  I'll finish up the SD780 fw 100b - some time this month most likely.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #611 on: 13 / July / 2011, 21:22:24 »
Awesome!

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #612 on: 18 / July / 2011, 19:27:52 »
I'm very interested in testing and having a working DHCK port for my camera! 
I actually got a big chunk of the porting work done last week.  Busy working on another camera right now but once I get a break,  I'll finish up the SD780 fw 100b - some time this month most likely.

I just got my SD780 IS and I just found out that it has 1.00B firmware :(
I shouldve checked the firmware version first, but it was on clearance so too hard to pass.
I dont know what is involved in the testing end, but Ill be happy to test it out if someone can get the port for 1.00B going. Coming from DSLR, only having JPEGs is like... i dunno how to explain it.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #613 on: 18 / July / 2011, 19:49:41 »
Coming from DSLR, only having JPEGs is like... i dunno how to explain it.
One way to help explain it might be to search the various threads in this forum about the limitations of CHDK RAW for P&S cameras.  If you are use to a DSLR, you might not realize how much post processing is needed for CHDK RAW files, especially "wide angle" shots.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #614 on: 20 / July / 2011, 23:57:28 »
@dagokun & voodoolady & Cloud : Okay - here's the first attempt at port to the 1.00b firmware for the IXUS100_SD780.

CHDK IXUS100_SD780 Beta 1

Its basically at the point where, if I actually owned a SD780,  I would load it on the camera to see what it does.

At a minimum,  I put code at the start of the boot code to turn on the Auto Focus lamp.  If things don't work for you,  does the AF lamp come on briefly at least  ?

NOTE : "SD card lock" boot method only.
« Last Edit: 21 / July / 2011, 00:02:39 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #615 on: 21 / July / 2011, 21:45:18 »
It works, the autofocus lamp turns on! (note to testers, don't turn the camera on with the autofocus lamp aiming directly to your eyes! Ouch!)

I tested turning the camera on with the PLAY button and the ON/OFF buton, and in the 3 shooting modes (auto, program and video), 6 combinations total. Every time, the only thing that happens is that the autofocus lamp turns on. No reaction on the other LEDs or the LCD. The camera freezes with the lamp on, and must remove battery to reset.

Like you said, the only way to run the code it to have the card bootable and locked. Otherwise, the "upgrade firmware" option is abscent.

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #616 on: 21 / July / 2011, 22:19:16 »
Beta 2 - found an address jump wrong in boot.c.  Let's see how this works ?

http://www.box.net/shared/x3q038ygu3fzlcf5qu55

« Last Edit: 22 / July / 2011, 00:28:45 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #617 on: 22 / July / 2011, 18:40:01 »
Beta 2 bahaves just like beta 1


Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #618 on: 22 / July / 2011, 19:09:31 »
Beta 2 bahaves just like beta 1.
Its now time to do this the hard way so here's a version with almost everything turned off (for now). 

IXUS100-SD780 fw 1.00b Beta 3

The yellow LED beside the viewfinder should blink rapidly at least once and hopefully several times.  Please let me know how many times it blinks ? (or if the blinking is too fast to count)


Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 100 IS (Europe) / PowerShot SD780 IS - Porting Thread
« Reply #619 on: 22 / July / 2011, 22:49:43 »
It worked. It blinks very fast, but using another camera to record it and playing it frame by frame I can see it blinking 3 times.

 

Related Topics