Can't get to first base w/ SD990 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

Can't get to first base w/ SD990

  • 3 Replies
Can't get to first base w/ SD990
« on: 16 / August / 2009, 02:28:18 »
This is so newbie that I am afraid to ask, but I am really stuck. I have a brand new SD990IS and I can't get to the point of displaying the firmware version number. I have done the following.

1) Start with the 32MB card provided with the camera.

2) Put it in a multi-size chip reader connected to the USB port on my laptop running Windows XP

3) Reformat it by right clicking on the "removeable disk" in Windows.

4) create file named ver.req (all lower case) by right clicking in the root directory, selecting new text file and changing the name to ver.req

5) put the card in the camera

6) power on using the "play" button (camera says "no image")

7) hold down funct set and, while holding it down press disp (no change in the display)

8) turn camera off by pressing "play" and turn on using power button (now in shooting mode)

9) take a picture, the picture appears on the screen

10) power down

11) power up by pusing the display mode (the picture I last took comes up on the screen)

12) repeat step 7 (no change in the display)

13) return the chip to the card reader. Confirm that ver.req is really there (zero length)

14) change its name to vers.req

15) repeat steps 5-7 (no change in display)

16) repeat steps 1-15 with a 4Gb card (no difference)

17) reformat the 4GB card in FAT16 using CardTricks

18) repeat steps 1-15 (no change)

19) use CardTricks to download and install on the card

20) lock the card

21) turn on the camera -- camera appears to be dead, as if it had no power

22) remove the card

23) turn on the camera (still dead)

24) remove and reinstalll the battery

25) turn on the camera (comes up, says No card)

26) reformat the 4GB card

27) camera again operates normally

Can anyone see what I am doing wrong?

Thanks in advance.


Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Can't get to first base w/ SD990
« Reply #1 on: 16 / August / 2009, 06:32:30 »
Hello & welcome, wrishel !

The file name must be ver.req or vers.req, i guess your file name is ver.req.txt - as Windows appends the additional .txt extension on "text" files and them hides this extension by default...

When you're running Windows with the Explorer's default settings:
  * In this mode Windows adds .txt to your filename, so the real file is named like file.req.txt
    (the full filename is shown in the file properties dialog from the Windows explorer)
 * See also "How to NOT hide extensions in Windows"

I was having some problems using the ver.req file to get find out my powershot a720 firmware version by RENAMING a .txt file to ver.req (giving me the file ver.req.txt), trying all the combinations with s, caps on... until I tried CHANGING the TYPE of file from .txt to .req (giving me ver.req without the .txt). Now it works! (Simply right click on the file and choose change type, in the box that says what type of file it is, write .req).
Hope this helps others having the same problem!

Re: Can't get to first base w/ SD990
« Reply #2 on: 16 / August / 2009, 10:40:41 »
No, this is not the problem. I do not hide extensions and when I changed the name from New Text Document.txt to ver.req I received and accepted the warning about changing the extension.

I am an experienced computer user/programmer and I have been through For Dummies procedure with a fine-tooth comb. I really hope I am doing something dumb, but fear that Canon has made a production change to disable the Set-Disp trigger. I note that when I push the two buttons together on a newer camera, the SD970IS, it brings up a funky 3-d time of day clock.

Any other suggestions, I hope? Any suggestions on how I might approach Canon support about this, if at all?


Offline reyalp

  • ******
  • 14098
Re: Can't get to first base w/ SD990
« Reply #3 on: 16 / August / 2009, 19:54:42 »
I don't know what you are doing wrong, but I can confirm the vers.req trick definitely works on the SD990.
Don't forget what the H stands for.


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal