SDM1.81 starting recording video problem - General Discussion and Assistance - CHDK Forum  

SDM1.81 starting recording video problem

  • 6 Replies
  • 2547 Views
SDM1.81 starting recording video problem
« on: 17 / August / 2009, 03:02:39 »
Advertisements
Dear Mircofunguy,

I downloaded and installed the SDM 1.81 but found out that I cannot start recording video using the USB switch.
If I turn my IXUS 860 into video mode and press th USB switch it just shows a red sqare with text 'USB' on display, but recording a video does not start
:(

What I am doing wrong?
2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM1.81 starting recording video problem
« Reply #1 on: 17 / August / 2009, 05:13:43 »
What I am doing wrong?

Nothing, it appears to be broken  :(

Probably the new code that allows you to cancel autofocus state with a second quick click.

Some people prefer the older method where a second slow or fast click takes the photo.
I will look at it and report back.

I sent you an email on 31st July, I have not had a reply.

It said :-

"You said that you added msleep(500) to code in kbd.c in order to solve the
script autostart problem..

As someone is still having a similar problem with the SX10IS, could you
confirm exactly where you added that line .. just to avoid any confusion ?"


David

Re: SDM1.81 starting recording video problem
« Reply #2 on: 17 / August / 2009, 06:06:47 »
Hi Microfunguy,

sorry, regarding the msleep(500), I will let you know today evening or tomorrow!
2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM1.81 starting recording video problem
« Reply #3 on: 18 / August / 2009, 06:21:46 »
Hi Microfunguy,

the changes I did in file core\kbd.c in function script_autostart():

void script_autostart()
{
  // ChangeNo 2, Mr. Burns 11July2009
  msleep(500); // without this additional msleep, scripts are not started automatically in Ixus 860

  strcpy(normal_script,conf.script_file);       
  const char *fn = "A/CHDK/SCRIPTS/Startup.bas";

  FILE *fdstartup = NULL;
...

May also a shorter delay will work, but I did not test yet.

Hope that helps!

Best regrads, and pls keep me updated regarding the 'starting recording video problem '

Thanks!
2 x IXUS 860IS 100c
2 x Powershot S110 103a


Re: SDM1.81 starting recording video problem
« Reply #4 on: 18 / August / 2009, 06:54:59 »
pls keep me updated regarding the 'starting recording video problem '

In \core\kbd.c  after the first occurence of this :-

                  else if(get_usb_power(1) && (nCount >=40) && !mvideo)
                   {
                    nCount=0;
                    nSW=114;
                   }

add this :-

         else if(!get_usb_power(1) && mvideo) nSW=114;   
         else return 1;



David

Re: SDM1.81 starting recording video problem
« Reply #5 on: 24 / September / 2009, 08:26:05 »
Hi Microfunguy,

finally I found time to change source code as you mentioned above.
Thanks that works, starting video on both cams simultanously by remote switch worked again.

2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: SDM1.81 starting recording video problem
« Reply #6 on: 24 / September / 2009, 14:53:25 »
finally I found time to change source code


Nice to know that you still exist !

Enjoy your stereo movies.


David

 

Related Topics