SX10 exposure bracketing in manual mode - Feature Requests - CHDK Forum
supplierdeeply

SX10 exposure bracketing in manual mode

  • 3 Replies
  • 2454 Views
SX10 exposure bracketing in manual mode
« on: 21 / August / 2009, 07:01:39 »
Advertisements
I usually shoot in manual mode. Now I need some HDR photos composed of 5 or more pictures but there is no exposure bracketing in the M mode of SX10. Can any CHDK script help?

Zmalol

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX10 exposure bracketing in manual mode
« Reply #1 on: 21 / August / 2009, 07:35:35 »
Hello & welcome, malol  !
I usually shoot in manual mode. Now I need some HDR photos composed of 5 or more pictures but there is no exposure bracketing in the M mode of SX10. Can any CHDK script help?
You can use the the build-in bracketing in P mode...or you use CHDK - so: YES, of course, CHDK can help ;)
You don't need a script, for 3,5,7 or 9 images you can do it scriptless:
-> Scriptless Tv bracketing
-> SD990 guidance

Re: SX10 exposure bracketing in manual mode
« Reply #2 on: 25 / August / 2009, 15:54:14 »
fe50 - thanks for advice. I have installed CHDK and I am checking all its options just now.

I have tried CHDK bracketing in continuous mode but it does not work exactly as I expected. Let me explain my plan in more details.

I try to get three RAW shots for HDR of night landscapes and I am interested to shoot long exposures something like 5, 25 and 100 seconds. It is good that I could trigger SX10 once for three long shots but camera takes only one shot using the override shutter speed (25.4") and two other shots from regular camera mode settings (for example 3" and 1/5).

In CHDK I set:
Dissable Overrides [Off]
Include AutoIso & Bracketing [ x ]
Bracketing type [ +/- ]

After the first long exposure shot (out of three) camera is "Busy" while processing the image. I suspect that this long time break may disturb bracketing mode. But I am new in this so certainy I am wrong.

BTW I am 1.03A firmware user and CHDK for this version is still in beta. May be this causes the issue.

Any help will be appreciated.

malol
 

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX10 exposure bracketing in manual mode
« Reply #3 on: 25 / August / 2009, 17:17:49 »
I have tried CHDK bracketing in continuous mode but it does not work exactly as I expected. Let me explain my plan in more details.
I try to get three RAW shots for HDR of night landscapes and I am interested to shoot long exposures something like 5, 25 and 100 seconds. It is good that I could trigger SX10 once for three long shots but camera takes only one shot using the override shutter speed (25.4") and two other shots from regular camera mode settings (for example 3" and 1/5).

In CHDK I set:
Dissable Overrides [Off]
Include AutoIso & Bracketing [ x ]
Bracketing type [ +/- ]

After the first long exposure shot (out of three) camera is "Busy" while processing the image. I suspect that this long time break may disturb bracketing mode. But I am new in this so certainy I am wrong.
Ahhh - XL exposure bracketing  :D

The CHDK "Bracketing in continuous mode" feature doesn't work in this situation...
You can do it with a script, e.g. this one: barberofcivil's Shutter Speed - Adjustable in LUA should do it  :)

*Edit: forgot the "busy" thing...
This is the Dark frame subtraction ("Noise reduction" in older CHDK versions) - with the default value ("Auto") on exposures > 1.3s (Canon threshold) the DF subtraction is active...
« Last Edit: 25 / August / 2009, 17:24:58 by fe50 »


 

Related Topics