Menu RBF Font under Visual Settings - General Help and Assistance on using CHDK stable releases - CHDK Forum

Menu RBF Font under Visual Settings

  • 7 Replies
  • 3076 Views
*

Offline bob c

  • *
  • 6
  • A620
Menu RBF Font under Visual Settings
« on: 28 / January / 2008, 23:23:55 »
Advertisements
I have an A620 FW 1.00F AllBest #16 version. I'd like to try out different sized fonts for the hack's main menu, the default size  is so tiny to make out for me. I found this list    http://tools.assembla.com/chdk/browser/branches/grand/fonts    of what I assume are different rbf fonts I can use?  Is there a way I can preview some of these before trying to load them into the camera- I'd be curious what size the default is? I think I'm pretty clear on how to load the fonts onto my card and into the camera, and how I can revert back to the default font by trying to load a UBasic script as a rbf font. I'm using test-keys.bas as the "illegal" rbf font. 

If anyone has tried to add more fonts I'd appreciate any feedback before I attempt to do it, thanks. 

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: Menu RBF Font under Visual Settings
« Reply #1 on: 29 / January / 2008, 03:07:54 »
CHDK Developer.

*

Offline bob c

  • *
  • 6
  • A620
Re: Menu RBF Font under Visual Settings
« Reply #2 on: 29 / January / 2008, 19:55:04 »
Thanks, yes I read thru that page and all the FAQs I could find before posting. I take it those fonts I linked to won't work for what I want to do and might be too large anyway? I was hoping I could somehow find some pre-made rbf fonts that would work to try first before diving into trying to make my own.  I should leave a suggestion at the appropriate place (feature requests)  that it would be great to add in a future build the ability to change the size of the hack menu font by choosing from a list of them included  in the build or some other simple method of changing the display size. 
« Last Edit: 29 / January / 2008, 20:43:56 by bob c »

*

Offline bob c

  • *
  • 6
  • A620
Re: Menu RBF Font under Visual Settings
« Reply #3 on: 31 / January / 2008, 22:05:36 »
Okay I finally figured it out and found a font I'm happy with. I just went down the line of available fonts on the page I previously linked to above, downloaded them and placed them in my SD card's CHDK Fonts subfolder and after reinserting my card in the camera I was able to choose one that worked for me in the CHDK main menu>visual settings>menu rbf fonts. I like  the Verdana 20b font it's big and bold and easy to read. 

I was originally confused because at least the first couple fonts I tried didn't appear any different than the default one so I thought maybe I had somehow messed up somewhere along the line or all these fonts weren't the right ones to use. I'm new to all this CHDK stuff. I'm glad these other fonts are available for us to use along with all the other useful and fun things  in these hacks. Thanks to all who have created them.


Re: Menu RBF Font under Visual Settings
« Reply #4 on: 30 / April / 2008, 06:40:48 »
Hi, bob c,
I am new too. Have you tried to change fonts of LDC measuerd values, e.g. display of DOF ?
Successful?
If so, let me know the way.

Kajakazik

*

Offline m2tk

  • **
  • 50
  • Sheet happens ...
Re: Menu RBF Font under Visual Settings
« Reply #5 on: 30 / April / 2008, 10:07:01 »
hi,
system fonts are hardcoded into CHDK, need to change source code and design new fonts shapes...
S5IS 1.01bc

Re: Menu RBF Font under Visual Settings
« Reply #6 on: 30 / April / 2008, 15:11:28 »
Hmmm, pity. So some work must be done. Pity, pity, because I see, that NOBODY needs these bigger digits (except me and my monkey). I wonder, because the results of measuring are at least equal important as Menu functions. But if not ............. Pity.

I must think about my own magnification glass on LCD.

Thakns anyway for the information,

Kajakazik (yet still with a little bit of hope)

Re: Menu RBF Font under Visual Settings
« Reply #7 on: 06 / April / 2009, 18:33:14 »
Hello
Im having a hard time seeing the text in the menus.
I've been able to change the font and color of text and background but when I cycle power all goes back to default settings. What am I missing?
I am using Autobuild build 0.9.7, revision 727 on a Cannon SX100IS
In an older build I was able to power up with the changes but I cant remember what I did.
Thanks
Craig


 

Related Topics