A2000IS porting - page 2 - DryOS Development - CHDK Forum

A2000IS porting

  • 95 Replies
  • 36737 Views
Re: A2000IS porting
« Reply #10 on: 07 / September / 2009, 05:21:20 »
Advertisements
dabbeljuh:  i don't see the actual CHDK files in either of the zips on the last (most recent) post.  One file in each...  i'm really confused now. :D

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #11 on: 07 / September / 2009, 05:34:27 »
dabbeljuh:  i don't see the actual CHDK files in either of the zips on the last (most recent) post.  One file in each...  i'm really confused now. :D

Hi, just try the following steps:

- Use CardTricks to format your card (use the "NewDryOS" button)
- Once finished just delete the files present on your card (CardTricks puts some files needed for firmware dumping)
- Download Diskboot.zip (from post above) and extract the single file it contains (DISKBOOT.BIN) on your card
- In the end your card must contain only the DISKBOOT.BIN file
- Extract card from PC
- Lock the card
- Put the card in your camera and power on

You should see the CHDK splash screen. Cam starts in play mode. Just half press the shoot button to enter shoot mode

Re: A2000IS porting
« Reply #12 on: 07 / September / 2009, 06:07:46 »
alright, that worked perfectly...  now i seem to have a problem.  I can't access the CHDK menu at all, when in shooting mode, pressing the print button quickly flashes white text on blue background that reads "Default Script            <ALT>", and no consecutive button pushes work except pressing print again to cancel the "alt" flag...  I see above you were able to access and fix most things, so I'm assuming there's something else I'm missing, like a script or something that tells it what the <ALT> button does in each scenario....

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #13 on: 07 / September / 2009, 06:21:52 »
alright, that worked perfectly...  now i seem to have a problem.  I can't access the CHDK menu at all, when in shooting mode, pressing the print button quickly flashes white text on blue background that reads "Default Script            <ALT>", and no consecutive button pushes work except pressing print again to cancel the "alt" flag...  I see above you were able to access and fix most things, so I'm assuming there's something else I'm missing, like a script or something that tells it what the <ALT> button does in each scenario....

Pressing the print button puts the camera in ALT mode (the one where you see the white on blue text at the bottom).

Once in ALT mode press the "DISP." button do show the CHDK menu.


*

Offline awf

  • *
  • 7
Re: A2000IS porting
« Reply #14 on: 07 / September / 2009, 06:55:23 »
Hello!

I try to load this version on my A2000IS (GM1.00B) and firmware does not working
I use sd 8GB and 256 MB, same resoults.
Canon PowerShot A2000IS

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #15 on: 07 / September / 2009, 07:38:29 »
Hello!

I try to load this version on my A2000IS (GM1.00B) and firmware does not working
I use sd 8GB and 256 MB, same resoults.

Hi my version supports 1.00C only, I think there is really little hope that it would work fine on 1.00B.

However I think that the task to adapt my work to 1.00B would be quite easy (just locate the correct function addresses and values in the firmware dump).

My code is quite well documented for that, and I can give support if someone would like to try.

Re: A2000IS porting
« Reply #16 on: 07 / September / 2009, 08:33:14 »
Hello!

I try to load this version on my A2000IS (GM1.00B) and firmware does not working
I use sd 8GB and 256 MB, same resoults.

Hi my version supports 1.00C only, I think there is really little hope that it would work fine on 1.00B.

I got a A2000IS(GM1.00B) and it seems to work on mine.
Canon Powershot A2000 IS (GM 1.00B)

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #17 on: 07 / September / 2009, 08:39:18 »
I got a A2000IS(GM1.00B) and it seems to work on mine.

hi, did you have time to test some CHDK features apart from CHDK loading. If 1.00B is automatically supported it would be great, however I fear there might be some problem with some founctionalities.

Could you please confirm that the following veatures are working on your 1.00B?

- Histogram
- Raw + DNG
- Overrides
- Scripting (for instance one of the script used for timelapses)

Thank you very much


Re: A2000IS porting
« Reply #18 on: 07 / September / 2009, 10:54:02 »
-Histogramm is working fine (at least all histogramms shown were looking reasonable)
-RAW + DNG is working as well
-Overrides:
     Tv-Bracketing is working
     Tv- and Av-Override are ok
-Scripting: badpixel.lua did work

I'm still testing on the rest, this might take some time, as I'm a newbie to all CHDK-matters
« Last Edit: 07 / September / 2009, 11:40:13 by dabbeljuh »
Canon Powershot A2000 IS (GM 1.00B)

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A2000IS porting
« Reply #19 on: 07 / September / 2009, 12:48:33 »
@dabbeljuh

on scripts: you could also try /SCRIPTS/TEST/llibtst.lua
it will give the lua script subsystem a good workout.

wim

 

Related Topics