A2000IS porting - page 3 - DryOS Development - CHDK Forum

A2000IS porting

  • 95 Replies
  • 36789 Views
Re: A2000IS porting
« Reply #20 on: 07 / September / 2009, 13:06:42 »
Advertisements
@dabbeljuh

on scripts: you could also try /SCRIPTS/TEST/llibtst.lua
it will give the lua script subsystem a good workout.

wim

works
Canon Powershot A2000 IS (GM 1.00B)

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #21 on: 07 / September / 2009, 15:05:14 »
Hello!

I try to load this version on my A2000IS (GM1.00B) and firmware does not working
I use sd 8GB and 256 MB, same resoults.

Can you give some more details about what happens on your camera when you try to load this version of CHDK? At least another user reports that this version looks to work fine for 1.00B.

thanks

Re: A2000IS porting
« Reply #22 on: 07 / September / 2009, 23:19:21 »
me again, i'm also having script problems, but mine have to do with not having any of the tests or scripts in my /scripts folder.  in fact, my scripts folder is empty...  are these specific to the build too, or are they generic and can be pulled from other chdk builds?  i'd specifically like badpixel since it's required to save as .dng (a big reason i wanted to go to CHDK :D  thanks again!

Re: A2000IS porting
« Reply #23 on: 08 / September / 2009, 05:15:48 »
you can just copy the scripts from other builds, i think
Canon Powershot A2000 IS (GM 1.00B)


*

Offline awf

  • *
  • 7
Re: A2000IS porting
« Reply #24 on: 08 / September / 2009, 08:04:28 »
Hello!

I try to load this version on my A2000IS (GM1.00B) and firmware does not working
I use sd 8GB and 256 MB, same resoults.


Can you give some more details about what happens on your camera when you try to load this version of CHDK? At least another user reports that this version looks to work fine for 1.00B.

thanks

Just normal camera working. No any flashig lights or something.
But appears 'chdk' folder in the root of sd card
Canon PowerShot A2000IS

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: A2000IS porting
« Reply #25 on: 08 / September / 2009, 09:32:24 »
@dabbeljuh

yes you can  :D in fact, to get a 'full'  CHDK:

1. download let's say an SX10 full archive at the Autobuild server: http://mighty-hoernsche.de/
2. unpack to an empty folder on your computer
3. delete PS.FI2
4. replace DISKBOOT.BIN with your own A2000 version's
5. copy folder contents to card

@awf

if the /CHDK folder has appeared, that means CHDK has started ...
normally, you press the Direct Print button and <Alt> will appear (bottom center screen)
once it does, press Menu and you're in the CHDK menu
(i said 'normally' because i don't know the cam / state of the port)
 
HTH,

wim
« Last Edit: 08 / September / 2009, 09:43:41 by whim »

Re: A2000IS porting
« Reply #26 on: 08 / September / 2009, 10:46:59 »
@awf

if the /CHDK folder has appeared, that means CHDK has started ...
normally, you press the Direct Print button and <Alt> will appear (bottom center screen)
once it does, press Menu and you're in the CHDK menu
(i said 'normally' because i don't know the cam / state of the port)
 
HTH,

wim


to reach the menu, it's the "display"-button on the a2000
Canon Powershot A2000 IS (GM 1.00B)

*

Offline reyalp

  • ******
  • 11902
Re: A2000IS porting
« Reply #27 on: 08 / September / 2009, 22:23:11 »
Working on merging this. Some questions/issues
in platform/sub/makefile.inc
PLATFORMID=12686
but http://chdk.wikia.com/wiki/A2000 says
P-ID:3191 (=12689)
makefile.inc mentions USB id, but this isn't relevant AFAIK.

also the FI2 encoding method isn't specified (see KEYSYS=... in other dryos cams) Looking at the dump, it appears to use the digic 4 values

also, platform/kbd.c
Quote
//There used to be a note here about order being important
 //and to look at kbd_get_pressed_key for more info, there wasn't any
 //so to mess with my karma I removed note and changed order.
 //Sofar the universe is ok with it.
Order does matter, otherwise you can confuse SHOOT_HALF and SHOOT_FULL (or any other buttons that shared bits). You happen to have got it in the order that's OK.

Another question, does the A2000 have an ND filter ? I'm guessing it doesn't have an adjustable iris since there's no Av mode ?

in platform/main.c, using SX10 fl_tbl must be wrong.

the vbatt settings I assume should be the same as other 2xAA cams.

edit:
very nice work overall btw :)

edit:
in camera.h, CAM_UNCACHED_BIT should be the default 0x10000000, you can see this in the early boot code where the CP15 regs are set up:
Code: [Select]
LDR     R0, =0x10000033
MCR     p15, 0, R0,c6,c3
sets up region 3 as 64mb at 0x10000000

This is described in ARM946E-S Technical Reference Manual
« Last Edit: 08 / September / 2009, 23:06:32 by reyalp »
Don't forget what the H stands for.


Re: A2000IS porting
« Reply #28 on: 09 / September / 2009, 02:37:15 »
I've been testing on my 1.00B and so far everything is working (as far as I could say)

things I've been testing:
-Overrides: Tv-/Av-Override, Subj-Dist-Override, Tv-/Av-/Subj-Dist-Bracketing,
-Video
-RAW + DNG
-Histograms
-Zebra
-Scripts: Badpixel.lua, llibtst (log attached)

Good work, thx a lot, I'm recharging my batteries  :D
w

Edit: Only problem I've seen (perhaps it's just a problem with my settings ?):
Sometimes, when I'm in the menu, a part (i.e. the upper half) of it or the whole menu vanishes. When I use one of the up/down keys, it's there again.
« Last Edit: 09 / September / 2009, 02:41:40 by dabbeljuh »
Canon Powershot A2000 IS (GM 1.00B)

*

Offline iax

  • *
  • 45
Re: A2000IS porting
« Reply #29 on: 09 / September / 2009, 03:07:40 »
@reyalp
thanks so much for the great help. will make the changes later today, test and the update the diff file as soon as possible

@dabbeljuh
thanks for the feedbacks! i have noticed an occasional menu refresh problem on my cam too (in my situation the menu just vanishes).  for my cam it is quite a rare problem and right now i have not been able to reproduce this problem systematically.


 

Related Topics