G9 scripts - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

G9 scripts

  • 22 Replies
  • 5715 Views
*

Offline spex

  • *
  • 21
G9 scripts
« on: 01 / September / 2009, 06:39:29 »
Advertisements
I have downloaded a interval script and put it in my script folder and rebooted, on entering Alt and going to load script i could only see badpixel.lua and llibtst.lua which on further investigation are to be found in the test folder. So next step i put my files which end in .bas into there as well, they didnt show in the menu. So now i have them in the root of Scripts, in the root of Test and in the root of Examples. On going back to the G9 and Alt and then load script the menu shows badpixel.lua and llibtst.lua and if i go up in the tree and pick scripts they are the only two that show. Is this a file extension problem or am i missing something in front of my face?

Re: G9 scripts
« Reply #1 on: 01 / September / 2009, 07:00:44 »
What is the name of the script, is it more than eight characters ?

It should definitely be in your CHDK\SCRIPTS folder.

*

Offline spex

  • *
  • 21
Re: G9 scripts
« Reply #2 on: 01 / September / 2009, 07:52:51 »
The two that show in the camera menu are badpixel.lua and llibtst.lua which are situated in my test folder which is in Scripts, i have just saved a text file in the root of Scripts as intrvl.bas and that doesnt show either :(

Re: G9 scripts
« Reply #3 on: 01 / September / 2009, 08:35:24 »
Try deleting the CFG file in the CHDK folder and try again.


*

Offline spex

  • *
  • 21
Re: G9 scripts
« Reply #4 on: 01 / September / 2009, 12:38:04 »
I dont seem to have one :(

*

Offline spex

  • *
  • 21
Re: G9 scripts
« Reply #5 on: 01 / September / 2009, 13:07:25 »
I have just cleared the partition and copied over g9-100d-0.9.8-795-full and i still get the same two files in the menu and cant get to any others and i dont have a cfg file in CHDK root or the root of the partition :(

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: G9 scripts
« Reply #6 on: 01 / September / 2009, 13:33:13 »
@spex

are you saying that after installing the full version of CHDK, starting your cam and CHDK, and shutting down
your cam you don't have CCHDK.CFG in the /CHDK folder ? At the next start (cam + CHDK) you should be able to find it using Miscellaneous -> File Browser.

In /SCRIPTS you should have "default.bas", plus 2 folders, EXAMPLES and TEST.
/TEST should have 2 lua scripts, badpixel and llibtst, EXAMPLES 8 :

countd~1.lua, eggtimer.bas, input1.lua etc.


hth,

wim

*

Offline spex

  • *
  • 21
Re: G9 scripts
« Reply #7 on: 01 / September / 2009, 14:17:31 »
Yes if i use the camera to browse i find cchdk.cfg and in scripts i have badpixel and llibtst. If i go Scripting parameters-load script from file or just load script from file i can only see badpixel and llibtst in the list and no matter how i cant get to any others .


*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: G9 scripts
« Reply #8 on: 01 / September / 2009, 14:38:01 »
 ??? that's really bizarre - especially since AFAIK when you "load script from file" the same code is used
as for the file browser, and this part of the code is common to all cams ...

hmm another idea: are you doing this in REVIEW/PLAY mode ? If not (meaning you're in shooting mode)
go back to REVIEW/PLAY and try again (clutching at straws here ...)

wim

edit: no, just checked (not on G9 though), even that should work ...

« Last Edit: 01 / September / 2009, 14:44:17 by whim »

*

Offline spex

  • *
  • 21
Re: G9 scripts
« Reply #9 on: 01 / September / 2009, 14:45:34 »
Yes i am in review mode, the odd thing is i cant get to Test or examples folder when i go up the tree, it only shows scripts and if i click on that it shows badpixel and llibtst which are in the Test folder. :~

 

Related Topics