SX20 IS firmware dump, I need help! - page 3 - General Discussion and Assistance - CHDK Forum  

SX20 IS firmware dump, I need help!

  • 125 Replies
  • 36362 Views
*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: SX20 IS firmware dump, I need help!
« Reply #20 on: 12 / September / 2009, 15:34:01 »
Advertisements
The P-ID is correct. This error is displayed after increasing the size of ps.fi2 using the method posted by whim. But that doesn't seem to work, as I don't get this error when trying to load the small 2.8 KB ps.fi2, but I can't get any leds lighting using the small file.

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SX20 IS firmware dump, I need help!
« Reply #21 on: 12 / September / 2009, 15:56:11 »
Note that the amount of zero padding was determined experimentally.
Maybe you can gradually increase the amount until you find the point where it switches from 'small ps.fi2 behaviour' to 'large ps.fi2' behaviour', IIRC that's how it was done for the original udumper.

wim

*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: SX20 IS firmware dump, I need help!
« Reply #22 on: 12 / September / 2009, 16:07:29 »
Even when adding only one zero to the end of ps.fi2, I get the error. When using an unmodified ps.fi2, the screen turns black and nothing happens.

*

Offline fe50

  • ******
  • 3107
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX20 IS firmware dump, I need help!
« Reply #23 on: 12 / September / 2009, 16:23:57 »
@jan
Have you also tried the code from my SX10 zip, updated with the SX20 P-ID number, build with the included .bat file - i.e. the "old style" diskboot way ?

Only a slight chance, but maybe Canon did not change the fw update mechansim on this small SX10 upgrade, only the LED addresses...


*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: SX20 IS firmware dump, I need help!
« Reply #24 on: 12 / September / 2009, 16:43:46 »
Should I try using a bootable card and diskboot.bin or should I create a ps.fi2 file using a separate fi2 encoder? I'm just wondering because there's no code to create a ps.fi2 in your zip.

While reading the thread where you posted your SX10 blinker I did also realize that adding zeros to ps.fi2 can't work since it is compressed and only the size of the uncompressed data inside it is important.

*

Offline fe50

  • ******
  • 3107
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX20 IS firmware dump, I need help!
« Reply #25 on: 12 / September / 2009, 16:54:25 »
Should I try using a bootable card and diskboot.bin or should I create a ps.fi2 file using a separate fi2 encoder? I'm just wondering because there's no code to create a ps.fi2 in your zip.

Yes.
Update the P-ID to 31E4, copy the diskboot.bin to the card, use a small (max. 2GB) SD card, CHDK-bootable, with the lock on.

The SX10 works this way (that's why i said "the old style way"), i did not use the fi2 manual loading, this wasn't necessary on the SX10...

*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: SX20 IS firmware dump, I need help!
« Reply #26 on: 12 / September / 2009, 17:03:39 »
I can only find the P-ID in a comment in Make.bat.

What should happen, if the code is run on the camera?

*

Offline fe50

  • ******
  • 3107
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX20 IS firmware dump, I need help!
« Reply #27 on: 12 / September / 2009, 17:22:16 »
I can only find the P-ID in a comment in Make.bat.

Ahhhrggg - yes, sorry for the confusion, did it in Dec 2008, loooong ago !  :'(

The diskboot method don't check the P-ID number,
only manual loading (with firmware update from the Canon menu) verifies the P-ID and rejects a file with a wrong number.
So for the diskboot test you can ignore the P-ID !

Quote
What should happen, if the code is run on the camera?
Normally all LED's are off, the camera don't react, if the specified address is correct the corresponding LED turn on...after all, the camera crashes, you have to remove the batteries then.


*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: SX20 IS firmware dump, I need help!
« Reply #28 on: 12 / September / 2009, 17:39:15 »
This would mean that I can only see if the code is executed properly, if one of the leds lights up, which can only work if the led address specified in the source code is correct for the camera?

*

Offline fe50

  • ******
  • 3107
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX20 IS firmware dump, I need help!
« Reply #29 on: 12 / September / 2009, 19:36:57 »
This would mean that I can only see if the code is executed properly, if one of the leds lights up, which can only work if the led address specified in the source code is correct for the camera?

Yes, that's correct; it's a simple blinker app.
It just tries to blink out the code from the given start address by switching on & off a LED on the specified address,
it writes to the given IO address (0x46 for switching the LED on, 0x44 for off).
The main loop blinks out the code byte for byte, then the LED will be switched off; the camera crashes after that.

There are some other blinker routines here in the forum, also a kind of 'LED finder' code, somewhere in old DryOS porting threads...

 

Related Topics