SX20 IS firmware dump, I need help!

  • 125 Replies
  • 23680 Views
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #60 on: 16 / September / 2009, 18:47:35 »
    Advertisements
    One other thing I noted with the particular photodiode I was using was this...

    If I had the photodiode against the led it would work for a short while but after a short bit it would stop receiving.  If I moved it 4 to 6 inches away it would continue receiving forever.  Very directionally sensitive.

    Harpo
    Canon Models - SD300, SD780, & SX210

    *

    Offline RaduP

    • *****
    • 856
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #61 on: 16 / September / 2009, 19:17:27 »
    Well, with my tests with the oscilloscope, the signal modulated by the light never shown in the RS232 port..

    *

    Offline RaduP

    • *****
    • 856
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #62 on: 17 / September / 2009, 00:19:44 »
    Ok, the trick was to start the loader program and THEN check with the oscilloscope.
    I have the firmware now :) But I need to clean the beginning test sequences and check and remove the CRCs. Did someone write a program that does that, or do I have to write it myself?

    *

    Offline RaduP

    • *****
    • 856
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #63 on: 17 / September / 2009, 03:07:22 »
    Ok, I got the clean, error free dump.
    There is a dec.c program, but it is broken, so I had to fix it.

    Now, how do I upload it? I don't want to put it on my server, for legal reasons.


    *

    Offline RaduP

    • *****
    • 856
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #64 on: 17 / September / 2009, 03:08:45 »
    I attached the fixed dec.c, so others won't waste their time.

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #65 on: 17 / September / 2009, 08:50:25 »
    Quote
    Now, how do I upload it? I don't want to put it on my server, for legal reasons

    1) use sth like rapidshare (lots of hassles though, like max. 10? DL, popup ads)

    2) make yourself a drop, go to http://drop.io/ (free, 100 MB max per drop)
        (me, i like this: no email required, still works even with Noscript blocking scripts)

    3) forum user mariush has offered to host CHDK stuff:  www.savedonthe.net
        (excellent, completely hasslefree upload)

    wherever you decide to put it, before long it's gonna end up here as well (fe50's archives, also on a drop) http://drop.io/chdkdumps2   :D

    big thumbs up for the work, btw

    wim
    « Last Edit: 17 / September / 2009, 09:07:44 by whim »

    *

    Online reyalp

    • ******
    • 9856
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #66 on: 17 / September / 2009, 16:57:47 »
    Quote
    Now, how do I upload it? I don't want to put it on my server, for legal reasons

    1) use sth like rapidshare (lots of hassles though, like max. 10? DL, popup ads)
    http://www.zshare.net/ has lots of nasty popups, but is otherwise hassle free.
    Don't forget what the H stands for.

    *

    Offline jan

    • *
    • 48
    • PowerShot SX20 IS (100f)
      • cms -db
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #67 on: 23 / September / 2009, 13:50:37 »
    I just had success with a diskboot encoded with the new dancingbits version (3) on my SX20. The green AF led lights up! Now I need to figure out the memory address.


    *

    Offline jan

    • *
    • 48
    • PowerShot SX20 IS (100f)
      • cms -db
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #68 on: 23 / September / 2009, 15:51:28 »
    I've found it! The AF led has the address 0xC02200B6 on the SX20!

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: SX20 IS firmware dump, I need help!
    « Reply #69 on: 23 / September / 2009, 19:13:29 »
    I've found it! The AF led has the address 0xC02200B6 on the SX20!
    Nice...SX10 AF LED +2 ... 0xC02200B8 could be the power lamp/button (orange) addresse...
    (while porting it's much more comfortable having two or more LED's to follow your code...)

    *EDIT:
    See also http://chdk.setepontos.com/index.php/topic,4255.msg40198.html#msg40198 for a new udumper version...
    « Last Edit: 23 / September / 2009, 19:41:07 by fe50 »

     

    Related Topics