350d boot from cf card - page 50 - DSLR Hack development - CHDK Forum supplierdeeply

350d boot from cf card

  • 510 Replies
  • 289544 Views
Re: 350d boot from cf card
« Reply #490 on: 11 / July / 2014, 22:04:41 »
Advertisements
The program that does the boot flag setting ends by going into an endless loop using the C instruction "for ( ; ; )", and as a result you have to remove the battery to turn off the camera.  That's really not a problem, and it should work normally after that.

Can't help you with the other issues.


Re: 350d boot from cf card
« Reply #491 on: 20 / August / 2014, 09:51:57 »
Hi, I'm new here but CHDK on Canon 350D using for several years. I have one question. Is it possible to make CHDK in Czech language? I tried to rewrite the English entry directly in the Czech AUTOEXEC.BIN file, but it worked only partially.

Re: 350d boot from cf card
« Reply #492 on: 22 / September / 2014, 18:58:04 »
Hi all,
To save battery, I would like to set reviewtime to off when shooting en timelapse mode.
I am compiling a new CHDK in order to set that but it doesn't work. 350d doesn't fire automaticaly after first shot, but shoot instantanly when half press the the shutter button.

Here my code:

Code: [Select]
#ifdef POSITION_TLAPSE
void SwitchTimeLapse(int button) {
int i, OldLcdBrightness, OldReviewTime;
switch (button) {
#ifdef USEPLAYFORSET
case BUTTON_PLAY:
#else
case BUTTON_SET:
#endif
for (OldLcdBrightness=cameraMode.LcdBrightness, //save brightness and review time values
OldReviewTime=cameraMode.ReviewTime,
//cameraMode.ReviewTime=0xff, //set review time to hold
cameraMode.ReviewTime=0, //set review time to off
SendToIntercom(0x16,1,1), //set brightness
SendToIntercom(0x53,0,0), //release
i=1; i<TLapseFrames; i++) {
SleepTask(TLapseInterval*1000);  //release
SendToIntercom(0x53,0,0);
}
cameraMode.ReviewTime=OldReviewTime; //restore brightness and review time settings when timelapse sequence is done
SendToIntercom(0x16,1,OldLcdBrightness);
SHORTCUTSIGNAL
break;

case BUTTON_LEFT:
if (TLapseInterval>1) TLapseInterval--;
break;

case BUTTON_RIGHT:
TLapseInterval++;
break;

case BUTTON_MENU:
TLapseFrames *= 2;
break;

case BUTTON_INFO:
if (TLapseFrames>1) TLapseFrames /= 2;
break;

#ifdef USEPLAYFORSET
case BUTTON_SET:
#else
case BUTTON_PLAY:
#endif
TLapseFrames++;
break;

  }
}
#endif

Help welcome!
Thanks

Re: 350d boot from cf card
« Reply #493 on: 04 / January / 2015, 06:49:09 »
Sorry guys,
can anyone point me to the most recent Canon 350D ML hack and perhaps a set of instructions?
The post is pretty big ..so...


Re: 350d boot from cf card
« Reply #494 on: 08 / January / 2015, 19:01:33 »
I think the process is described here:

http://chdk.wikia.com/wiki/350D

*

Offline reyalp

  • ******
  • 12208
Re: 350d boot from cf card
« Reply #495 on: 10 / January / 2015, 14:27:42 »
Sorry guys,
can anyone point me to the most recent Canon 350D ML hack and perhaps a set of instructions?
The post is pretty big ..so...
I would strongly recommend that you read very carefully, since more than one person irrecoverably damaged their camera.

Also note the 350D hack is neither ML nor CHDK.
Don't forget what the H stands for.

Re: 350d boot from cf card
« Reply #496 on: 05 / April / 2015, 13:55:18 »
hi everybody
i'm new to this forum
i've a 350d i've tried to use chdk on it, but i wasn't able to let it boot from the CF
i've read an tried different things (formatting the card, using CardTricks or HxD on it) on different cards (250MB, 2GB,4GB)
nothing seems to work.
someone can help me pointing me to the right procedure?
i'd like to do some timelapse
thanks

Re: 350d boot from cf card
« Reply #497 on: 20 / May / 2015, 16:10:43 »
I'm a little late to the party (6 years late to be exact) but I hope I will still find someone who knows anything about this firmware...

I have just tried to install it on a 350D, firmware 1.0.3 that was modified for full-spectrum and that I'm using for astrophoto with the hope that I can use its intervalometer.

I failed to have the firmware installed. No, the camera isn't bricked, it works just as well as before, but the firmware hack didn't "catch"

Here's what happens:

1. I have a CF card (an old one, 64MB "MrFlash" brand that I've been using for other firmware updates etc)  that was freshly formatted to FAT16, blank otherwise, added to its root bootflg2.fir from post #342 on this thread.

2. Inserted the card into the 350D, went to the firmware menu, verified once more that I have 1.0.3, pressed "set" then selected OK to upgrade firmware

3. camera went on to display "CF card containing firmware is required to update" as expected

4. blue light flashes briefly. All good.

5. blue light flashes briefly. All good.

6 Nothing happens for a very, very long time. No LEDs are on.

7. After waiting for about 10 minutes, still nothing happens. Turned camera off, took battery out then back in, turn camera on. All works well. Firmware still shows 1.0.3, not sure if it should have changed or not...

8. Tried to boot from a card that I had previously made bootable with a hex editor, and has autoexec.bin on it. Camera displays "CF Err" on small LCD. Tried another random CF card, works well. Info menu doesn't have anything new.

9. Restarted process at 2, attempted 2 more times to have the firmware flashed (formatting the CF card each time and re-writing bootflg2.fir to it each time. The exact same thing happens.

10. Attempted the process again using the original scanled.fir from 2009 instead. This time, the blue LED flashes briefly, then the red LED briefly, then again nothing happens with the camera displaying "CF card containing firmware is required to update" for a long time with no LEDs on. Turn camera off, remove and reinsert battery, turn camera on, everything works, nothing is changed.

So it seems that toggling the boot flag on this camera fails. Any suggestions? Thanks in advance.


Re: 350d boot from cf card
« Reply #498 on: 20 / May / 2015, 17:12:15 »
I would stop fiddling with the bootflag: once it has been set, there is no need to touch it any longer, even if you want to upgrade the hack. From the message you are seeing, I would bet you are not preparing the cards properly; format them again, and be sure to edit the right bytes.

Hope this helps.

Re: 350d boot from cf card
« Reply #499 on: 20 / May / 2015, 19:16:03 »
Thanks for the reply, but I don't think this is it. The bootflag process clearly starts (thus the file is recognized, loaded and executed) but never completes as I never see the completion of the correct LED sequence. I have since tried another card, a 256MB CF that I did first a low-level format on, then formatted FAT16, edited the boot sector in the correct location (at 0x2B "EOS_DEVELOP"
at 0x40 "BOOTDISK")  and placed autoexec.bin on. It doesn't boot.
« Last Edit: 20 / May / 2015, 19:18:30 by stamasd »

 

Related Topics