supplierdeeply

350d boot from cf card

  • 510 Replies
  • 212687 Views
Re: 350d boot from cf card
« Reply #450 on: 27 / November / 2012, 11:23:01 »
Advertisements
I have not really tested that code except for one daytime 400-shot lapse (that worked fine), camera was set to a shot every 10 seconds.
I know that there are problems when you set a too short time between shots. 5 sec (in your case) should be fine, but maybe you want to try again with a few seconds more, just to see if something changes?

Re: 350d boot from cf card
« Reply #451 on: 10 / December / 2012, 09:14:23 »
Hi, I have been trying the features of the last version and I don't have problems at all.
And now my question, is there a way to make HDR time lapses?
If I activate bracketing and I do a time lapse the camera takes only one shoot at a time, but with different apertures each time.
This feature would be great.
Thanks for your help and work.

Re: 350d boot from cf card
« Reply #452 on: 18 / December / 2012, 14:30:04 »
I was trying to install custom firmware for my d350 this happened
everything seemed to went well, but after restarting my camera it would not power on. I pressed shutter release and it powered on but I could not get into menus, take pictures or power down.

http://www.youtube.com/watch?v=Xa4R-noKsnQ#ws


7. Insert CF in the camera. If the camera is booting from the card the Blue LED will flash.

my camera wont show any colors when i insert the card

Re: 350d boot from cf card
« Reply #453 on: 18 / December / 2012, 16:23:35 »
what happens is you start the cam without a card in it?


*

Offline RayeR

  • *
  • 18
    • RayeR's homepage
Re: 350d boot from cf card
« Reply #454 on: 26 / December / 2012, 16:10:41 »
Hi, I'm still using 350D but planning update to 550 or 600D next year.
Anyway thanks for CHDK update. I just went back to this forum to read what's new and found there's update by zestoi (16.9.2012) so I just checked it out. When I was playing with time lapse (main reason I use CHDK) I found some unstable behavior. Sometimes after finish the shoot sequence I was unable to go back to menu - display remained off and I cannot activate it by menu/shutter on/off etc. On small LCD was displayed "busy" all the time. Only open/close battery door helped. In other case I ended with "CF full" warning despite that I took only few shots. Again only way to reset is was battery open/close. I tried to note some exact step-by-step test case but unfortunatelly this didn't happened again (as usual when you're trying to catch a random bug, agrh!).
I can see that cobarcore also reported hanged camera during timelapse. What about other users?
I think that I din't have this issues with previos version (6.8.2011, AUTOEXEC.BIN - 14824B).

BTW is there known some function for drawing a pixel or color rectangle over screen?

Another comment is about using big CF cards in 350D: I have tried 16GB CF with FAT32 and it works at full capacity but you have to format in PC not in camera. If you format it in camera you ended with only 8GB and rest will be useless. Then you have to format in PC again. Another stupid bug by Canon. I readed that they fixed it in some firmware updates but they don't care about such old cams like 350D.
« Last Edit: 26 / December / 2012, 16:18:17 by RayeR »
Canon EOS 350D, PowerShot A95

Cameras bricked
« Reply #455 on: 23 / January / 2013, 12:21:26 »
Just how many cameras got bricked, after trying to set the boot flag to 1?
I just got a used 350d, but cannot afford yet another camera if things go south. So i was wondering how many bricked their camera, while having firmware version 1.0.3, as opposed to how many did not?
Don't be fooled, i did read through the entire topic before asking, and i know there were a couple of ppl that had 1.0.2 firmware, and at least 1 guy who had 1.0.3, but i wonder if i forget anything. Don't feel 100% ready to do this yet. Also i want to apply the hack only for the shutter count.
One more thing maybe someone can verify this, i am curious. I know u can't get shutter actuations from 350d reading exif info, but, i was wondering if someone can check this.
I read that the shutter count is stored in the file. Just open a RAW file in a hex editor and search for the string "00 00 00 00 00 00 00 FF FF FF FF". The shutter count is right in front of this hex string, in hex format of course. Can someone that has applied the hack confirm this ?
After all this is what i am after, i am just starting photography.

Re: 350d boot from cf card
« Reply #456 on: 22 / March / 2013, 15:20:21 »
Hi all,

thanks for this hack. I just wanted to give a short summary how to install it on bigger cf cards without complex editing with Hex-editors. In this thread there is this Link but i had some problems doing it and maybe this short summary helps other people in future.

First check your Firmware is 1.0.3

then i copied scanled.fir to the card, started the Firmware update, waited about one minute while the blue led was lit, turned off (the message "CF card containing firmware is required to update" did not disappear from display after turning off), took out the main battery for a little time and inserted it again.


After that i wanted to make my card bootable. I have a 8GB card in FAT32. In the link mentioned above you find the tool EOScard. You can use this, just check the marks EOS_DEVELOP and BOOTDISK and then press save. Actually then this tool installs Magic Lantern, but thats not a problem. When thats finished browse your cf with the explorer and remove all Magic Lantern files. Then copy one of the autoexec.bin files you find in this thread and you are done.

I will try all the functions now. I am looking forward to doing a timelapse of a sunset :D
« Last Edit: 27 / March / 2013, 17:01:53 by marc109 »

Re: 350d boot from cf card
« Reply #457 on: 03 / May / 2013, 15:50:57 »
Hi!

Does anybody know if the scripting language works on 350d?
see http://chdk.wikia.com/wiki/Canon_Basic
I wonder how to start the execution as the 350d does not have a func/set button.

regards


Re: 350d boot from cf card
« Reply #458 on: 03 / May / 2013, 16:15:47 »
And one more thing: Does anybody know where (if available) to find the debug port?

I think TX is the testpin i painted red .
Not yet tested to connect an uart, but looks like 115kbaud on my scope.

Any idea where RX is?

regards,

Re: 350d boot from cf card
« Reply #459 on: 04 / May / 2013, 09:21:44 »
Hi!

Okay i figured out the serial connection. See the attached image.
There is something called ICU Terminal. When i enter help it shows the commandlist attached to this post.

regards

 

Related Topics