SD1200 IS Porting Thread - page 12 - DryOS Development - CHDK Forum supplierdeeply

SD1200 IS Porting Thread

  • 312 Replies
  • 154854 Views
*

Offline tillo

  • *
  • 43
Re: SD1200 IS Porting Thread
« Reply #110 on: 10 / June / 2010, 19:09:33 »
Advertisements
hi guys, do you know how does the macro shooting works? it gives me DOF i am almost sure it does that by moving the focusing lens which may be totally useless for actual DOF pictures but if it is applicable to non macro shootings we should try that.
I don't really know how macro works in this camera so I don't know if it is applicable I gess its not because it may be only done by focusing (I hope I'm wrong) but if someone knows then let us know.

Re: SD1200 IS Porting Thread
« Reply #111 on: 15 / June / 2010, 18:01:52 »
@Yossar
Wow!  I'm amazed you got the thing working with the main trunk!  Have you been able to locate the menu issue?

Wonder if its listed in the trunk yet *goes to check*

Re: SD1200 IS Porting Thread
« Reply #112 on: 16 / June / 2010, 06:09:42 »
I think I solved the menu issue. In lib.c, function vid_get_bitmap_screen_width should return 720. Menu is now displayed over whole screen. It still looks somewhat strange to me, but it could be a font issue.

Anyway, I've been trying to solve the broken flash problem, but without success so far.
Here's what I found:

  - freeze occurs in capt_seq.c in function sub_FFC4A3B8_my. Program never returns from call  "BL      sub_FFCFC540_my"

  - when I replace call to function "sub_FFC4A3B8_my" with call to original function, the freeze does not occur
  - when I replace call to "sub_FFCFC540_my" with call to original function, and remove the call to "capt_seq_hook_raw_here", camera freezes on flash use. This is strange because there should not be any difference between two code segments.

  - upon inspecting the function "sub_FFCFC540_my", I find that the code in it executes fine, so the freeze is probably located in firmware code, after branch to "B       sub_FFCFC5EC"

I think I'm running out of ideas on this. I will try to copy the remaining code to "sub_FFCFC540_my" and see if it locks there, but it's a long shot.

Re: SD1200 IS Porting Thread
« Reply #113 on: 19 / June / 2010, 12:12:37 »
am i right in thinking that this thing is almost working now then?

How do you try out the latest firmware?


Re: SD1200 IS Porting Thread
« Reply #114 on: 25 / June / 2010, 16:19:32 »
@jiggling_john far from it, you can do scripts but that is about it. Yossar has made the most progress since the porting started and stopped last year. With any luck the SD1200 may have been added to the trunk already and the porting can continue with conformity with the rest of CHDK

I wonder if the CHDK PTP http://chdk.setepontos.com/index.php/topic,4338.0.html interface can help?  It probably needs a lot of work to add to a camera but I wonder if it could help you in debugging it.  There are three features that might be useful to you, Memory inspection and manipulation, Remote function calling, Retrieval of properties and parameter data

:P otherwise there are other features that are close but still not working such as the USB remote and it would be nice if the function to turn off the screen in the LUA script (for time lapse power save) would be neat.  But either way im glad you're still working on it
« Last Edit: 26 / June / 2010, 16:02:07 by awdark »

Re: SD1200 IS Porting Thread
« Reply #115 on: 28 / June / 2010, 10:11:54 »
Here's the latest build, if anyone wants to test it.

Note that there is no new functionality (flash still broken, no usb support...).


Re: SD1200 IS Porting Thread
« Reply #116 on: 29 / June / 2010, 18:56:40 »
Flash bug is fixed, finally. Problem was in incorrect function call in capt_seq.c

Also, noise reduction override should work now, although I don't know where to turn it on.

I'm attaching the latest version for testing. Please report if you notice anything odd.

Re: SD1200 IS Porting Thread
« Reply #117 on: 29 / June / 2010, 22:53:44 »
The font on this is small but readable. 

How would one use the flash feature?  I attempted to change the manual setting to adjust power level, but it doesn't seem to change it.


Re: SD1200 IS Porting Thread
« Reply #118 on: 30 / June / 2010, 02:43:22 »
The font on this is small but readable. 

How would one use the flash feature?  I attempted to change the manual setting to adjust power level, but it doesn't seem to change it.

We could probably make the font larger by lowering the resolution and changing the aspect ratio, but I would rather leave it like this.

I haven't tried manual flash settings, I'll look into it.


Re: SD1200 IS Porting Thread
« Reply #119 on: 30 / June / 2010, 15:35:15 »
Oh its okay, I was just wondering if fixing the flash added any functionality.  But it looks like the flash functions fine now and that is far better than a bug that causes the camera to freeze up.

Do you think repairing the USB remote function would be a difficult task? 

Either way *thumbs up* it's awesome that we finally have someone who can seriously work on this camera!

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal