SD1200 IS Porting Thread - page 5 - DryOS Development - CHDK Forum supplierdeeply

SD1200 IS Porting Thread

  • 312 Replies
  • 109220 Views
Re: SD1200 IS Porting Thread
« Reply #40 on: 12 / February / 2010, 21:42:54 »
Advertisements
I think some apps treat it as a TIFF because DNG4PS2 appears to embed the full sized jpg into it as a "thumbnail" I used a command line raw utility and ended up extracting a 2mb JPG from the DNG so... the DNG produced by DNG2ps2 is a bit.. illogical?

You can actually do quite a bit with the stock firmware.  For example in the P mode, you can go for long exposure mode which will let you take a picture from 1 second up to 15 second.  It appears that CHDK manages to take pictures up to 64 seconds so 1-15sec stock 1/1000-64second with CHDK LUA.  So mount it on a tripod, set the ISO80, consider using a 2second timer then go for night shots.  

You can also change the exposure with the stock firmware.  In P mode, press up and you can change the exposure from -2ev to +2ev which will give you a little control over the exposure.  If you were to use the shutter speed script supplied by CHDK, you will be able to control the shutter speed but without an exposure meter its hard to guess the correct values to use.  This is as close to manual mode as we can get because the camera has a fixed iris (ranging from 2.8-3.9?) so the aperture only changes with the focal length and the only value we can really control is the shutter speed.

The captured RAW files allow you to tweak the images a bit more, you can change the exposure, have better control over the white balance, do highlight recovery, increase blacks or saturation, use fill light.  It can help fine tune an image but it wont do any miracles.  Currently the raw files captured by the camera aren't very good, in fact it appears that every other raw file produced is ruined possibly due to an unflushed buffer.  Ideally, we will one day be able to take pictures and have the camera save the files directly in DNG format where it will be more useful.  Unfortunately right now all we can really do is wait for KevB to return or wait for someone else to take over.
« Last Edit: 13 / February / 2010, 21:12:31 by awdark »

Re: SD1200 IS Porting Thread
« Reply #41 on: 13 / February / 2010, 20:24:58 »
If the raw+jpg file helps at all IMG_0760.zip - 15.84MB
I really think DNG4PS will work if we get the right settings because RawTherapee can display the image, F-Spot, and DCraw can recognize the file.  Of course those viewers are designed to look for things in the file, I guess the same way some movie players can play parts of a downloaded video without the headers.


Puahahaha
Sensor Size: 3720 x 2772
JPEG Size: 3648 x 2736 3684 x 2760
Active Zone x1, y1: 6, 12 0, 0
Active Zone x2, y2: 3690, 2736 3720, 2772
Black-White levels: 127 - 4095
Mosaic Type: Red, Green Green, Blue
Bits Per Unit: 12 bit
Active Zones if you paste the JPG onto the DNG you will notice the image shifts, we have 36 x 12 to adjust for this JPG is offset.  I came up with a offset of -12, 6 shift by moving the stacked images. Think we just need to mess with the active zones to make the jpg match with the raw.

Keep your default matrix, I grabbed this randomly from the SD880 profile after I accidentally overwrote my matrix.
Matrix: 0.759444 -0.270106 -0.111462 -0.005098 0.519067 0.041750 0.023861 0.044290 0.212756
Multiplicator: 0.0 0.0 0.0


Be sure to select SD1200 under camera type 3720x 2772 so DNG4PS will know what to use if you don't have the JPG files to go with it.

Edit:
DNG4PS is definitely working, DNG files can be created from just the raw file so I know it isn't a full sized embedded thumbnail.

Edit:
Used the source to build a PS.FI2 file, changed the values in camera_features.h to reflect the values used in DNG4PS.  Now the viewable DNG images created are purple, I believe I tried values for RGGB and GBRG and both produce the purple images.  Must be doing something wrong.  There are still a ton of corrupted raw files and Photoshop does not recognize the files which is very discouraging.  

Did searching and found this http://chdk.setepontos.com/index.php/topic,2187.msg29529.html#msg29529 states sometimes raws are stored in different raw addresses so the raw feature needs more work but might be something to look for.
« Last Edit: 14 / February / 2010, 00:24:23 by awdark »

*

Offline tillo

  • *
  • 43
Re: SD1200 IS Porting Thread
« Reply #42 on: 14 / February / 2010, 15:45:43 »
wzp guys, how do you use minimalistic script i've been changing numbers and the time doesn't seem to change h/e thanks for the tip on the scripts, i didn't knew they worked.

Re: SD1200 IS Porting Thread
« Reply #43 on: 14 / February / 2010, 16:27:59 »
I copied the text then saved it as a minitl.lua in the folder with the other scripts.

In alt mode, hit the Set button to bring up the script options, navigate to the script of choice, click set, then adjust the options.  Then while still in Alt mode, press the shutter (shutter starts the script) it should start taking pictures.  When you're done press the shutter again to stop the script.

How do we find out if this camera supports the extended shutter times?  From what I read, it sounds like extended shutters (beyond 64 seconds) would need a camera that supports the extended shutter and the CHDK to have a certain flag enabled for those extreme overrides, I currently can't find the topic on it.   

I wonder if its possible to merge KevB's code with the official CHDK SVN server?  Well, I KNOW it can be merged, I know camera.h was changed and the folder for IXUS 95 SD1200 was added.  So its all good just not sure if its OK in terms of use of code etc.  I don't see any reason why it shouldn't be added to the official server, a lot of the functionality is there already and I would say its at least in the alpha or beta stage... guess alpha because functionality was being added.
« Last Edit: 04 / March / 2010, 02:50:32 by awdark »


Re: SD1200 IS Porting Thread
« Reply #44 on: 04 / March / 2010, 07:31:03 »
Hi! When it will be ready chdk? And whether it is possible to add management of a shutter and breaketing?

Re: SD1200 IS Porting Thread
« Reply #45 on: 05 / March / 2010, 10:04:58 »
Hi guys,

I believe that I found the second image buffer and the flag that controls the switch.
I worked with KevB's code and this is what you need to change in \platform\ixus95_sd1200\sub\100c\lib.c


char *hook_raw_image_addr()
{
   return (char*) (*(int*)(0x2890) ? 0x424B358C : 0x40F30D7C);
}

So, the second buffer is at 0x424B358C and flag is 0x2884 + 0xC.

I hope this helps...

Re: SD1200 IS Porting Thread
« Reply #46 on: 06 / March / 2010, 02:32:57 »
Amazing!  I changed it and the RAW files are saving fine now!

I should go see if the badpixel.lua script runs better after that bug was fixed.  :)

Hmm I should mention it looks like the raw>DNG conversion is still a little off, adjusting the white balance doesn't seem to work on all levels instead only parts are responding to it.  So its possible to give someone blue hair through the white balance slider.   :lol  I think its possible the values for the color calibration or settings are just off.  It definitely needs work and all the pictures come out extra grainy

If anyone wants to go searching I did a search for DNG and found
\platform\ixus95_sd1200\sub\100c\stubs_min.S
has two lines that are 0xDEAD and are for "some_f_for_dng" and "second_ext_for_dng" so I guess that might be why DNG support doesn't work.  I used the values for DNG4PS on the camera and I can only get a strangely colored 14mb thumbnail.

Edit:  Do you mind sharing how you found the value?  I tried to look through the files and I assume its a complex process, I looked at the wiki and hoped the disassembly process was complete so values just needed to be transferred into the code.
« Last Edit: 18 / March / 2010, 04:30:45 by awdark »

Re: SD1200 IS Porting Thread
« Reply #47 on: 15 / March / 2010, 03:05:26 »
All of this sounds very promising and exciting.


*

Offline tillo

  • *
  • 43
Re: SD1200 IS Porting Thread
« Reply #48 on: 18 / March / 2010, 11:36:20 »
Hi guys, i've been off for a while now, but here I am asking more stuff to go further on my "investigation".
the problem on my script was not running it, what i intend to do with it is to change the shutter speed or exposure time, but it seems pictures are been taken in 2s max, i wish to take a picture with shutter open for 30s or more, i've changed numbers and variables in the script but nothing seems to change on the picture itself, thanks for your replys.
edit: i forgot to say that the camera seems to stop working (as if the picture was still been taken) but the image proves that there has been no difference, if I move my hand infront of the camera there should appear a blur, it doesnt seems to apear by now.
« Last Edit: 18 / March / 2010, 11:39:37 by tillo »

*

Offline tillo

  • *
  • 43
Re: SD1200 IS Porting Thread
« Reply #49 on: 18 / March / 2010, 13:24:01 »
i've been checking a lot of stuff and using different exposure scripts, none of them seem to work but i will try to use them all.

 

Related Topics