SD980 beta release - page 18 - CHDK Releases - CHDK Forum  

SD980 beta release

  • 376 Replies
  • 151219 Views
Re: SD980 beta release
« Reply #170 on: 11 / June / 2011, 11:02:40 »
Advertisements
First off all, i appreciate the effort! Shame i have no programming knowledge whatsoever to help more in htat regard :(

I used cardtricks on a 512mb card, formatted it, made it bootable and used the chdk -> card part, locked it, inserted into camera and pressed play.

Just got a No Image, Card Locked notice, nothing else happens unfortunately.

Added LED code to the  Loader code - it doesn't get much more basic than this.  Hopefully we can get a couple of people to try it and report results here.

SD980 TEST3 Download File

« Last Edit: 11 / June / 2011, 11:05:08 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline james

  • *
  • 10
Re: SD980 beta release
« Reply #171 on: 11 / June / 2011, 11:42:03 »
Is this now ready for use with sd980 v. 1.01c ?

I load it (format card - make bootable aso.) but - shitt happens - nothing.

I think the camera only works with ps.fi2 and is not able to start in automodus with diskboot.bin ?!?

Re: SD980 beta release
« Reply #172 on: 11 / June / 2011, 12:07:28 »
Is this now ready for use with sd980 v. 1.01c ?
Supposed to be. Just trying to help out here - I don't have the camera so there is only so much I can do.

Quote
I load it (format card - make bootable aso.) but - shitt happens - nothing.
Do any of the LED's come on - especially the AF LED on the front of the camera ?  Are you starting the camera by pressing the Play button pn the back ?  I think I read somewhere that you might need to do that rather than pressing the on/off button on top.

Quote
I think the camera only works with ps.fi2 and is not able to start in automodus with diskboot.bin ?!?
Diskboot.bin works for the 1.00c firmware.   Seems unlikely it doesn't work for the 1.01c.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline james

  • *
  • 10
Re: SD980 beta release
« Reply #173 on: 11 / June / 2011, 12:21:46 »
I pressed the Play button and the power on. It will be the same. Is thomething wrong because the cam has a touch screen?


Re: SD980 beta release
« Reply #174 on: 11 / June / 2011, 12:27:54 »
I pressed the Play button and the power on. It will be the same. Is thomething wrong because the cam has a touch screen?
I guess I stuck unless somebody else can get it to boot.  The camera should work - there is a working port for firmware 1.00c
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline titbb

  • *
  • 38
Re: SD980 beta release
« Reply #175 on: 11 / June / 2011, 14:24:09 »
Well,

since there aren't many leds on the camera it shouldn't be hard to see if it works or not.

i reformatted and made the card bootable, just to be sure, but the only thing i get is just 3 green flashes, but they always come when the play button is pressed at poweroff.

so, im afraid to say it doesn't work also :((

Re: SD980 beta release
« Reply #176 on: 11 / June / 2011, 15:12:58 »
so, im afraid to say it doesn't work also :((

As a test,  I cut and pasted the code I added to the SD980 loader and boot.c files into the SD940 camera files (I have one of those).  The resulting LED pattern is really slow and obvious - you could not possibly miss it if it runs.

The SD980 boot loader code and LED addresses are identical to the SD940 so I tried booting that DISKBOOT.BIN file.  Nothing happened - just like everyone here has reported.  Strange - I should have at least seen the boot LED pattern.

Time to dig a little deeper I guess.

Update :  I took the SD980 boot source code and used it as a the boot source code for the SD940.  Works fine for the SD940. Somewhere I have address wrong in the build files I'm thinking. 
« Last Edit: 11 / June / 2011, 15:16:52 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD980 beta release
« Reply #177 on: 11 / June / 2011, 15:58:25 »


OK, i'm back. haven't had time to do another 8G dump, but looks like it's not necessary?

@waterwingz, just d'loaded the 0.9.9TEST3 version, will load and test now.  it looks like i'm looking for led flashes if chdk doesn't run?



Re: SD980 beta release
« Reply #178 on: 11 / June / 2011, 17:47:01 »
Progress !   Not being able to boot at all does not make any sense.   So with a little digging I noticed an underscore ( _ ) character in front of NEED_ENCODED_DISKBOOT in makefile.inc.   That would pretty much explain everything right there.   So here's a rebuild - see if this flys now ?

  IXUS200-SD980 Test Version 4


Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline titbb

  • *
  • 38
Re: SD980 beta release
« Reply #179 on: 11 / June / 2011, 17:59:44 »
Its a [admin: avoid swearing please], 1 little thing wrong and the whole doesn't work!

Progress now though! Blinking leds! Front AND back, when it stops and when pressed function key i get the CHDK logo!

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal