the sx20 porting thread - page 103 - General Discussion and Assistance - CHDK Forum

the sx20 porting thread

  • 1279 Replies
  • 358068 Views
Re: the sx20 porting thread
« Reply #1020 on: 08 / January / 2011, 05:35:33 »
Advertisements
it would need to be pretty quick (like shooting in the 1/200 range).  Am I dreaming

Yes, unfortunately.

With SDM, we can take a photo 20 msec after an event (such as remote button release).
That is with the capture sequence at the screen-blanked stage, so no use for motion detection.

With the MD script, the reaction time is about 60 msec (1/16 sec).

*

Offline ultimA

  • ***
  • 137
Re: the sx20 porting thread
« Reply #1021 on: 08 / January / 2011, 21:01:46 »
Hi all,

I have been playing around with the md_demo1.bas script from sx20-102b-0.9.9-959-full.zip and I have never been able to get the camera to trigger properly.  If I move my hands in front of the camera, the boxes on the LCD trigger right away, but the camera doesn't fire for like 20 seconds. 

Has anyone been able to get this to work on the sx20?  I upgraded to the current sx20-102b-0.9.9-1030-full build. but no dice.

I'm hoping to use it as a motion trigger for an SLR and strobe setup firing over a PocketWizard radio, but it would need to be pretty quick (like shooting in the 1/200 range).  Am I dreaming or this really possible?

Thanks very much for your help!

Not all MD scripts work on all cameras. Try another one, and one will definitely work. I know cause I've also found one that works some weeks before. Sry but I don't know which one it was.

*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: the sx20 porting thread
« Reply #1022 on: 09 / January / 2011, 12:09:01 »
...been playing around with the md_demo1.bas script from sx20-102b-0.9.9-959-full.zip and I have never been able to get the camera to trigger properly.
Not all MD scripts work on all cameras. Try another one, and one will definitely work. I know cause I've also found one that works some weeks before. Sry but I don't know which one it was.
Here are a few that work  on the SX20:
From the CHDK "UBASIC/Scripts" page under "User-written Scripts" http://chdk.wikia.com/wiki/UBASIC/Scripts
- Fast Motion detection (MDFB-080914 by fudgey)
- Multipurpose Motion Detection (Uses Fingalo's firmware) http://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection

And this one by @fudgey I modified to work on my SX20
- Motion detect surveillance camera "mdCCTV"
  http://chdk.setepontos.com/index.php?topic=1596.msg55688#msg55688

Re: the sx20 porting thread
« Reply #1023 on: 09 / January / 2011, 18:03:11 »
 ;)   You can take amazing pictures with CHDK + Script motion detection, as this lightning shot on August 18, 2010 during a storm.

To view =  http://www.megaupload.com/?d=611WO797

Regards NEZtron
Canon SX20 is 1.02b CHDK


Re: the sx20 porting thread
« Reply #1024 on: 10 / January / 2011, 05:15:07 »
Thanks for all the responses on the motion detection issue.  I'm digging through the referenced scripts and I think I should be ok from here.

Cheers!

Re: the sx20 porting thread
« Reply #1025 on: 15 / January / 2011, 13:40:59 »
Hi bdasmith!
In the past two days I have seen similar random shutdowns on my camera (1.02d) too, though it happens randomly during initialization and does not depend on pressing a button. This was surprising to me, as I have never ever seen this happening before. So I was thinking about what has/could have changed. One of the possibilities that popped into my mind was cold. In these days I have been using my camera mainly outside and it is freezing and snowing here. So after making up this theory, I did notice that the crashes do not occure after staying inside a building for a longer period of time. Can you remember/confirm where you were using your camera when the crashes happened? Was it outside and was it cold there? Though it would still be strange, since without CHDK there are absolutely no crashes.

The problem about the orientation metadata has been discussed and confirmed before, even on the german forum and by myself too. It sure is annoying, but not annoying enough for me to put it into a visible place on my priority list. Sry. Has anybody seen these symptoms on another camera with the orientation sensor?

Same problem here. SX20, 2 different card,one 16gb the other 8gb. 2 partitions on each. I didn't had that problem one month ago but since I d/l the version 1023, I have had that random problem everyday. Very annoying. Is there a place where I could re-download an older version like pre 1000? It would probably cure that pesky problem.
SX20 1.02d

*

Offline reyalp

  • ******
  • 13440
Re: the sx20 porting thread
« Reply #1026 on: 15 / January / 2011, 15:12:48 »
Is there a place where I could re-download an older version like pre 1000? It would probably cure that pesky problem.
You can build any version you want from SVN, chdkshell can help you do this: http://chdk.setepontos.com/index.php?topic=845.0
Don't forget what the H stands for.

*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: the sx20 porting thread
« Reply #1027 on: 15 / January / 2011, 22:23:17 »
...I didn't had that problem one month ago but since I d/l the version 1023, I have had that random problem everyday. Very annoying. Is there a place where I could re-download an older version like pre 1000?
@wowsers51  

Here are two versions on Megaupload that can still be downloaded:

File name: sx20-102d-0.9.9-000-full.zip  File description: based on revision 926 +new-edge-v5.diff from ultimA +zebra fix for sx20 +Games,...  File size: 543.1 KB    http://www.megaupload.com/?d=1IZ4HMWZ

File name: sx20-102d-0.9.9-000-full.zip   File description: based on revision 938 swap up to four partitions (FW1.02d)  File size: 543.93 KB  http://www.megaupload.com/?d=KYWCEL3M

I'm not sure what the "based on" means, so no guarantees. Good luck!

@NEZtron also had problems with the newer build versions on a SX20 fw 1.02b and obviously you are seeing the same thing with fw 1.02d, so it might be something "in common" with the builds.
« Last Edit: 15 / January / 2011, 22:46:31 by SkyWalker9 »


*

Offline ultimA

  • ***
  • 137
Re: the sx20 porting thread
« Reply #1028 on: 16 / January / 2011, 14:31:40 »

*

Offline reyalp

  • ******
  • 13440
Re: the sx20 porting thread
« Reply #1029 on: 16 / January / 2011, 14:39:03 »
http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29 may be helpful.

It is most useful if you have the main.dump that corresponds the build that crashed.
Don't forget what the H stands for.

 

Related Topics